mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-16 11:55:27 -05:00
b7a0935420
* gnu/packages/gnuzilla.scm (mozilla-compare-locales) (all-mozilla-locales, %icecat-version, %icecat-build-id): Update. (icecat-source): Update upstream source hash. Update to latest gnuzilla commit. Remove the hack that provided 'rename' as 'prename'; set RENAME_CMD environment variable instead. Add python to PATH. Set PYTHONPATH appropriately. Adapt substitutions for the reorganized 'makeicecat' script. Run 'makeicecat' outside of the IceCat source directory. (icecat)[inputs]: Add cairo, font-dejavu, libpng-apng, libvpx, pciutils, hunspell, libnotify, sqlite, and zlib. Update icu4c to version 69. [native-inputs]: Update rust and cargo to 1.51. Update rust-cbindgen to 0.19. Update llvm and clang to 11. Add m4. Remove autoconf. [description]: Update embedded version number to 91. [arguments]: Remove "#:out-of-source? #t". Add "#:validate-runpath? #f". In configure-flags, add "--enable-application=browser", "--enable-rust-simd", "--enable-release", "--enable-optimize", "--enable-strip", "--disable-elf-hack", "--with-system-png", and "--with-system-zlib". Adjust the set of modules. Remove the 'link-libxul-with-libraries' and 'bootstrap' phases. Remove the sandbox whitelist population code from the 'fix-ffmpeg-runtime-linker' phase. Add a new 'build-sandbox-whitelist' phase. The new whitelist code now adds <font-dejavu>/share/fonts to the whitelist, and also the runpaths of all libraries in the 'mesa' package. Update the 'configure' phase to use clang-11 and llvm-11 for compilation (previously we used gcc), to create a 'mozconfig' file and run './mach configure' (previously we passed flags to './configure'). Update the 'build' and 'install' phases to use './mach'. Update and simplify the 'neutralise-store-references' phase. Move the 'install-desktop-entry' phase to happen after 'wrap-program', whereas previously it was run after 'configure'. In the 'wrap-program' phase, add libpng-apng and libnotify to LD_LIBRARY_PATH. (mozilla-78-compare-locales, all-mozilla-78-locales, %icecat-78-version) (icecat-78-source): New variables, containing the previous values of mozilla-compare-locales, all-mozilla-locales, %icecat-version, and icecat-source, respectively. (icedove)[source]: Use 'icecat-78-source'. * gnu/packages/patches/icecat-makeicecat.patch: Adapt to the reorganized 'makeicecat' script. * gnu/packages/patches/icecat-78-makeicecat.patch: New file, containing previous contents of icecat-makeicecat.patch. * gnu/local.mk: Add icecat-78-makeicecat.patch.
110 lines
4.2 KiB
Diff
110 lines
4.2 KiB
Diff
Make some of the changes needed to the 'makeicecat' script, to allow it to run
|
|
in a snippet without network access. After this patch is applied, some
|
|
additional changes will be made using 'substitute*'.
|
|
|
|
diff --git a/makeicecat b/makeicecat
|
|
index 8be2362..48716f2 100755
|
|
--- a/makeicecat
|
|
+++ b/makeicecat
|
|
@@ -31,55 +31,55 @@ SOURCEDIR=icecat-$FFVERSION
|
|
|
|
DATA="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )"/data
|
|
|
|
-mkdir -p output
|
|
-cd output
|
|
+# mkdir -p output
|
|
+# cd output
|
|
|
|
###############################################################################
|
|
# Retrieve FF source code
|
|
###############################################################################
|
|
|
|
-rm mozilla-esr${FFMAJOR} $SOURCEDIR -rf
|
|
-
|
|
-wget -N https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${FFVERSION}esr/source/firefox-${FFVERSION}esr.source.tar.xz
|
|
-wget -N https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${FFVERSION}esr/source/firefox-${FFVERSION}esr.source.tar.xz.asc
|
|
-gpg --recv-keys --keyserver keyserver.ubuntu.com 14F26682D0916CDD81E37B6D61B7B526D98F0353
|
|
-gpg --verify firefox-${FFVERSION}esr.source.tar.xz.asc
|
|
-echo -n 1aa041db28cd742e93d663a9da8defd33040b38d8b9470350538473251621643 firefox-${FFVERSION}esr.source.tar.xz |sha256sum -c -
|
|
-
|
|
-echo Extracting Firefox tarball
|
|
-tar -xf firefox-${FFVERSION}esr.source.tar.xz
|
|
-
|
|
-mv firefox-${FFVERSION} $SOURCEDIR
|
|
+# rm mozilla-esr${FFMAJOR} $SOURCEDIR -rf
|
|
+#
|
|
+# wget -N https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${FFVERSION}esr/source/firefox-${FFVERSION}esr.source.tar.xz
|
|
+# wget -N https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${FFVERSION}esr/source/firefox-${FFVERSION}esr.source.tar.xz.asc
|
|
+# gpg --recv-keys --keyserver keyserver.ubuntu.com 14F26682D0916CDD81E37B6D61B7B526D98F0353
|
|
+# gpg --verify firefox-${FFVERSION}esr.source.tar.xz.asc
|
|
+# echo -n 1aa041db28cd742e93d663a9da8defd33040b38d8b9470350538473251621643 firefox-${FFVERSION}esr.source.tar.xz |sha256sum -c -
|
|
+#
|
|
+# echo Extracting Firefox tarball
|
|
+# tar -xf firefox-${FFVERSION}esr.source.tar.xz
|
|
+#
|
|
+# mv firefox-${FFVERSION} $SOURCEDIR
|
|
|
|
###############################################################################
|
|
# Retrieve l10n
|
|
###############################################################################
|
|
|
|
-mkdir l10n
|
|
-cd l10n
|
|
-while read line;do
|
|
- line=$(echo $line |cut -d' ' -f1)
|
|
- #[ $line = "es-ES" ] || continue # To speed up testing
|
|
- [ $line = "en-US" ] && continue
|
|
- hg clone https://hg.mozilla.org/l10n-central/$line
|
|
- mkdir -p $line/browser/chrome/browser/preferences
|
|
- touch $line/browser/chrome/browser/preferences/advanced-scripts.dtd
|
|
- rm -rf $line/.hg*
|
|
-done < ../$SOURCEDIR/browser/locales/shipped-locales
|
|
-cd ..
|
|
-
|
|
-mv l10n $SOURCEDIR
|
|
-
|
|
-hg clone https://hg.mozilla.org/l10n/compare-locales/
|
|
-cd compare-locales/
|
|
-hg checkout RELEASE_8_0_0
|
|
-cd ..
|
|
-rm compare-locales/.hg* compare-locales/.git* -rf
|
|
-mv compare-locales $SOURCEDIR/l10n
|
|
+# mkdir l10n
|
|
+# cd l10n
|
|
+# while read line;do
|
|
+# line=$(echo $line |cut -d' ' -f1)
|
|
+# #[ $line = "es-ES" ] || continue # To speed up testing
|
|
+# [ $line = "en-US" ] && continue
|
|
+# hg clone https://hg.mozilla.org/l10n-central/$line
|
|
+# mkdir -p $line/browser/chrome/browser/preferences
|
|
+# touch $line/browser/chrome/browser/preferences/advanced-scripts.dtd
|
|
+# rm -rf $line/.hg*
|
|
+# done < ../$SOURCEDIR/browser/locales/shipped-locales
|
|
+# cd ..
|
|
+#
|
|
+# mv l10n $SOURCEDIR
|
|
+#
|
|
+# hg clone https://hg.mozilla.org/l10n/compare-locales/
|
|
+# cd compare-locales/
|
|
+# hg checkout RELEASE_8_0_0
|
|
+# cd ..
|
|
+# rm compare-locales/.hg* compare-locales/.git* -rf
|
|
+# mv compare-locales $SOURCEDIR/l10n
|
|
|
|
#######################################################
|
|
|
|
-cd $SOURCEDIR
|
|
+# cd $SOURCEDIR
|
|
|
|
shopt -s nullglob
|
|
for patch in $DATA/patches/*.patch; do
|
|
@@ -598,6 +598,6 @@ sed 's/777/755/;' -i toolkit/crashreporter/google-breakpad/Makefile.in
|
|
# Fix CVE-2012-3386
|
|
/bin/sed 's/chmod a+w/chmod u+w/' -i ./js/src/ctypes/libffi/Makefile.in ./toolkit/crashreporter/google-breakpad/Makefile.in ./toolkit/crashreporter/google-breakpad/src/third_party/glog/Makefile.in || true
|
|
|
|
-cd ..
|
|
-echo Packaging tarball
|
|
-tar cfj icecat-$ICECATVERSION.tar.bz2 $SOURCEDIR
|
|
+# cd ..
|
|
+# echo Packaging tarball
|
|
+# tar cfj icecat-$ICECATVERSION.tar.bz2 $SOURCEDIR
|