guix/gnu/packages/patches/knot-test_net_shortwrite-ensure-connection.patch
Simon South 4e869b180a
gnu: knot: Fix test failure on aarch64-linux.
* gnu/packages/dns.scm (knot)[source]: Apply patch from upstream that
helps ensure the "test_net_shortwrite" test suite can complete
regardless of platform or configuration.
* gnu/packages/patches/knot-test_net_shortwrite-ensure-connection.patch:
New file.
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
2020-10-06 16:20:39 +02:00

19 lines
666 B
Diff

This patch duplicates upstream commit 4144d1e, which helps ensure the
"test_net_shortwrite" test suite can succeed across all platforms by
deepening the pending-connection queue of the server it creates from 0
to 1.
See the original report at
https://gitlab.nic.cz/knot/knot-dns/-/issues/693
--- a/tests/contrib/test_net_shortwrite.c
+++ b/tests/contrib/test_net_shortwrite.c
@@ -88,7 +88,7 @@ int main(int argc, char *argv[])
int server = net_bound_socket(SOCK_STREAM, &addr, 0);
ok(server >= 0, "server: bind socket");
- r = listen(server, 0);
+ r = listen(server, 1);
ok(r == 0, "server: start listening");
struct sockaddr *sa = (struct sockaddr *)&addr;