guix/gnu/packages/patches/openjdk-9-hotspot-stack-size.patch
Marius Bakke 389b5b5359
gnu: OpenJDK@9: Fix build with newer toolchain.
* gnu/packages/java.scm (openjdk9)[source](patches): New field.
* gnu/packages/patches/openjdk-9-hotspot-pointer-comparison.patch,
gnu/packages/patches/openjdk-9-hotspot-stack-size.patch: New files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
2022-09-13 14:53:08 +02:00

28 lines
912 B
Diff

Dynamically allocate the stack since SIGSTKSZ is not constant since glibc 2.34.
Backported from:
https://github.com/openjdk/jdk17u/commit/bb7c412e259893091210267252faf3c0a1be0969
diff --git a/hotspot/test/runtime/StackGuardPages/exeinvoke.c b/hotspot/test/runtime/StackGuardPages/exeinvoke.c
--- a/hotspot/test/runtime/StackGuardPages/exeinvoke.c
+++ b/hotspot/test/runtime/StackGuardPages/exeinvoke.c
@@ -67,8 +67,17 @@ static void handler(int sig, siginfo_t *si, void *unused) {
longjmp(context, 1);
}
+static char* altstack = NULL;
+
void set_signal_handler() {
- static char altstack[SIGSTKSZ];
+ if (altstack == NULL) {
+ // Dynamically allocated in case SIGSTKSZ is not constant
+ altstack = malloc(SIGSTKSZ);
+ if (altstack == NULL) {
+ fprintf(stderr, "Test ERROR. Unable to malloc altstack space\n");
+ exit(7);
+ }
+ }
stack_t ss = {
.ss_size = SIGSTKSZ,