mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
b3e992e984
* gnu/packages/elixir.scm (elixir): Update to 1.10.0. * gnu/packages/patches/elixir-path-length.patch: Update patch so it can be applied to v1.10.0 source Signed-off-by: Marius Bakke <mbakke@fastmail.com>
15 lines
487 B
Diff
15 lines
487 B
Diff
In the package definition the call to the command 'git' is substituted with
|
|
the full path to the git executable. This change causes the mix formatting tool
|
|
to complain that the line is too long. This workaround reformats the file
|
|
after the substitution is made.
|
|
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -265,6 +265,7 @@ format: compile
|
|
$(call FORMAT)
|
|
|
|
test_formatted: compile
|
|
+ $(call FORMAT,lib/mix/lib/mix/scm/git.ex)
|
|
$(call FORMAT,--check-formatted)
|
|
|
|
test_erlang: compile $(TEST_ERLS)
|