mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
2932c421a3
* gnu/packages/tls.scm (openssl-3.0): New variable. * gnu/packages/patches/openssl-3.0-c-rehash-in.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
18 lines
660 B
Diff
18 lines
660 B
Diff
This patch removes the explicit reference to the 'perl' binary,
|
|
such that OpenSSL does not retain a reference to Perl.
|
|
|
|
The 'c_rehash' program is seldom used, but it is used nonetheless
|
|
to create symbolic links to certificates, for instance in the 'nss-certs'
|
|
package.
|
|
|
|
diff --git a/tools/c_rehash.in b/tools/c_rehash.in
|
|
--- a/tools/c_rehash.in
|
|
+++ b/tools/c_rehash.in
|
|
@@ -1,4 +1,6 @@
|
|
-#!{- $config{HASHBANGPERL} -}
|
|
+eval '(exit $?0)' && eval 'exec perl -wS "$0" ${1+"$@"}'
|
|
+ & eval 'exec perl -wS "$0" $argv:q'
|
|
+ if 0;
|
|
{- use OpenSSL::Util; -}
|
|
# {- join("\n# ", @autowarntext) -}
|
|
# Copyright 1999-2021 The OpenSSL Project Authors. All Rights Reserved.
|