guix/gnu/packages/patches/racket-gui-tethered-launcher-backport.patch
Philip McGrath 81e532ff19
gnu: racket: Use Git origins for Racket packages.
* gnu/packages/patches/racket-gui-tethered-launcher-backport.patch:
Adjust path.
* gnu/packages/racket.scm (racket-packages-origin)
(simple-racket-origin): New procedures.
(extend-layer): Rename to ...
(configure-layer.rkt): ... this variable.  Tweak command-line arguments.
Adapt to 'config-tethered-apps-dir'.
(racket): Stop inheriting from 'racket-minimal'.
[version]: Use '%racket-version'.
[source]: Stop using bundled tarball.
[inputs]: Remove labels. Add 'racket-minimal' and package sources.
[native-inputs]: Reduce to racket-minimal.
Untested, as cross-compilation doesn't work yet.
[arguments]: Rewrite to use G-expressions, package sources from
'inputs', an explicit 'install' phase, and the revised
'configure-layer.rkt'.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
2022-03-04 23:37:24 +01:00

26 lines
829 B
Diff

From aa792e707b1fbc5cc33691bfaee5828dc3fbebaa Mon Sep 17 00:00:00 2001
From: Matthew Flatt <mflatt@racket-lang.org>
Date: Mon, 31 Jan 2022 15:31:22 -0700
Subject: [PATCH] fix creation of tethered launchers
Related to racket/racket#4133
(cherry picked from commit 563c68432f127729592f234ef30c31e92618b517)
---
gui-lib/mred/installer.rkt | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/gui-lib/mred/installer.rkt b/gui-lib/mred/installer.rkt
index b1691472..9ef06c53 100644
--- a/gui-lib/mred/installer.rkt
+++ b/gui-lib/mred/installer.rkt
@@ -72,4 +72,5 @@
(list "-A" (path->string (find-system-path 'addon-dir)))))
(define (config-flags)
- (list "-G" (path->string (find-config-dir))))
+ (list "-X" (path->string (find-collects-dir))
+ "-G" (path->string (find-config-dir))))
--
2.32.0