mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
b9a4705f80
This revisits <https://issues.guix.gnu.org/40837> with a fix that doesn't require to have PULSE_CLIENTCONFIG point to an absolute store location, which will allow us to revert to have PULSE_CLIENTCONFIG point to a fixed location under /etc. This would alleviate the need to reboot to have changes to the PulseAudio configuration effected. * gnu/packages/patches/webkitgtk-share-store.patch: Delete file. * gnu/packages/patches/webkitgtk-bubblewrap-paths.patch: Add file. * gnu/packages/patches/webkitgtk-canonicalize-paths.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Update patches list. * gnu/packages/webkit.scm (webkitgtk)[patches]: Adjust accordingly.
25 lines
1.3 KiB
Diff
25 lines
1.3 KiB
Diff
Upstream commit: https://github.com/WebKit/WebKit/commit/31ac354cbeecf866f9a38f7b2f8f59f7975d3f6a
|
|
|
|
diff --git a/Source/WebKit/UIProcess/Launcher/glib/BubblewrapLauncher.cpp b/Source/WebKit/UIProcess/Launcher/glib/BubblewrapLauncher.cpp
|
|
index ecc804663784..8de174be3c0e 100644
|
|
--- a/Source/WebKit/UIProcess/Launcher/glib/BubblewrapLauncher.cpp
|
|
+++ b/Source/WebKit/UIProcess/Launcher/glib/BubblewrapLauncher.cpp
|
|
@@ -288,6 +288,7 @@ static void bindFonts(Vector<CString>& args)
|
|
const char* homeDir = g_get_home_dir();
|
|
const char* dataDir = g_get_user_data_dir();
|
|
const char* cacheDir = g_get_user_cache_dir();
|
|
+ const char* const * dataDirs = g_get_system_data_dirs();
|
|
|
|
// Configs can include custom dirs but then we have to parse them...
|
|
GUniquePtr<char> fontConfig(g_build_filename(configDir, "fontconfig", nullptr));
|
|
@@ -304,6 +305,10 @@ static void bindFonts(Vector<CString>& args)
|
|
bindIfExists(args, fontHomeConfigDir.get());
|
|
bindIfExists(args, fontData.get());
|
|
bindIfExists(args, fontHomeData.get());
|
|
+ for (auto* dataDir = dataDirs; dataDir && *dataDir; dataDir++) {
|
|
+ GUniquePtr<char> fontDataDir(g_build_filename(*dataDir, "fonts", nullptr));
|
|
+ bindIfExists(args, fontDataDir.get());
|
|
+ }
|
|
bindIfExists(args, "/var/cache/fontconfig"); // Used by Debian.
|
|
}
|
|
|