mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
b5baa98053
* gnu/packages/package-management.scm (nix): Update to 2.16.1. [source]: Use HTTPS for package source. [inputs]: Add nlohmann-json. [native-inputs]: Add rapidcheck. [arguments]<#:phases>: In phase "check", change the value of environment variable "NIX_STORE" to "/nix/store" temporarily. * gnu/packages/patches/nix-dont-build-html-doc.diff: Update. Co-authored-by: jgart <jgart@dismail.de>
43 lines
1.6 KiB
Diff
43 lines
1.6 KiB
Diff
"--enable-doc-gen" configure flag will enable HTML document generation that requires mdbook.
|
|
We can't simply disable it because we need manpages.
|
|
|
|
Author: Zhu Zihao <all_but_last@163.com>
|
|
|
|
--- a/doc/manual/local.mk
|
|
+++ b/doc/manual/local.mk
|
|
@@ -138,11 +138,6 @@
|
|
$(trace-gen) $(dummy-env) NIX_PATH=nix/corepkgs=corepkgs $(bindir)/nix __dump-builtins > $@.tmp
|
|
@mv $@.tmp $@
|
|
|
|
-# Generate the HTML manual.
|
|
-.PHONY: manual-html
|
|
-manual-html: $(docdir)/manual/index.html
|
|
-install: $(docdir)/manual/index.html
|
|
-
|
|
# Generate 'nix' manpages.
|
|
install: $(mandir)/man1/nix3-manpages
|
|
man: doc/manual/generated/man1/nix3-manpages
|
|
@@ -167,23 +162,4 @@
|
|
done
|
|
@touch $@
|
|
|
|
-$(docdir)/manual/index.html: $(MANUAL_SRCS) $(d)/book.toml $(d)/anchors.jq $(d)/custom.css $(d)/src/SUMMARY.md $(d)/src/command-ref/new-cli $(d)/src/contributing/experimental-feature-descriptions.md $(d)/src/command-ref/conf-file.md $(d)/src/language/builtins.md
|
|
- $(trace-gen) \
|
|
- tmp="$$(mktemp -d)"; \
|
|
- cp -r doc/manual "$$tmp"; \
|
|
- find "$$tmp" -name '*.md' | while read -r file; do \
|
|
- $(call process-includes,$$file,$$file); \
|
|
- done; \
|
|
- find "$$tmp" -name '*.md' | while read -r file; do \
|
|
- docroot="$$(realpath --relative-to="$$(dirname "$$file")" $$tmp/manual/src)"; \
|
|
- sed -i "s,@docroot@,$$docroot,g" "$$file"; \
|
|
- done; \
|
|
- set -euo pipefail; \
|
|
- RUST_LOG=warn mdbook build "$$tmp/manual" -d $(DESTDIR)$(docdir)/manual.tmp 2>&1 \
|
|
- | { grep -Fv "because fragment resolution isn't implemented" || :; }; \
|
|
- rm -rf "$$tmp/manual"
|
|
- @rm -rf $(DESTDIR)$(docdir)/manual
|
|
- @mv $(DESTDIR)$(docdir)/manual.tmp/html $(DESTDIR)$(docdir)/manual
|
|
- @rm -rf $(DESTDIR)$(docdir)/manual.tmp
|
|
-
|
|
endif
|