mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-26 04:29:25 -05:00
2073b55e6b
Fixes <https://bugs.gnu.org/30756>. Initially reported by Julien Lepiller <julien@lepiller.eu>. * gnu/packages/base.scm (make-gcc-libc): Remove 'treat-glibc-as-system-header' phase from 'arguments'. * gnu/packages/commencement.scm (gcc-final): Likewise. * gnu/packages/gcc.scm (gcc-4.7)[arguments]: Add "include/c++" to 'CPLUS_INCLUDE_PATH'. (gcc-6)[native-search-paths]: Remove. * gnu/packages/make-bootstrap.scm (gcc-for-bootstrap): Remove 'native-search-paths' and 'arguments'. * gnu/packages/patches/python-2.7-search-paths.patch, gnu/packages/patches/python-3-search-paths.patch: Replace "CPATH" with "C_INCLUDE_PATH". * guix/build-system/cmake.scm (lower): When not cross-compiling, move INPUTS from the 'host-inputs' field to the 'build-inputs' field of the bag, right after NATIVE-INPUTS. * guix/build-system/glib-or-gtk.scm (lower): Likewise. * guix/build-system/gnu.scm (lower): Likewise. * guix/build-system/meson.scm (lower): Likewise.
25 lines
1.4 KiB
Diff
25 lines
1.4 KiB
Diff
Make sure the build system honors C_INCLUDE_PATH and LIBRARY_PATH when
|
|
looking for headers and libraries.
|
|
|
|
--- a/setup.py 2015-10-07 23:32:58.891329173 +0200
|
|
+++ b/setup.py 2015-10-07 23:46:29.653349924 +0200
|
|
@@ -676,15 +676,15 @@
|
|
# if a file is found in one of those directories, it can
|
|
# be assumed that no additional -I,-L directives are needed.
|
|
if not CROSS_COMPILING:
|
|
- self.lib_dirs = self.compiler.library_dirs + system_lib_dirs
|
|
- self.inc_dirs = self.compiler.include_dirs + system_include_dirs
|
|
+ self.lib_dirs = os.getenv('LIBRARY_PATH', '').split(os.pathsep)
|
|
+ self.inc_dirs = os.getenv('C_INCLUDE_PATH', '').split(os.pathsep)
|
|
else:
|
|
# Add the sysroot paths. 'sysroot' is a compiler option used to
|
|
# set the logical path of the standard system headers and
|
|
# libraries.
|
|
- self.lib_dirs = (self.compiler.library_dirs +
|
|
+ self.lib_dirs = (os.getenv('CROSS_LIBRARY_PATH', '').split(os.pathsep) +
|
|
sysroot_paths(('LDFLAGS', 'CC'), system_lib_dirs))
|
|
- self.inc_dirs = (self.compiler.include_dirs +
|
|
+ self.inc_dirs = (os.getenv('CROSS_CPATH', '').split(os.pathsep) +
|
|
sysroot_paths(('CPPFLAGS', 'CFLAGS', 'CC'),
|
|
system_include_dirs))
|
|
|