mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
af88972bb8
* gnu/packages/patches/clang-runtime-3.8-libsanitizer-mode-field.patch, gnu/packages/patches/clang-runtime-3.9-libsanitizer-mode-field.patch, gnu/packages/patches/clang-runtime-9-libsanitizer-mode-field.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/llvm.scm (clang-runtime, clang-runtime-8, clang-runtime-7, clang-runtime-6, clang-runtime-3.9.1, clang-runtime-3.8, clang-runtime-3.7): Add the respective patches.
60 lines
2.2 KiB
Diff
60 lines
2.2 KiB
Diff
Adjust libsanitizer to ABI change in glibc 2.31.
|
|
|
|
Taken from this upstream commit:
|
|
https://github.com/llvm/llvm-project/commit/947f9692440836dcb8d88b74b69dd379d85974ce
|
|
|
|
diff --git a/lib/sanitizer_common/sanitizer_platform_limits_posix.cc b/lib/sanitizer_common/sanitizer_platform_limits_posix.cc
|
|
--- a/lib/sanitizer_common/sanitizer_platform_limits_posix.cc
|
|
+++ b/lib/sanitizer_common/sanitizer_platform_limits_posix.cc
|
|
@@ -1126,8 +1126,9 @@ CHECK_SIZE_AND_OFFSET(ipc_perm, uid);
|
|
CHECK_SIZE_AND_OFFSET(ipc_perm, gid);
|
|
CHECK_SIZE_AND_OFFSET(ipc_perm, cuid);
|
|
CHECK_SIZE_AND_OFFSET(ipc_perm, cgid);
|
|
-#if !defined(__aarch64__) || !SANITIZER_LINUX || __GLIBC_PREREQ (2, 21)
|
|
-/* On aarch64 glibc 2.20 and earlier provided incorrect mode field. */
|
|
+#if !SANITIZER_LINUX || __GLIBC_PREREQ (2, 31)
|
|
+/* glibc 2.30 and earlier provided 16-bit mode field instead of 32-bit
|
|
+ on many architectures. */
|
|
CHECK_SIZE_AND_OFFSET(ipc_perm, mode);
|
|
#endif
|
|
|
|
diff --git a/compiler-rt/lib/sanitizer_common/sanitizer_platform_limits_posix.h b/compiler-rt/lib/sanitizer_common/sanitizer_platform_limits_posix.h
|
|
--- a/lib/sanitizer_common/sanitizer_platform_limits_posix.h
|
|
+++ b/lib/sanitizer_common/sanitizer_platform_limits_posix.h
|
|
@@ -203,28 +203,15 @@ namespace __sanitizer {
|
|
u64 __unused1;
|
|
u64 __unused2;
|
|
#elif defined(__sparc__)
|
|
-#if defined(__arch64__)
|
|
- unsigned mode;
|
|
- unsigned short __pad1;
|
|
-#else
|
|
- unsigned short __pad1;
|
|
- unsigned short mode;
|
|
- unsigned short __pad2;
|
|
-#endif
|
|
- unsigned short __seq;
|
|
- unsigned long long __unused1;
|
|
- unsigned long long __unused2;
|
|
-#elif defined(__mips__) || defined(__aarch64__) || defined(__s390x__)
|
|
- unsigned int mode;
|
|
- unsigned short __seq;
|
|
- unsigned short __pad1;
|
|
- unsigned long __unused1;
|
|
- unsigned long __unused2;
|
|
+ unsigned mode;
|
|
+ unsigned short __pad2;
|
|
+ unsigned short __seq;
|
|
+ unsigned long long __unused1;
|
|
+ unsigned long long __unused2;
|
|
#else
|
|
- unsigned short mode;
|
|
- unsigned short __pad1;
|
|
- unsigned short __seq;
|
|
- unsigned short __pad2;
|
|
+ unsigned int mode;
|
|
+ unsigned short __seq;
|
|
+ unsigned short __pad2;
|
|
#if defined(__x86_64__) && !defined(_LP64)
|
|
u64 __unused1;
|
|
u64 __unused2;
|