mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
497b2d3942
* gnu/packages/patches/dbus-c++-gcc-compat.patch, gnu/packages/patches/dbus-c++-threading-mutex.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/glib.scm (dbus-c++)[source](patches): New field. [arguments]: End phases on #t.
14 lines
433 B
Diff
14 lines
433 B
Diff
Fix a string comparison in C++ 11.
|
|
|
|
Taken from Debian:
|
|
https://sources.debian.org/src/dbus-c++/0.9.0-8.1/debian/patches/06_fix_gcc-7_ftbfs.patch/
|
|
|
|
--- a/src/pipe.cpp
|
|
+++ b/src/pipe.cpp
|
|
@@ -83,5 +83,5 @@ ssize_t Pipe::read(void *buffer, unsigne
|
|
void Pipe::signal()
|
|
{
|
|
// TODO: ignoring return of read/write generates warning; maybe relevant for eventloop work...
|
|
- ::write(_fd_write, '\0', 1);
|
|
+ ::write(_fd_write, "\0", 1);
|
|
}
|