mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
e22a6ed8f8
* gnu/packages/firmware.scm (make-openbios-package)[source]: Add patch to correctly detect aarch64 and riscv64 build hosts. (openbios-qemu-ppc)[arguments]: Remove aarch64 workaround for #:system. * gnu/packages/patches/openbios-aarch64-riscv64-support.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
17 lines
643 B
Diff
17 lines
643 B
Diff
This was submitted upstream
|
|
https://github.com/openbios/openbios/pull/12
|
|
|
|
diff --git a/config/scripts/switch-arch b/config/scripts/switch-arch
|
|
index b5acc6c..a96ef4b 100755
|
|
--- a/config/scripts/switch-arch
|
|
+++ b/config/scripts/switch-arch
|
|
@@ -38,7 +38,8 @@ longbits()
|
|
if test "$cpu" = "sparc64" -o "$cpu" = "ia64" \
|
|
-o "$cpu" = "amd64" -o "$cpu" = "x86_64" \
|
|
-o "$cpu" = "powerpc64" -o "$cpu" = "ppc64" \
|
|
- -o "$cpu" = "ppc64le" -o "$cpu" = "alpha" ; then
|
|
+ -o "$cpu" = "ppc64le" -o "$cpu" = "alpha" \
|
|
+ -o "$cpu" = "aarch64" -o "$cpu" = "riscv64" ; then
|
|
echo 64
|
|
else
|
|
echo 32
|