mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
2c8cdb0550
* gnu/packages/display-managers.scm (slim)[version]: Update to 1.4.0. [inputs]: Remove input label. [arguments]: Use gexp and remove fix-0-pointer-comparison. [home-pages]: Update to slim-fork's url. * gnu/packages/patches/slim-config.patch: Port to slim-1.4.0. * gnu/packages/patches/slim-display.patch: Port to slim-1.4.0. * gnu/packages/patches/slim-reset.patch: Deleted, no ablilty to port this patch for big change in v1.4.0. * gnu/packages/patches/slim-session.patch: Deleted. seem to work without this patch, further observation is needed. * gnu/packages/patches/slim-sigusr1.patch: Deleted, fixed in upstream. * gnu/local.mk: Remove slim-reset.patch, slim-session.patch, slim-sigur1.patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
36 lines
915 B
Diff
36 lines
915 B
Diff
Allow the configuration file and theme directory to be specified at run time.
|
|
|
|
Patch by Eelco Dolstra, from Nixpkgs.
|
|
---
|
|
app.cpp | 8 ++++++--
|
|
1 file changed, 6 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/app.cpp b/app.cpp
|
|
index 237477d..735df9c 100644
|
|
--- a/app.cpp
|
|
+++ b/app.cpp
|
|
@@ -285,7 +285,9 @@ void App::Run()
|
|
if ( cfg == 0 )
|
|
{
|
|
cfg = new Cfg;
|
|
- cfg->readConf(CFGFILE);
|
|
+ const char* cfgfile = getenv("SLIM_CFGFILE");
|
|
+ if (!cfgfile) cfgfile = CFGFILE;
|
|
+ cfg->readConf(cfgfile);
|
|
}
|
|
string themebase = "";
|
|
string themefile = "";
|
|
@@ -297,7 +299,9 @@ void App::Run()
|
|
}
|
|
else
|
|
{
|
|
- themebase = string(THEMESDIR) + "/";
|
|
+ const char* themesdir = getenv("SLIM_THEMESDIR");
|
|
+ if (!themesdir) themesdir = THEMESDIR;
|
|
+ themebase = string(themesdir) + "/";
|
|
themeName = cfg->getOption("current_theme");
|
|
string::size_type pos;
|
|
if ((pos = themeName.find(",")) != string::npos)
|
|
--
|
|
2.39.2
|
|
|