mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-26 14:28:15 -05:00
de002b93db
To avoid Guile module dependency cycles, inherited packages must be defined in the same module. Use this opportunity to simplify the patches applying mechanism, versioning custom patches the same as for other packages. * gnu/packages/patches/ffmpeg-jami-change-RTCP-ratio.patch: New file. * gnu/packages/patches/ffmpeg-jami-rtp_ext_abs_send_time.patch: Likewise. * gnu/packages/patches/ffmpeg-jami-libopusdec-enable-FEC.patch: Likewise. * gnu/packages/patches/ffmpeg-jami-libopusenc-enable-FEC.patch: Likewise. * gnu/packages/patches/ffmpeg-jami-libopusenc-reload-packet-loss-at-encode.patch: Likewise. * gnu/packages/patches/ffmpeg-jami-remove-mjpeg-log.patch: Likewise. * gnu/packages/patches/ffmpeg-jami-screen-sharing-x11-fix.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Register them. * gnu/packages/jami.scm (jami-apply-custom-patches): Delete procedure. (%ffmpeg-default-configure-flags): Delete variable. (ffmpeg-compose-configure-flags): Delete procedure. (ffmpeg-jami): Move to... * gnu/packages/video.scm (ffmpeg-jami): ... here. Apply patches to origin and repatriate configure flags. Change-Id: Id374fae18240cd76b224915d80b61422635ccb77
27 lines
898 B
Diff
27 lines
898 B
Diff
From a884b62c9e6f23b9f4369d724e25db2f42dad28d Mon Sep 17 00:00:00 2001
|
|
From: Pierre LESPAGNOL <pierre.lespagnol@savoirfairelinux.com>
|
|
Date: Tue, 28 May 2019 16:18:20 -0400
|
|
Subject: [PATCH] Changement du ratio de 0.5% a 5%
|
|
|
|
---
|
|
libavformat/rtp.h | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/libavformat/rtp.h b/libavformat/rtp.h
|
|
index 54512c6f71..16916ff86a 100644
|
|
--- a/libavformat/rtp.h
|
|
+++ b/libavformat/rtp.h
|
|
@@ -78,8 +78,8 @@ enum AVCodecID ff_rtp_codec_id(const char *buf, enum AVMediaType codec_type);
|
|
#define RTP_VERSION 2
|
|
#define RTP_MAX_SDES 256 /**< maximum text length for SDES */
|
|
|
|
-/* RTCP packets use 0.5% of the bandwidth */
|
|
-#define RTCP_TX_RATIO_NUM 5
|
|
+/* RTCP packets use 2.5% of the bandwidth */
|
|
+#define RTCP_TX_RATIO_NUM 25
|
|
#define RTCP_TX_RATIO_DEN 1000
|
|
|
|
/* An arbitrary id value for RTP Xiph streams - only relevant to indicate
|
|
--
|
|
2.17.1
|
|
|