mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-26 14:28:15 -05:00
a05c130435
* gnu/packages/patches/jami-enable-testing.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/jami.scm (jami) [source]: Apply it. [phases] <check>: Use 'ctest' to run tests. Update comment explaining why the QML test suite is disabled. Change-Id: I5c9333a3b5064ecec9a2dd4fe13ae597d5354b7c
26 lines
686 B
Diff
26 lines
686 B
Diff
Fix an issue where ctest wouldn't find the qml test files.
|
|
Upstream status: forwarded to jami@gnu.org
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index e802357f..75cffda2 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -884,5 +884,6 @@ qt_finalize_executable(${PROJECT_NAME})
|
|
# tests
|
|
if(BUILD_TESTING)
|
|
message("Add Jami tests")
|
|
+ enable_testing()
|
|
add_subdirectory(${TESTS_DIR})
|
|
endif()
|
|
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
|
|
index 37796e52..06008ccf 100644
|
|
--- a/tests/CMakeLists.txt
|
|
+++ b/tests/CMakeLists.txt
|
|
@@ -1,6 +1,6 @@
|
|
cmake_minimum_required(VERSION 3.16)
|
|
|
|
-enable_testing(true)
|
|
+enable_testing()
|
|
|
|
set(QT_TESTING_MODULES
|
|
${QT_MODULES}
|