mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
99d288a6b1
* gnu/packages/patches/llvm-3.6-fix-build-with-gcc-10.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/llvm.scm (llvm-3.6)[source]: Use it.
13 lines
506 B
Diff
13 lines
506 B
Diff
Adapted from https://github.com/digego/extempore/pull/322/files
|
|
|
|
--- a/include/llvm/IR/ValueMap.h 2015-08-04 00:30:24.000000000 +0200
|
|
+++ b/include/llvm/IR/ValueMap.h 2018-07-14 21:09:09.769502736 +0200
|
|
@@ -99,7 +99,7 @@
|
|
explicit ValueMap(const ExtraData &Data, unsigned NumInitBuckets = 64)
|
|
: Map(NumInitBuckets), Data(Data) {}
|
|
|
|
- bool hasMD() const { return MDMap; }
|
|
+ bool hasMD() const { return static_cast<bool>(MDMap); }
|
|
MDMapT &MD() {
|
|
if (!MDMap)
|
|
MDMap.reset(new MDMapT);
|