mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 16:06:16 -05:00
fedb9571eb
* gnu/packages/sagemath.scm (lcalc): New variable. * gnu/packages/patches/lcalc-default-parameters-1.patch, gnu/packages/patches/lcalc-default-parameters-2.patch, gnu/packages/patches/lcalc-lcommon-h.patch, gnu/packages/patches/lcalc-using-namespace-std.patch: New files. * gnu/local.mk (dist_patch_DATA): Register patches.
26 lines
1.3 KiB
Diff
26 lines
1.3 KiB
Diff
Patch taken from the Sage packaging system.
|
|
|
|
diff -Naur lcalc-1.23-vanilla/include/Ldirichlet_series.h lcalc-1.23-fixed-gcc.4.9/include/Ldirichlet_series.h
|
|
--- lcalc-1.23-vanilla/include/Ldirichlet_series.h 2012-08-08 23:21:55.000000000 +0200
|
|
+++ lcalc-1.23-fixed-gcc.4.9/include/Ldirichlet_series.h 2014-04-21 14:37:59.027464849 +0200
|
|
@@ -43,7 +43,7 @@
|
|
//XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
|
|
template <class ttype>
|
|
Complex L_function <ttype>::
|
|
-dirichlet_series(Complex s, long long N=-1)
|
|
+dirichlet_series(Complex s, long long N)
|
|
{
|
|
Complex z=0.;
|
|
long long m,n;
|
|
diff -Naur lcalc-1.23-vanilla/include/L.h lcalc-1.23-fixed-gcc.4.9/include/L.h
|
|
--- lcalc-1.23-vanilla/include/L.h 2012-08-08 23:21:55.000000000 +0200
|
|
+++ lcalc-1.23-fixed-gcc.4.9/include/L.h 2014-04-21 14:32:04.003467348 +0200
|
|
@@ -491,7 +491,7 @@
|
|
|
|
//#include "Ldirichlet_series.h" //for computing Dirichlet series
|
|
Complex partial_dirichlet_series(Complex s, long long N1, long long N2);
|
|
- Complex dirichlet_series(Complex s, long long N);
|
|
+ Complex dirichlet_series(Complex s, long long N=-1LL);
|
|
|
|
//#include "Ltaylor_series.h" //for computing taylor series for Dirichlet series
|
|
//void compute_taylor_series(int N, int K, Complex s_0, Complex *series);
|