mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
8d48f358e9
* gnu/packages/patches/parted-glibc-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/disk.scm (parted)[source](patches): New field.
17 lines
526 B
Diff
17 lines
526 B
Diff
Include <sys/sysmacros.h> for "major" and "minor".
|
|
|
|
Taken from upstream:
|
|
https://git.savannah.gnu.org/cgit/parted.git/commit/?id=ba5e0451b51c983e40afd123b6e0d3eddb55e610
|
|
|
|
diff --git a/libparted/arch/linux.c b/libparted/arch/linux.c
|
|
index 31b98ab..7e86b51 100644
|
|
--- a/libparted/arch/linux.c
|
|
+++ b/libparted/arch/linux.c
|
|
@@ -41,6 +41,7 @@
|
|
#include <sys/utsname.h> /* for uname() */
|
|
#include <scsi/scsi.h>
|
|
#include <assert.h>
|
|
+#include <sys/sysmacros.h>
|
|
#ifdef ENABLE_DEVICE_MAPPER
|
|
#include <libdevmapper.h>
|
|
#endif
|