mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
b7a0935420
* gnu/packages/gnuzilla.scm (mozilla-compare-locales) (all-mozilla-locales, %icecat-version, %icecat-build-id): Update. (icecat-source): Update upstream source hash. Update to latest gnuzilla commit. Remove the hack that provided 'rename' as 'prename'; set RENAME_CMD environment variable instead. Add python to PATH. Set PYTHONPATH appropriately. Adapt substitutions for the reorganized 'makeicecat' script. Run 'makeicecat' outside of the IceCat source directory. (icecat)[inputs]: Add cairo, font-dejavu, libpng-apng, libvpx, pciutils, hunspell, libnotify, sqlite, and zlib. Update icu4c to version 69. [native-inputs]: Update rust and cargo to 1.51. Update rust-cbindgen to 0.19. Update llvm and clang to 11. Add m4. Remove autoconf. [description]: Update embedded version number to 91. [arguments]: Remove "#:out-of-source? #t". Add "#:validate-runpath? #f". In configure-flags, add "--enable-application=browser", "--enable-rust-simd", "--enable-release", "--enable-optimize", "--enable-strip", "--disable-elf-hack", "--with-system-png", and "--with-system-zlib". Adjust the set of modules. Remove the 'link-libxul-with-libraries' and 'bootstrap' phases. Remove the sandbox whitelist population code from the 'fix-ffmpeg-runtime-linker' phase. Add a new 'build-sandbox-whitelist' phase. The new whitelist code now adds <font-dejavu>/share/fonts to the whitelist, and also the runpaths of all libraries in the 'mesa' package. Update the 'configure' phase to use clang-11 and llvm-11 for compilation (previously we used gcc), to create a 'mozconfig' file and run './mach configure' (previously we passed flags to './configure'). Update the 'build' and 'install' phases to use './mach'. Update and simplify the 'neutralise-store-references' phase. Move the 'install-desktop-entry' phase to happen after 'wrap-program', whereas previously it was run after 'configure'. In the 'wrap-program' phase, add libpng-apng and libnotify to LD_LIBRARY_PATH. (mozilla-78-compare-locales, all-mozilla-78-locales, %icecat-78-version) (icecat-78-source): New variables, containing the previous values of mozilla-compare-locales, all-mozilla-locales, %icecat-version, and icecat-source, respectively. (icedove)[source]: Use 'icecat-78-source'. * gnu/packages/patches/icecat-makeicecat.patch: Adapt to the reorganized 'makeicecat' script. * gnu/packages/patches/icecat-78-makeicecat.patch: New file, containing previous contents of icecat-makeicecat.patch. * gnu/local.mk: Add icecat-78-makeicecat.patch.
51 lines
1.4 KiB
Diff
51 lines
1.4 KiB
Diff
Make some of the changes needed to the 'makeicecat' script, to allow it to run
|
|
in a snippet without network access. After this patch is applied, some
|
|
additional changes will be made using 'substitute*'.
|
|
|
|
diff --git a/makeicecat b/makeicecat
|
|
index bf2b7a6..bc3b19b 100755
|
|
--- a/makeicecat
|
|
+++ b/makeicecat
|
|
@@ -58,7 +58,7 @@ readonly SOURCEDIR=icecat-${FFVERSION}
|
|
# debug/shell options
|
|
readonly DEVEL=0
|
|
set -euo pipefail
|
|
-(( DEVEL )) && set -x
|
|
+set -x
|
|
|
|
|
|
###############################################################################
|
|
@@ -459,7 +459,7 @@ configure_search()
|
|
sed 's|ddg@|ddg-html@|' -i browser/components/search/extensions/ddg-html/manifest.json
|
|
|
|
# Process various JSON pre-configuration dumps.
|
|
- python3 ../../tools/process-json-files.py . browser/components/extensions/schemas/
|
|
+ python3 "${DATADIR}"/../tools/process-json-files.py . browser/components/extensions/schemas/
|
|
}
|
|
|
|
configure_mobile()
|
|
@@ -855,12 +855,12 @@ finalize_sourceball()
|
|
# entry point
|
|
###############################################################################
|
|
|
|
-validate_env || exit 1
|
|
-prepare_env
|
|
-fetch_source
|
|
-verify_sources
|
|
-extract_sources
|
|
-fetch_l10n
|
|
+# validate_env || exit 1
|
|
+# prepare_env
|
|
+# fetch_source
|
|
+# verify_sources
|
|
+# extract_sources
|
|
+# fetch_l10n
|
|
apply_patches
|
|
configure
|
|
configure_search
|
|
@@ -872,4 +872,4 @@ prepare_macos_packaging
|
|
configure_extensions
|
|
configure_onboarding
|
|
apply_bugfixes
|
|
-finalize_sourceball
|
|
+# finalize_sourceball
|