diff options
author | Ryan Schanzenbacher <ryan@rschanz.org> | 2023-06-11 01:02:40 -0400 |
---|---|---|
committer | Ryan Schanzenbacher <ryan@rschanz.org> | 2023-06-11 01:02:40 -0400 |
commit | bbdc3d8697ff3025d655de5174e7b9f18926263a (patch) | |
tree | 6fe0036d19e0131f089516cfb2b602f7c8ad0397 | |
parent | 98217a4c29e7fedefdbadf1db6a2d3abbd3bbbc0 (diff) |
added hyprland config, added hyprland desktop portal
-rw-r--r-- | home-config/hypr/hyprland.conf | 16 | ||||
-rw-r--r-- | home-config/nix-home-manager/home.nix | 1 | ||||
-rw-r--r-- | modules/ryan-config/base-system.scm | 2 | ||||
-rw-r--r-- | modules/ryan-packages/freedesktop.scm | 54 |
4 files changed, 72 insertions, 1 deletions
diff --git a/home-config/hypr/hyprland.conf b/home-config/hypr/hyprland.conf index e4056c4..5df73de 100644 --- a/home-config/hypr/hyprland.conf +++ b/home-config/hypr/hyprland.conf | |||
@@ -178,4 +178,20 @@ bind = $mainMod SHIFT, Print, exec, grimblast edit area | |||
178 | bind = $mainMod, N, exec, makoctl dismiss | 178 | bind = $mainMod, N, exec, makoctl dismiss |
179 | bind = $mainMod SHIFT, N, exec, makoctl dismiss -a | 179 | bind = $mainMod SHIFT, N, exec, makoctl dismiss -a |
180 | 180 | ||
181 | # Window Rules | ||
182 | |||
183 | # Firefox PiP | ||
184 | windowrulev2 = float, class:^(firefox)$, title:^(Picture-in-Picture)$ | ||
185 | windowrulev2 = pin, class:^(firefox)$, title:^(Picture-in-Picture)$ | ||
186 | windowrulev2 = size 578 326, class:^(firefox)$, title:^(Picture-in-Picture)$ | ||
187 | |||
188 | # Firefox Sharing Indicator | ||
189 | windowrulev2 = float, class:^(firefox)$, title:^(Firefox — Sharing Indicator)$ | ||
190 | windowrulev2 = size 56 31, class:^(firefox)$, title:^(Firefox — Sharing Indicator)$ | ||
191 | windowrulev2 = move 50% 0, class:^(firefox)$, title:^(Firefox — Sharing Indicator)$ | ||
192 | |||
193 | # Weather | ||
194 | windowrulev2 = float,class:^(ala-wttr)$ | ||
195 | windowrulev2 = size 740 712, class:^(ala-wttr)$ | ||
196 | |||
181 | exec-once = ~/.config/hypr/autostart.sh | 197 | exec-once = ~/.config/hypr/autostart.sh |
diff --git a/home-config/nix-home-manager/home.nix b/home-config/nix-home-manager/home.nix index 5ee8d22..d19051c 100644 --- a/home-config/nix-home-manager/home.nix +++ b/home-config/nix-home-manager/home.nix | |||
@@ -28,6 +28,7 @@ | |||
28 | # # "Hello, world!" when run. | 28 | # # "Hello, world!" when run. |
29 | # pkgs.hello | 29 | # pkgs.hello |
30 | yt-dlp | 30 | yt-dlp |
31 | xdg-desktop-portal-hyprland | ||
31 | 32 | ||
32 | # # It is sometimes useful to fine-tune packages, for example, by applying | 33 | # # It is sometimes useful to fine-tune packages, for example, by applying |
33 | # # overrides. You can do that directly here, just don't forget the | 34 | # # overrides. You can do that directly here, just don't forget the |
diff --git a/modules/ryan-config/base-system.scm b/modules/ryan-config/base-system.scm index 8ff2581..9273e17 100644 --- a/modules/ryan-config/base-system.scm +++ b/modules/ryan-config/base-system.scm | |||
@@ -141,7 +141,7 @@ | |||
141 | "wireplumber" | 141 | "wireplumber" |
142 | "wireshark" | 142 | "wireshark" |
143 | "zsh")) | 143 | "zsh")) |
144 | (list my-ca-certs xdg-desktop-portal-wlr-new swaylock-effects-new waybar-new) | 144 | (list my-ca-certs swaylock-effects-new waybar-new xdg-desktop-portal-hyprland hyprland-share-picker) |
145 | %my-base-packages )) | 145 | %my-base-packages )) |
146 | 146 | ||
147 | ;; Below is the list of system services. To search for available | 147 | ;; Below is the list of system services. To search for available |
diff --git a/modules/ryan-packages/freedesktop.scm b/modules/ryan-packages/freedesktop.scm index 6c0770a..57c3442 100644 --- a/modules/ryan-packages/freedesktop.scm +++ b/modules/ryan-packages/freedesktop.scm | |||
@@ -1,10 +1,20 @@ | |||
1 | (define-module (ryan-packages freedesktop) | 1 | (define-module (ryan-packages freedesktop) |
2 | #:use-module (guix download) | 2 | #:use-module (guix download) |
3 | #:use-module ((guix licenses) #:prefix license:) | ||
4 | #:use-module (guix gexp) | ||
5 | #:use-module (guix build-system meson) | ||
6 | #:use-module (guix build-system qt) | ||
3 | #:use-module (guix packages) | 7 | #:use-module (guix packages) |
4 | #:use-module (guix git-download) | 8 | #:use-module (guix git-download) |
5 | #:use-module (guix utils) | 9 | #:use-module (guix utils) |
6 | #:use-module (gnu packages) | 10 | #:use-module (gnu packages) |
11 | #:use-module (gnu packages gl) | ||
12 | #:use-module (gnu packages linux) | ||
13 | #:use-module (gnu packages qt) | ||
14 | #:use-module (gnu packages cmake) | ||
15 | #:use-module (gnu packages pkg-config) | ||
7 | #:use-module (gnu packages freedesktop) | 16 | #:use-module (gnu packages freedesktop) |
17 | #:use-module (rosenthal packages wm) | ||
8 | #:use-module (gnu packages wm)) | 18 | #:use-module (gnu packages wm)) |
9 | 19 | ||
10 | (define-public xdg-desktop-portal-wlr-new | 20 | (define-public xdg-desktop-portal-wlr-new |
@@ -22,3 +32,47 @@ | |||
22 | (patches (search-patches "xdg-desktop-portal-wlr-harcoded-length.patch")))) | 32 | (patches (search-patches "xdg-desktop-portal-wlr-harcoded-length.patch")))) |
23 | (native-inputs (modify-inputs (package-native-inputs xdg-desktop-portal-wlr) | 33 | (native-inputs (modify-inputs (package-native-inputs xdg-desktop-portal-wlr) |
24 | (append wlroots))))) | 34 | (append wlroots))))) |
35 | |||
36 | (define-public xdg-desktop-portal-hyprland | ||
37 | (package | ||
38 | (name "xdg-desktop-portal-hyprland") | ||
39 | (version "0.4.0") | ||
40 | (source (origin | ||
41 | (method git-fetch) | ||
42 | (uri (git-reference | ||
43 | (url "https://github.com/hyprwm/xdg-desktop-portal-hyprland") | ||
44 | (commit (string-append "v" version)))) | ||
45 | (file-name (git-file-name name version)) | ||
46 | (sha256 | ||
47 | (base32 | ||
48 | "1dcglmx02j73qbmw9qsacamn8byakyzwknpqjnhsyphixb4crrdg")))) | ||
49 | (build-system meson-build-system) | ||
50 | (arguments | ||
51 | (list | ||
52 | #:configure-flags #~(list "-Dsystemd=disabled"))) | ||
53 | (native-inputs (list cmake pkg-config wayland hyprland-protocols)) | ||
54 | (inputs (list elogind hyprland hyprland-protocols pipewire wayland-protocols wayland libinih mesa `(,util-linux "lib"))) | ||
55 | (home-page "") | ||
56 | (synopsis "test") | ||
57 | (description "test") | ||
58 | (license license:bsd-3))) | ||
59 | |||
60 | (define-public hyprland-share-picker | ||
61 | (package | ||
62 | (inherit xdg-desktop-portal-hyprland) | ||
63 | (name "hyprland-share-picker") | ||
64 | (build-system qt-build-system) | ||
65 | (inputs (modify-inputs (package-inputs xdg-desktop-portal-hyprland) | ||
66 | (append qtwayland-5))) | ||
67 | (native-inputs (modify-inputs (package-native-inputs xdg-desktop-portal-hyprland) | ||
68 | (append qtwayland-5))) | ||
69 | (arguments | ||
70 | (list | ||
71 | #:tests? #f | ||
72 | #:phases | ||
73 | #~(modify-phases %standard-phases | ||
74 | (add-after 'unpack 'chdir | ||
75 | (lambda _ (chdir "hyprland-share-picker")))))) | ||
76 | (synopsis "share picker"))) | ||
77 | |||
78 | hyprland-share-picker | ||