summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Schanzenbacher <ryan@rschanz.org>2024-10-19 20:53:35 -0400
committerRyan Schanzenbacher <ryan@rschanz.org>2024-10-19 20:53:35 -0400
commitbde398cb8c3dd49ec9d726ef9bef8e6c99766c46 (patch)
tree34fa1713a0ddbbb661e39f5225d197f962125698
parent260a2e3d681bea7a71596a8db244a3bc9d096bbc (diff)
got portals working again for screensharing
-rwxr-xr-xhome-config/hypr/autostart.sh18
-rw-r--r--home-config/nix-home-manager/flake.lock98
-rw-r--r--home-config/nix-home-manager/flake.nix7
-rw-r--r--home-config/nix-home-manager/home.nix8
4 files changed, 25 insertions, 106 deletions
diff --git a/home-config/hypr/autostart.sh b/home-config/hypr/autostart.sh
index 6e64202..77ebae8 100755
--- a/home-config/hypr/autostart.sh
+++ b/home-config/hypr/autostart.sh
@@ -14,6 +14,20 @@ swayidle -w timeout 300 'swaylock --screenshots --clock --indicator --grace 3 --
14 14
15syncthing serve --no-browser & 15syncthing serve --no-browser &
16 16
17wl-clip-persist -c regular & 17# Kill any orphans of this
18killall wl-clip-persist
19wl-clip-persist -c regular --reconnect-tries 5 &
18 20
19kanshi -c ~/.config/hypr/kanshi.conf 21kanshi -c ~/.config/hypr/kanshi.conf &
22
23# Start the portals
24
25sleep 0.5
26killall -e xdg-desktop-portal-hyprland
27killall xdg-desktop-portal-gtk
28killall xdk-desktop-portal
29
30~/.nix-profile/libexec/xdg-desktop-portal-hyprland &
31~/.nix-profile/libexec/xdg-desktop-portal-gtk &
32sleep 2
33XDG_DESKTOP_PORTAL_DIR="/home/ryan/.nix-profile/share/xdg-desktop-portal/portals" ~/.nix-profile/libexec/xdg-desktop-portal &
diff --git a/home-config/nix-home-manager/flake.lock b/home-config/nix-home-manager/flake.lock
index 8a67541..8885a8c 100644
--- a/home-config/nix-home-manager/flake.lock
+++ b/home-config/nix-home-manager/flake.lock
@@ -207,67 +207,14 @@
207 "type": "github" 207 "type": "github"
208 } 208 }
209 }, 209 },
210 "hyprlang_2": {
211 "inputs": {
212 "hyprutils": [
213 "hyprlock",
214 "hyprutils"
215 ],
216 "nixpkgs": [
217 "hyprlock",
218 "nixpkgs"
219 ],
220 "systems": [
221 "hyprlock",
222 "systems"
223 ]
224 },
225 "locked": {
226 "lastModified": 1721324361,
227 "narHash": "sha256-BiJKO0IIdnSwHQBSrEJlKlFr753urkLE48wtt0UhNG4=",
228 "owner": "hyprwm",
229 "repo": "hyprlang",
230 "rev": "adbefbf49664a6c2c8bf36b6487fd31e3eb68086",
231 "type": "github"
232 },
233 "original": {
234 "owner": "hyprwm",
235 "repo": "hyprlang",
236 "type": "github"
237 }
238 },
239 "hyprlock": {
240 "inputs": {
241 "hyprlang": "hyprlang_2",
242 "hyprutils": "hyprutils_2",
243 "nixpkgs": [
244 "nixpkgs"
245 ],
246 "systems": "systems_2"
247 },
248 "locked": {
249 "lastModified": 1721563228,
250 "narHash": "sha256-w+AyYuqlZ/uWEimiptlHjtDFECm/JlUOD2ciCw8/+/8=",
251 "owner": "hyprwm",
252 "repo": "hyprlock",
253 "rev": "dba9d8b5175a6f23463035aafc6b0c741f9b73a5",
254 "type": "github"
255 },
256 "original": {
257 "owner": "hyprwm",
258 "ref": "v0.4.1",
259 "repo": "hyprlock",
260 "type": "github"
261 }
262 },
263 "hyprpicker-git": { 210 "hyprpicker-git": {
264 "inputs": { 211 "inputs": {
265 "hyprutils": "hyprutils_3", 212 "hyprutils": "hyprutils_2",
266 "hyprwayland-scanner": "hyprwayland-scanner_2", 213 "hyprwayland-scanner": "hyprwayland-scanner_2",
267 "nixpkgs": [ 214 "nixpkgs": [
268 "nixpkgs" 215 "nixpkgs"
269 ], 216 ],
270 "systems": "systems_3" 217 "systems": "systems_2"
271 }, 218 },
272 "locked": { 219 "locked": {
273 "lastModified": 1727732210, 220 "lastModified": 1727732210,
@@ -311,31 +258,6 @@
311 "hyprutils_2": { 258 "hyprutils_2": {
312 "inputs": { 259 "inputs": {
313 "nixpkgs": [ 260 "nixpkgs": [
314 "hyprlock",
315 "nixpkgs"
316 ],
317 "systems": [
318 "hyprlock",
319 "systems"
320 ]
321 },
322 "locked": {
323 "lastModified": 1721324102,
324 "narHash": "sha256-WAZ0X6yJW1hFG6otkHBfyJDKRpNP5stsRqdEuHrFRpk=",
325 "owner": "hyprwm",
326 "repo": "hyprutils",
327 "rev": "962582a090bc233c4de9d9897f46794280288989",
328 "type": "github"
329 },
330 "original": {
331 "owner": "hyprwm",
332 "repo": "hyprutils",
333 "type": "github"
334 }
335 },
336 "hyprutils_3": {
337 "inputs": {
338 "nixpkgs": [
339 "hyprpicker-git", 261 "hyprpicker-git",
340 "nixpkgs" 262 "nixpkgs"
341 ], 263 ],
@@ -449,7 +371,6 @@
449 "inputs": { 371 "inputs": {
450 "home-manager": "home-manager", 372 "home-manager": "home-manager",
451 "hyprland": "hyprland", 373 "hyprland": "hyprland",
452 "hyprlock": "hyprlock",
453 "hyprpicker-git": "hyprpicker-git", 374 "hyprpicker-git": "hyprpicker-git",
454 "nixgl": "nixgl", 375 "nixgl": "nixgl",
455 "nixpkgs": "nixpkgs" 376 "nixpkgs": "nixpkgs"
@@ -485,21 +406,6 @@
485 "type": "github" 406 "type": "github"
486 } 407 }
487 }, 408 },
488 "systems_3": {
489 "locked": {
490 "lastModified": 1689347949,
491 "narHash": "sha256-12tWmuL2zgBgZkdoB6qXZsgJEH9LR3oUgpaQq2RbI80=",
492 "owner": "nix-systems",
493 "repo": "default-linux",
494 "rev": "31732fcf5e8fea42e59c2488ad31a0e651500f68",
495 "type": "github"
496 },
497 "original": {
498 "owner": "nix-systems",
499 "repo": "default-linux",
500 "type": "github"
501 }
502 },
503 "xdph": { 409 "xdph": {
504 "inputs": { 410 "inputs": {
505 "hyprland-protocols": "hyprland-protocols_2", 411 "hyprland-protocols": "hyprland-protocols_2",
diff --git a/home-config/nix-home-manager/flake.nix b/home-config/nix-home-manager/flake.nix
index 9eb13bf..6429214 100644
--- a/home-config/nix-home-manager/flake.nix
+++ b/home-config/nix-home-manager/flake.nix
@@ -16,17 +16,13 @@
16 url = "github:hyprwm/hyprland/v0.44.1"; 16 url = "github:hyprwm/hyprland/v0.44.1";
17 inputs.nixpkgs.follows = "nixpkgs"; 17 inputs.nixpkgs.follows = "nixpkgs";
18 }; 18 };
19 hyprlock = {
20 url = "github:hyprwm/hyprlock/v0.4.1";
21 inputs.nixpkgs.follows = "nixpkgs";
22 };
23 nixgl = { 19 nixgl = {
24 url = "github:nix-community/nixGL"; 20 url = "github:nix-community/nixGL";
25 inputs.nixpkgs.follows = "nixpkgs"; 21 inputs.nixpkgs.follows = "nixpkgs";
26 }; 22 };
27 }; 23 };
28 24
29 outputs = { nixpkgs, home-manager, hyprpicker-git, hyprland, hyprlock, nixgl, ... }@inputs: 25 outputs = { nixpkgs, home-manager, hyprpicker-git, hyprland, nixgl, ... }@inputs:
30 let 26 let
31 system = "x86_64-linux"; 27 system = "x86_64-linux";
32 pkgs = nixpkgs.legacyPackages.${system}; 28 pkgs = nixpkgs.legacyPackages.${system};
@@ -47,7 +43,6 @@
47 _module.args = { 43 _module.args = {
48 inherit hyprland; 44 inherit hyprland;
49 inherit nixgl; 45 inherit nixgl;
50 inherit hyprlock;
51 }; 46 };
52 } 47 }
53 ]; 48 ];
diff --git a/home-config/nix-home-manager/home.nix b/home-config/nix-home-manager/home.nix
index c572a6f..a886c6a 100644
--- a/home-config/nix-home-manager/home.nix
+++ b/home-config/nix-home-manager/home.nix
@@ -1,4 +1,4 @@
1{ config, pkgs, hyprland, hyprlock, nixgl, ... }: 1{ config, pkgs, hyprland, nixgl, ... }:
2 2
3{ 3{
4 # Home Manager needs a bit of information about you and the paths it should 4 # Home Manager needs a bit of information about you and the paths it should
@@ -45,11 +45,15 @@
45 gdu 45 gdu
46 spotify-player 46 spotify-player
47 hyprpicker 47 hyprpicker
48 hyprlock
49 xwayland
50 xdg-desktop-portal
51 xdg-desktop-portal-gtk
48 52
49 # Flakes specific things defined in flake.nix 53 # Flakes specific things defined in flake.nix
50 hyprland.packages.${pkgs.system}.default 54 hyprland.packages.${pkgs.system}.default
55 hyprland.packages.${pkgs.system}.xdg-desktop-portal-hyprland
51 nixgl.packages.${pkgs.system}.nixGLIntel 56 nixgl.packages.${pkgs.system}.nixGLIntel
52 hyprlock.packages.${pkgs.system}.default
53 57
54 # Fonts! 58 # Fonts!
55 noto-fonts 59 noto-fonts