summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Schanzenbacher <ryan@rschanz.org>2024-10-28 22:55:28 -0400
committerRyan Schanzenbacher <ryan@rschanz.org>2024-10-28 22:55:28 -0400
commitc23b60f866a687aa6ae3618265f47ae63c9c5b64 (patch)
treec75d58973f8309cf9e996dfef751bed2608ef777
parent1c3f6332247dbd7f27bd89779a93bf39d5297f39 (diff)
wttr popup fix, firefox on nix, fontconfig fixes
-rw-r--r--home-config/home-configuration.scm24
-rw-r--r--home-config/hypr/hyprland.conf2
-rw-r--r--home-config/nix-home-manager/flake.lock274
-rw-r--r--home-config/nix-home-manager/flake.nix3
-rw-r--r--home-config/nix-home-manager/home.nix7
5 files changed, 233 insertions, 77 deletions
diff --git a/home-config/home-configuration.scm b/home-config/home-configuration.scm
index b9e95d0..683f6aa 100644
--- a/home-config/home-configuration.scm
+++ b/home-config/home-configuration.scm
@@ -15,6 +15,7 @@
15 (gnu home services shells) 15 (gnu home services shells)
16 (gnu home services desktop) 16 (gnu home services desktop)
17 (gnu home services gnupg) 17 (gnu home services gnupg)
18 (gnu home services fontutils)
18 (gnu home services) 19 (gnu home services)
19 (ryan-services pipewire) 20 (ryan-services pipewire)
20 (ryan-services spotify) 21 (ryan-services spotify)
@@ -134,7 +135,7 @@
134 "signal-desktop" 135 "signal-desktop"
135 "sc-im" 136 "sc-im"
136 "git-lfs")) 137 "git-lfs"))
137 (list my-neovim wl-mirror firefox-wrapped calcurse-fixed ))) 138 (list my-neovim wl-mirror calcurse-fixed )))
138 139
139 ;; Below is the list of Home services. To search for available 140 ;; Below is the list of Home services. To search for available
140 ;; services, run 'guix home search KEYWORD' in a terminal. 141 ;; services, run 'guix home search KEYWORD' in a terminal.
@@ -169,12 +170,31 @@
169 (".mozilla/native-messaging-hosts/tridactyl.json" ,(local-file "tridactyl/tridactyl.json")) 170 (".mozilla/native-messaging-hosts/tridactyl.json" ,(local-file "tridactyl/tridactyl.json"))
170 ;(".gnupg/sshcontrol" ,(local-file "gnupg/sshcontrol")) 171 ;(".gnupg/sshcontrol" ,(local-file "gnupg/sshcontrol"))
171 ;(".gnupg/gpg-agent.conf" ,(local-file "gnupg/gpg-agent.conf")) 172 ;(".gnupg/gpg-agent.conf" ,(local-file "gnupg/gpg-agent.conf"))
172 (".fonts" ,(local-file "fonts" #:recursive? #t)) 173 (".local/share/fonts" ,(local-file "fonts" #:recursive? #t))
173 (".gitconfig" ,(local-file "gitconfig")) 174 (".gitconfig" ,(local-file "gitconfig"))
174 (".docker/cli-plugins" ,(local-file "docker/cli-plugins" #:recursive? #t)) 175 (".docker/cli-plugins" ,(local-file "docker/cli-plugins" #:recursive? #t))
175 (".nix-channels" ,(local-file "nix-channels")))) 176 (".nix-channels" ,(local-file "nix-channels"))))
176 (service home-pipewire-service-type) 177 (service home-pipewire-service-type)
177 (service home-spotifyd-service-type) 178 (service home-spotifyd-service-type)
179 ; font things for nix to play nice
180 (simple-service 'additional-fonts-service
181 home-fontconfig-service-type
182 (list "~/.nix-profile/share/fonts"
183 '(match (@ (target "pattern"))
184 (edit (@ (name "family") (mode "prepend"))
185 (string "DejaVu Sans")))
186 '(alias
187 (family "serif")
188 (prefer
189 (family "DejaVu Serif")))
190 '(alias
191 (family "sans")
192 (prefer
193 (family "DejaVu Sans")))
194 '(alias
195 (family "monospace")
196 (prefer
197 (family "DejaVu Sans Mono")))))
178 (service home-dbus-service-type) 198 (service home-dbus-service-type)
179 ;;; trying some changes 199 ;;; trying some changes
180 ;(template-files "." 200 ;(template-files "."
diff --git a/home-config/hypr/hyprland.conf b/home-config/hypr/hyprland.conf
index c3e5049..12e97c5 100644
--- a/home-config/hypr/hyprland.conf
+++ b/home-config/hypr/hyprland.conf
@@ -241,7 +241,7 @@ windowrulev2 = suppressevent fullscreen maximize, class:^(firefox)$, title:^(Fir
241 241
242# Weather 242# Weather
243windowrulev2 = float,class:^(ala-wttr)$ 243windowrulev2 = float,class:^(ala-wttr)$
244windowrulev2 = size 740 712, class:^(ala-wttr)$ 244windowrulev2 = size 822 1026, class:^(ala-wttr)$
245 245
246# Floating terminal 246# Floating terminal
247windowrulev2 = float,class:^(float-foot)$ 247windowrulev2 = float,class:^(float-foot)$
diff --git a/home-config/nix-home-manager/flake.lock b/home-config/nix-home-manager/flake.lock
index f899e74..d350b50 100644
--- a/home-config/nix-home-manager/flake.lock
+++ b/home-config/nix-home-manager/flake.lock
@@ -2,29 +2,17 @@
2 "nodes": { 2 "nodes": {
3 "aquamarine": { 3 "aquamarine": {
4 "inputs": { 4 "inputs": {
5 "hyprutils": [ 5 "hyprutils": "hyprutils",
6 "hyprland", 6 "hyprwayland-scanner": "hyprwayland-scanner",
7 "hyprutils" 7 "nixpkgs": "nixpkgs",
8 ], 8 "systems": "systems"
9 "hyprwayland-scanner": [
10 "hyprland",
11 "hyprwayland-scanner"
12 ],
13 "nixpkgs": [
14 "hyprland",
15 "nixpkgs"
16 ],
17 "systems": [
18 "hyprland",
19 "systems"
20 ]
21 }, 9 },
22 "locked": { 10 "locked": {
23 "lastModified": 1727261104, 11 "lastModified": 1729527199,
24 "narHash": "sha256-rxDI7WrxIRV9it9mDCHcLa7xQykf1JloXnoXr5xQ8zI=", 12 "narHash": "sha256-D5/YksfRga8Akd04ZtIkuYSIOjXVrAzQIQBSeplokzU=",
25 "owner": "hyprwm", 13 "owner": "hyprwm",
26 "repo": "aquamarine", 14 "repo": "aquamarine",
27 "rev": "b82fdaff917582a9d568969e15e61b398c71e990", 15 "rev": "8d732fa8aff8b12ef2b1e2f00fc8153e41312b72",
28 "type": "github" 16 "type": "github"
29 }, 17 },
30 "original": { 18 "original": {
@@ -33,6 +21,22 @@
33 "type": "github" 21 "type": "github"
34 } 22 }
35 }, 23 },
24 "flake-compat": {
25 "flake": false,
26 "locked": {
27 "lastModified": 1696426674,
28 "narHash": "sha256-kvjfFW7WAETZlt09AgDn1MrtKzP7t90Vf7vypd3OL1U=",
29 "owner": "edolstra",
30 "repo": "flake-compat",
31 "rev": "0f9255e01c2351cc7d116c072cb317785dd33b33",
32 "type": "github"
33 },
34 "original": {
35 "owner": "edolstra",
36 "repo": "flake-compat",
37 "type": "github"
38 }
39 },
36 "flake-utils": { 40 "flake-utils": {
37 "locked": { 41 "locked": {
38 "lastModified": 1659877975, 42 "lastModified": 1659877975,
@@ -48,6 +52,28 @@
48 "type": "github" 52 "type": "github"
49 } 53 }
50 }, 54 },
55 "gitignore": {
56 "inputs": {
57 "nixpkgs": [
58 "hyprland",
59 "pre-commit-hooks",
60 "nixpkgs"
61 ]
62 },
63 "locked": {
64 "lastModified": 1709087332,
65 "narHash": "sha256-HG2cCnktfHsKV0s4XW83gU3F57gaTljL9KNSuG6bnQs=",
66 "owner": "hercules-ci",
67 "repo": "gitignore.nix",
68 "rev": "637db329424fd7e46cf4185293b9cc8c88c95394",
69 "type": "github"
70 },
71 "original": {
72 "owner": "hercules-ci",
73 "repo": "gitignore.nix",
74 "type": "github"
75 }
76 },
51 "home-manager": { 77 "home-manager": {
52 "inputs": { 78 "inputs": {
53 "nixpkgs": [ 79 "nixpkgs": [
@@ -85,11 +111,11 @@
85 ] 111 ]
86 }, 112 },
87 "locked": { 113 "locked": {
88 "lastModified": 1727532803, 114 "lastModified": 1728669738,
89 "narHash": "sha256-ZaZ7h7PY8mQc4vtGmVqWLAq9CAO02gHMyNR5yY8zDmM=", 115 "narHash": "sha256-EDNAU9AYcx8OupUzbTbWE1d3HYdeG0wO6Msg3iL1muk=",
90 "owner": "hyprwm", 116 "owner": "hyprwm",
91 "repo": "hyprcursor", 117 "repo": "hyprcursor",
92 "rev": "b98726e431d4d3ed58bd58bee1047cdb81cec69f", 118 "rev": "0264e698149fcb857a66a53018157b41f8d97bb0",
93 "type": "github" 119 "type": "github"
94 }, 120 },
95 "original": { 121 "original": {
@@ -104,25 +130,26 @@
104 "hyprcursor": "hyprcursor", 130 "hyprcursor": "hyprcursor",
105 "hyprland-protocols": "hyprland-protocols", 131 "hyprland-protocols": "hyprland-protocols",
106 "hyprlang": "hyprlang", 132 "hyprlang": "hyprlang",
107 "hyprutils": "hyprutils", 133 "hyprutils": "hyprutils_2",
108 "hyprwayland-scanner": "hyprwayland-scanner", 134 "hyprwayland-scanner": "hyprwayland-scanner_2",
109 "nixpkgs": [ 135 "nixpkgs": [
110 "nixpkgs" 136 "nixpkgs"
111 ], 137 ],
112 "systems": "systems", 138 "pre-commit-hooks": "pre-commit-hooks",
139 "systems": "systems_2",
113 "xdph": "xdph" 140 "xdph": "xdph"
114 }, 141 },
115 "locked": { 142 "locked": {
116 "lastModified": 1728478479, 143 "lastModified": 1729553322,
117 "narHash": "sha256-AbfdIlK92oWpI39xlIaUekPeL9u95sXzxVsSqhIMfIc=", 144 "narHash": "sha256-CjdhWsojvgZEr2t8eK6HaaWmLxirnaEckeXt/kveQNs=",
118 "owner": "hyprwm", 145 "owner": "hyprwm",
119 "repo": "hyprland", 146 "repo": "hyprland",
120 "rev": "4520b30d498daca8079365bdb909a8dea38e8d55", 147 "rev": "5e96d738e698f22969ca502d042d5751711c6d8a",
121 "type": "github" 148 "type": "github"
122 }, 149 },
123 "original": { 150 "original": {
124 "owner": "hyprwm", 151 "owner": "hyprwm",
125 "ref": "v0.44.1", 152 "ref": "main",
126 "repo": "hyprland", 153 "repo": "hyprland",
127 "type": "github" 154 "type": "github"
128 } 155 }
@@ -139,38 +166,11 @@
139 ] 166 ]
140 }, 167 },
141 "locked": { 168 "locked": {
142 "lastModified": 1727451107, 169 "lastModified": 1728345020,
143 "narHash": "sha256-qV9savtHwmZUa0eJE294WYJjKPGB2+bJhwByFShsVyo=", 170 "narHash": "sha256-xGbkc7U/Roe0/Cv3iKlzijIaFBNguasI31ynL2IlEoM=",
144 "owner": "hyprwm",
145 "repo": "hyprland-protocols",
146 "rev": "6b3261ee13a6d2b99de79a31d352f6996e35bde3",
147 "type": "github"
148 },
149 "original": {
150 "owner": "hyprwm",
151 "repo": "hyprland-protocols",
152 "type": "github"
153 }
154 },
155 "hyprland-protocols_2": {
156 "inputs": {
157 "nixpkgs": [
158 "hyprland",
159 "xdph",
160 "nixpkgs"
161 ],
162 "systems": [
163 "hyprland",
164 "xdph",
165 "systems"
166 ]
167 },
168 "locked": {
169 "lastModified": 1721326555,
170 "narHash": "sha256-zCu4R0CSHEactW9JqYki26gy8h9f6rHmSwj4XJmlHgg=",
171 "owner": "hyprwm", 171 "owner": "hyprwm",
172 "repo": "hyprland-protocols", 172 "repo": "hyprland-protocols",
173 "rev": "5a11232266bf1a1f5952d5b179c3f4b2facaaa84", 173 "rev": "a7c183800e74f337753de186522b9017a07a8cee",
174 "type": "github" 174 "type": "github"
175 }, 175 },
176 "original": { 176 "original": {
@@ -195,11 +195,11 @@
195 ] 195 ]
196 }, 196 },
197 "locked": { 197 "locked": {
198 "lastModified": 1725997860, 198 "lastModified": 1728168612,
199 "narHash": "sha256-d/rZ/fHR5l1n7PeyLw0StWMNLXVU9c4HFyfskw568so=", 199 "narHash": "sha256-AnB1KfiXINmuiW7BALYrKqcjCnsLZPifhb/7BsfPbns=",
200 "owner": "hyprwm", 200 "owner": "hyprwm",
201 "repo": "hyprlang", 201 "repo": "hyprlang",
202 "rev": "dfeb5811dd6485490cce18d6cc1e38a055eea876", 202 "rev": "f054f2e44d6a0b74607a6bc0f52dba337a3db38e",
203 "type": "github" 203 "type": "github"
204 }, 204 },
205 "original": { 205 "original": {
@@ -210,12 +210,12 @@
210 }, 210 },
211 "hyprpicker-git": { 211 "hyprpicker-git": {
212 "inputs": { 212 "inputs": {
213 "hyprutils": "hyprutils_2", 213 "hyprutils": "hyprutils_3",
214 "hyprwayland-scanner": "hyprwayland-scanner_2", 214 "hyprwayland-scanner": "hyprwayland-scanner_3",
215 "nixpkgs": [ 215 "nixpkgs": [
216 "nixpkgs" 216 "nixpkgs"
217 ], 217 ],
218 "systems": "systems_2" 218 "systems": "systems_3"
219 }, 219 },
220 "locked": { 220 "locked": {
221 "lastModified": 1727705155, 221 "lastModified": 1727705155,
@@ -236,19 +236,21 @@
236 "inputs": { 236 "inputs": {
237 "nixpkgs": [ 237 "nixpkgs": [
238 "hyprland", 238 "hyprland",
239 "aquamarine",
239 "nixpkgs" 240 "nixpkgs"
240 ], 241 ],
241 "systems": [ 242 "systems": [
242 "hyprland", 243 "hyprland",
244 "aquamarine",
243 "systems" 245 "systems"
244 ] 246 ]
245 }, 247 },
246 "locked": { 248 "locked": {
247 "lastModified": 1727300645, 249 "lastModified": 1728941256,
248 "narHash": "sha256-OvAtVLaSRPnbXzOwlR1fVqCXR7i+ICRX3aPMCdIiv+c=", 250 "narHash": "sha256-WRypmcZ2Bw94lLmcmxYokVOHPJSZ7T06V49QZ4tkZeQ=",
249 "owner": "hyprwm", 251 "owner": "hyprwm",
250 "repo": "hyprutils", 252 "repo": "hyprutils",
251 "rev": "3f5293432b6dc6a99f26aca2eba3876d2660665c", 253 "rev": "fd4be8b9ca932f7384e454bcd923c5451ef2aa85",
252 "type": "github" 254 "type": "github"
253 }, 255 },
254 "original": { 256 "original": {
@@ -260,6 +262,31 @@
260 "hyprutils_2": { 262 "hyprutils_2": {
261 "inputs": { 263 "inputs": {
262 "nixpkgs": [ 264 "nixpkgs": [
265 "hyprland",
266 "nixpkgs"
267 ],
268 "systems": [
269 "hyprland",
270 "systems"
271 ]
272 },
273 "locked": {
274 "lastModified": 1728941256,
275 "narHash": "sha256-WRypmcZ2Bw94lLmcmxYokVOHPJSZ7T06V49QZ4tkZeQ=",
276 "owner": "hyprwm",
277 "repo": "hyprutils",
278 "rev": "fd4be8b9ca932f7384e454bcd923c5451ef2aa85",
279 "type": "github"
280 },
281 "original": {
282 "owner": "hyprwm",
283 "repo": "hyprutils",
284 "type": "github"
285 }
286 },
287 "hyprutils_3": {
288 "inputs": {
289 "nixpkgs": [
263 "hyprpicker-git", 290 "hyprpicker-git",
264 "nixpkgs" 291 "nixpkgs"
265 ], 292 ],
@@ -286,10 +313,12 @@
286 "inputs": { 313 "inputs": {
287 "nixpkgs": [ 314 "nixpkgs": [
288 "hyprland", 315 "hyprland",
316 "aquamarine",
289 "nixpkgs" 317 "nixpkgs"
290 ], 318 ],
291 "systems": [ 319 "systems": [
292 "hyprland", 320 "hyprland",
321 "aquamarine",
293 "systems" 322 "systems"
294 ] 323 ]
295 }, 324 },
@@ -310,6 +339,31 @@
310 "hyprwayland-scanner_2": { 339 "hyprwayland-scanner_2": {
311 "inputs": { 340 "inputs": {
312 "nixpkgs": [ 341 "nixpkgs": [
342 "hyprland",
343 "nixpkgs"
344 ],
345 "systems": [
346 "hyprland",
347 "systems"
348 ]
349 },
350 "locked": {
351 "lastModified": 1726874836,
352 "narHash": "sha256-VKR0sf0PSNCB0wPHVKSAn41mCNVCnegWmgkrneKDhHM=",
353 "owner": "hyprwm",
354 "repo": "hyprwayland-scanner",
355 "rev": "500c81a9e1a76760371049a8d99e008ea77aa59e",
356 "type": "github"
357 },
358 "original": {
359 "owner": "hyprwm",
360 "repo": "hyprwayland-scanner",
361 "type": "github"
362 }
363 },
364 "hyprwayland-scanner_3": {
365 "inputs": {
366 "nixpkgs": [
313 "hyprpicker-git", 367 "hyprpicker-git",
314 "nixpkgs" 368 "nixpkgs"
315 ], 369 ],
@@ -356,6 +410,38 @@
356 }, 410 },
357 "nixpkgs": { 411 "nixpkgs": {
358 "locked": { 412 "locked": {
413 "lastModified": 1729413321,
414 "narHash": "sha256-I4tuhRpZFa6Fu6dcH9Dlo5LlH17peT79vx1y1SpeKt0=",
415 "owner": "NixOS",
416 "repo": "nixpkgs",
417 "rev": "1997e4aa514312c1af7e2bda7fad1644e778ff26",
418 "type": "github"
419 },
420 "original": {
421 "owner": "NixOS",
422 "ref": "nixos-unstable",
423 "repo": "nixpkgs",
424 "type": "github"
425 }
426 },
427 "nixpkgs-stable": {
428 "locked": {
429 "lastModified": 1720386169,
430 "narHash": "sha256-NGKVY4PjzwAa4upkGtAMz1npHGoRzWotlSnVlqI40mo=",
431 "owner": "NixOS",
432 "repo": "nixpkgs",
433 "rev": "194846768975b7ad2c4988bdb82572c00222c0d7",
434 "type": "github"
435 },
436 "original": {
437 "owner": "NixOS",
438 "ref": "nixos-24.05",
439 "repo": "nixpkgs",
440 "type": "github"
441 }
442 },
443 "nixpkgs_2": {
444 "locked": {
359 "lastModified": 1729168305, 445 "lastModified": 1729168305,
360 "narHash": "sha256-jmhxZnrlOyLEMUL2+JkVfkN0XWXI5uE6EB5kVZFR0fo=", 446 "narHash": "sha256-jmhxZnrlOyLEMUL2+JkVfkN0XWXI5uE6EB5kVZFR0fo=",
361 "owner": "nixos", 447 "owner": "nixos",
@@ -370,13 +456,37 @@
370 "type": "github" 456 "type": "github"
371 } 457 }
372 }, 458 },
459 "pre-commit-hooks": {
460 "inputs": {
461 "flake-compat": "flake-compat",
462 "gitignore": "gitignore",
463 "nixpkgs": [
464 "hyprland",
465 "nixpkgs"
466 ],
467 "nixpkgs-stable": "nixpkgs-stable"
468 },
469 "locked": {
470 "lastModified": 1728778939,
471 "narHash": "sha256-WybK5E3hpGxtCYtBwpRj1E9JoiVxe+8kX83snTNaFHE=",
472 "owner": "cachix",
473 "repo": "git-hooks.nix",
474 "rev": "ff68f91754be6f3427e4986d7949e6273659be1d",
475 "type": "github"
476 },
477 "original": {
478 "owner": "cachix",
479 "repo": "git-hooks.nix",
480 "type": "github"
481 }
482 },
373 "root": { 483 "root": {
374 "inputs": { 484 "inputs": {
375 "home-manager": "home-manager", 485 "home-manager": "home-manager",
376 "hyprland": "hyprland", 486 "hyprland": "hyprland",
377 "hyprpicker-git": "hyprpicker-git", 487 "hyprpicker-git": "hyprpicker-git",
378 "nixgl": "nixgl", 488 "nixgl": "nixgl",
379 "nixpkgs": "nixpkgs" 489 "nixpkgs": "nixpkgs_2"
380 } 490 }
381 }, 491 },
382 "systems": { 492 "systems": {
@@ -409,9 +519,27 @@
409 "type": "github" 519 "type": "github"
410 } 520 }
411 }, 521 },
522 "systems_3": {
523 "locked": {
524 "lastModified": 1689347949,
525 "narHash": "sha256-12tWmuL2zgBgZkdoB6qXZsgJEH9LR3oUgpaQq2RbI80=",
526 "owner": "nix-systems",
527 "repo": "default-linux",
528 "rev": "31732fcf5e8fea42e59c2488ad31a0e651500f68",
529 "type": "github"
530 },
531 "original": {
532 "owner": "nix-systems",
533 "repo": "default-linux",
534 "type": "github"
535 }
536 },
412 "xdph": { 537 "xdph": {
413 "inputs": { 538 "inputs": {
414 "hyprland-protocols": "hyprland-protocols_2", 539 "hyprland-protocols": [
540 "hyprland",
541 "hyprland-protocols"
542 ],
415 "hyprlang": [ 543 "hyprlang": [
416 "hyprland", 544 "hyprland",
417 "hyprlang" 545 "hyprlang"
@@ -434,11 +562,11 @@
434 ] 562 ]
435 }, 563 },
436 "locked": { 564 "locked": {
437 "lastModified": 1727524473, 565 "lastModified": 1728166987,
438 "narHash": "sha256-1DGktDtSWIJpnDbVoj/qpvJSH5zg6JbOfuh6xqZMap0=", 566 "narHash": "sha256-w6dVTguAn9zJ+7aPOhBQgDz8bn6YZ7b56cY8Kg5HJRI=",
439 "owner": "hyprwm", 567 "owner": "hyprwm",
440 "repo": "xdg-desktop-portal-hyprland", 568 "repo": "xdg-desktop-portal-hyprland",
441 "rev": "7e500e679ede40e79cf2d89b5f5fa3e34923bd26", 569 "rev": "fb9c8d665af0588bb087f97d0f673ddf0d501787",
442 "type": "github" 570 "type": "github"
443 }, 571 },
444 "original": { 572 "original": {
diff --git a/home-config/nix-home-manager/flake.nix b/home-config/nix-home-manager/flake.nix
index 7ba72b4..419cf50 100644
--- a/home-config/nix-home-manager/flake.nix
+++ b/home-config/nix-home-manager/flake.nix
@@ -13,8 +13,9 @@
13 inputs.nixpkgs.follows = "nixpkgs"; 13 inputs.nixpkgs.follows = "nixpkgs";
14 }; 14 };
15 hyprland = { 15 hyprland = {
16 url = "github:hyprwm/hyprland/v0.44.1"; 16 url = "github:hyprwm/hyprland/main";
17 inputs.nixpkgs.follows = "nixpkgs"; 17 inputs.nixpkgs.follows = "nixpkgs";
18 inputs.aquamarine.url = "github:hyprwm/aquamarine/main";
18 }; 19 };
19 nixgl = { 20 nixgl = {
20 url = "github:nix-community/nixGL/310f8e49a149e4c9ea52f1adf70cdc768ec53f8a"; 21 url = "github:nix-community/nixGL/310f8e49a149e4c9ea52f1adf70cdc768ec53f8a";
diff --git a/home-config/nix-home-manager/home.nix b/home-config/nix-home-manager/home.nix
index 210523d..031e76a 100644
--- a/home-config/nix-home-manager/home.nix
+++ b/home-config/nix-home-manager/home.nix
@@ -20,6 +20,11 @@
20 nixpkgs.config.allowUnfree = true; 20 nixpkgs.config.allowUnfree = true;
21 #targets.genericLinux.enable = true; 21 #targets.genericLinux.enable = true;
22 fonts.fontconfig.enable = true; 22 fonts.fontconfig.enable = true;
23 fonts.fontconfig.defaultFonts = {
24 monospace = [ "DejaVu Sans Mono" ];
25 sansSerif = [ "DejaVu Sans" ];
26 serif = [ "DejaVu Serif" ];
27 };
23 28
24 # wayland.windowManager.hyprland.enable = true; 29 # wayland.windowManager.hyprland.enable = true;
25 30
@@ -53,6 +58,8 @@
53 libvdpau 58 libvdpau
54 wpaperd 59 wpaperd
55 hypridle 60 hypridle
61 firefox
62 eza
56 63
57 # Wrapped programs for some env variables 64 # Wrapped programs for some env variables
58 (pkgs.writeScriptBin "hyprlock" '' 65 (pkgs.writeScriptBin "hyprlock" ''