summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Schanzenbacher <ryan@rschanz.org>2025-01-23 09:15:03 -0500
committerRyan Schanzenbacher <ryan@rschanz.org>2025-01-23 09:15:03 -0500
commitcd99ce84467b2d6140cf6805f80669d274d12274 (patch)
treec31399864195b7846c39702d37e4398364535aee
parent479e112a8b9dd711569310414dd9919b38373601 (diff)
Updated bashrc to use eza and delta, installed delta.
Updated nix flake to use deterministic commits again
-rw-r--r--home-config/bashrc6
-rw-r--r--home-config/nix-home-manager/flake.lock12
-rw-r--r--home-config/nix-home-manager/flake.nix4
-rw-r--r--home-config/nix-home-manager/home.nix1
4 files changed, 15 insertions, 8 deletions
diff --git a/home-config/bashrc b/home-config/bashrc
index 386a2db..05b0c3f 100644
--- a/home-config/bashrc
+++ b/home-config/bashrc
@@ -54,5 +54,11 @@ export GPG_TTY=$(tty)
54# Zoxide 54# Zoxide
55eval "$(zoxide init --cmd cd bash)" 55eval "$(zoxide init --cmd cd bash)"
56 56
57# eza
58alias ls='eza --icons=always -Gx'
59
60# Delta
61alias diff='delta'
62
57# Starship 63# Starship
58eval "$(starship init bash)" 64eval "$(starship init bash)"
diff --git a/home-config/nix-home-manager/flake.lock b/home-config/nix-home-manager/flake.lock
index ae044f1..e938810 100644
--- a/home-config/nix-home-manager/flake.lock
+++ b/home-config/nix-home-manager/flake.lock
@@ -8,11 +8,11 @@
8 "systems": "systems" 8 "systems": "systems"
9 }, 9 },
10 "locked": { 10 "locked": {
11 "lastModified": 1736702516, 11 "lastModified": 1737636397,
12 "narHash": "sha256-NbJiiPFnmciji3JHpqF/L0SdMQXKXn+q3Q/D8RjF/ak=", 12 "narHash": "sha256-F5MbBj3QVorycVSFE9qjuOTLtIQBqt2VWbXa0uwzm98=",
13 "owner": "hyprwm", 13 "owner": "hyprwm",
14 "repo": "aquamarine", 14 "repo": "aquamarine",
15 "rev": "e7719f9b9f5321c7100733773ad9f38cb6db6b6f", 15 "rev": "7fe006981fae53e931f513026fc754e322f13145",
16 "type": "github" 16 "type": "github"
17 }, 17 },
18 "original": { 18 "original": {
@@ -584,15 +584,15 @@
584 "locked": { 584 "locked": {
585 "lastModified": 1736159088, 585 "lastModified": 1736159088,
586 "narHash": "sha256-WDBc35XdHCdmgVYbPOtd2IeUtUHCYwNyEpIr5vLZMng=", 586 "narHash": "sha256-WDBc35XdHCdmgVYbPOtd2IeUtUHCYwNyEpIr5vLZMng=",
587 "owner": "bb010g", 587 "owner": "ryan77627",
588 "repo": "nixGL", 588 "repo": "nixGL",
589 "rev": "3865170cbc23b32ec7cc8df1ec811fd44b6c2a58", 589 "rev": "3865170cbc23b32ec7cc8df1ec811fd44b6c2a58",
590 "type": "github" 590 "type": "github"
591 }, 591 },
592 "original": { 592 "original": {
593 "owner": "bb010g", 593 "owner": "ryan77627",
594 "ref": "main",
595 "repo": "nixGL", 594 "repo": "nixGL",
595 "rev": "3865170cbc23b32ec7cc8df1ec811fd44b6c2a58",
596 "type": "github" 596 "type": "github"
597 } 597 }
598 }, 598 },
diff --git a/home-config/nix-home-manager/flake.nix b/home-config/nix-home-manager/flake.nix
index 9dd2bec..f600506 100644
--- a/home-config/nix-home-manager/flake.nix
+++ b/home-config/nix-home-manager/flake.nix
@@ -19,10 +19,10 @@
19 hyprland = { 19 hyprland = {
20 url = "github:hyprwm/hyprland/0dc7367a7006cc3cc877d52bf34c4998144bff84"; 20 url = "github:hyprwm/hyprland/0dc7367a7006cc3cc877d52bf34c4998144bff84";
21 inputs.nixpkgs.follows = "nixpkgs"; 21 inputs.nixpkgs.follows = "nixpkgs";
22 inputs.aquamarine.url = "github:hyprwm/aquamarine/main"; 22 inputs.aquamarine.url = "github:hyprwm/aquamarine/7fe006981fae53e931f513026fc754e322f13145";
23 }; 23 };
24 nixgl = { 24 nixgl = {
25 url = "github:bb010g/nixGL/main"; 25 url = "github:ryan77627/nixGL/3865170cbc23b32ec7cc8df1ec811fd44b6c2a58";
26 inputs.nixpkgs.follows = "nixpkgs"; 26 inputs.nixpkgs.follows = "nixpkgs";
27 }; 27 };
28 wpaperd = { 28 wpaperd = {
diff --git a/home-config/nix-home-manager/home.nix b/home-config/nix-home-manager/home.nix
index 54b6060..cf1b56e 100644
--- a/home-config/nix-home-manager/home.nix
+++ b/home-config/nix-home-manager/home.nix
@@ -398,6 +398,7 @@
398 wl-mirror 398 wl-mirror
399 starship 399 starship
400 taskwarrior3 400 taskwarrior3
401 delta
401 402
402 # Wrapped programs for some env variables 403 # Wrapped programs for some env variables
403 (pkgs.writeScriptBin "hyprlock" '' 404 (pkgs.writeScriptBin "hyprlock" ''