summaryrefslogtreecommitdiff
path: root/home-config/fish/config.fish
diff options
context:
space:
mode:
authorRyan Schanzenbacher <ryan@rschanz.org>2024-04-10 20:13:45 -0400
committerRyan Schanzenbacher <ryan@rschanz.org>2024-04-10 20:13:45 -0400
commit9026be364d5e7ec04c739bfbc5fcc20b03bddf43 (patch)
tree486c2ca7e1a0fd15739be9d37dd7774b62fb948a /home-config/fish/config.fish
parentb88d77fb2d0d5028a6f5670695dee6bec129501f (diff)
FISH
Diffstat (limited to 'home-config/fish/config.fish')
-rw-r--r--home-config/fish/config.fish7
1 files changed, 7 insertions, 0 deletions
diff --git a/home-config/fish/config.fish b/home-config/fish/config.fish
index f300cfe..5cbc322 100644
--- a/home-config/fish/config.fish
+++ b/home-config/fish/config.fish
@@ -7,9 +7,16 @@ if status is-interactive
7 alias gc "git -C ~/.config/guix add . && git -C ~/.config/guix commit && git -C ~/.config/guix push all" 7 alias gc "git -C ~/.config/guix add . && git -C ~/.config/guix commit && git -C ~/.config/guix push all"
8 alias cg "git -C ~/.config/guix pull" 8 alias cg "git -C ~/.config/guix pull"
9 alias cgh "git -C ~/.config/guix pull stationeryh main" 9 alias cgh "git -C ~/.config/guix pull stationeryh main"
10 alias python "python3"
11 alias spt "spotify_player"
12 alias ls "ls -p --color=auto"
13 alias grep "grep --color=auto"
14 alias ll "ls -l"
10 set -gx EDITOR nvim 15 set -gx EDITOR nvim
11 set -gax XDG_DATA_DIRS ~/.nix-profile/share 16 set -gax XDG_DATA_DIRS ~/.nix-profile/share
12 fish_add_path ~/.local/bin 17 fish_add_path ~/.local/bin
13 fish_add_path ~/.nix-profile/bin 18 fish_add_path ~/.nix-profile/bin
14 19
20 zoxide init fish | source
21
15end 22end