summaryrefslogtreecommitdiff
path: root/home-config/fish/config.fish
diff options
context:
space:
mode:
authorRyan Schanzenbacher <ryan@rschanz.org>2024-04-21 18:31:34 -0400
committerRyan Schanzenbacher <ryan@rschanz.org>2024-04-21 18:31:34 -0400
commit9c7803603fb56042ab97abc3e6a6c01acb598ebf (patch)
tree28108df1fcf137c404dc21bffcd709ca7925da9a /home-config/fish/config.fish
parent8a48a5775072430da4cc37f815b00d81db7283b4 (diff)
updated things and fish stuff
Diffstat (limited to 'home-config/fish/config.fish')
-rw-r--r--home-config/fish/config.fish10
1 files changed, 7 insertions, 3 deletions
diff --git a/home-config/fish/config.fish b/home-config/fish/config.fish
index 4705a90..3ccd0cb 100644
--- a/home-config/fish/config.fish
+++ b/home-config/fish/config.fish
@@ -4,17 +4,21 @@ if status is-login
4 -p ~/.guix-profile \ 4 -p ~/.guix-profile \
5 -p /run/current-system/profile)" 5 -p /run/current-system/profile)"
6 6
7 fenv source /etc/profile
8 set -gx HOME_ENVIRONMENT $HOME/.guix-home
9 fenv source $HOME_ENVIRONMENT/setup-environment
10 fenv $HOME_ENVIRONMENT/on-first-login
7 fish_add_path -Pp ~/.local/bin 11 fish_add_path -Pp ~/.local/bin
8 fish_add_path -Pp ~/.guix-home/profile/bin 12 fish_add_path -Pp ~/.guix-home/profile/bin
9 fish_add_path -Pp /run/setuid-programs 13 fish_add_path -Pp /run/setuid-programs
10 fish_add_path -Pp ~/.nix-profile/bin 14 fish_add_path -Pp ~/.nix-profile/bin
11 set -gx EDITOR nvim 15 set -gx EDITOR nvim
12 set -gax XDG_DATA_DIRS ~/.nix-profile/share 16 set -gax --path XDG_DATA_DIRS ~/.nix-profile/share
13 fenv source ~/.profile
14 # Bad 17 # Bad
15 find ~/.config/fish/ -name "*tmp*" -exec {} + 18 find ~/.config/fish/ -name "*tmp*" -exec rm {} +
16end 19end
17if status is-interactive 20if status is-interactive
21 set -gax --path XDG_DATA_DIRS ~/.local/share/flatpak/exports/share
18 # Commands to run in interactive sessions can go here 22 # Commands to run in interactive sessions can go here
19 alias quit exit 23 alias quit exit
20 alias cat "bat --paging=never" 24 alias cat "bat --paging=never"