summaryrefslogtreecommitdiff
path: root/home-config/home-configuration.scm
diff options
context:
space:
mode:
authorRyan Schanzenbacher <ryan@rschanz.org>2024-01-13 23:55:15 -0500
committerRyan Schanzenbacher <ryan@rschanz.org>2024-01-13 23:55:15 -0500
commit12e3af575860ca4cdbcef6fd2267ebd6befe0f49 (patch)
tree22516cc9e4e488e24c50384c504bc7ef59340bf6 /home-config/home-configuration.scm
parent67bd380ad4a43ee9ed084b701ed2c685564a7fa2 (diff)
Added spotify-player and spotifyd service
Diffstat (limited to 'home-config/home-configuration.scm')
-rw-r--r--home-config/home-configuration.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/home-config/home-configuration.scm b/home-config/home-configuration.scm
index 5c4eb8b..3651d6c 100644
--- a/home-config/home-configuration.scm
+++ b/home-config/home-configuration.scm
@@ -17,6 +17,7 @@
17 (gnu home services gnupg) 17 (gnu home services gnupg)
18 (gnu home services) 18 (gnu home services)
19 (ryan-services pipewire) 19 (ryan-services pipewire)
20 (ryan-services spotify)
20 (ryan-packages freedesktop) 21 (ryan-packages freedesktop)
21 (ryan-packages mozilla)) 22 (ryan-packages mozilla))
22 23
@@ -128,6 +129,7 @@
128 ("sway" ,(local-file "sway" #:recursive? #t)) 129 ("sway" ,(local-file "sway" #:recursive? #t))
129 ("hypr" ,(local-file "hypr" #:recursive? #t)) 130 ("hypr" ,(local-file "hypr" #:recursive? #t))
130 ("foot" ,(local-file "foot" #:recursive? #t)) 131 ("foot" ,(local-file "foot" #:recursive? #t))
132 ("spotify-player" ,(local-file "spotify-player" #:recursive? #t))
131 ("pulse/client.conf" ,(local-file "pulseaudio/client.conf")) 133 ("pulse/client.conf" ,(local-file "pulseaudio/client.conf"))
132 ("waybar" ,(local-file "waybar" #:recursive? #t)) 134 ("waybar" ,(local-file "waybar" #:recursive? #t))
133 ("alacritty" ,(local-file "alacritty" #:recursive? #t)) 135 ("alacritty" ,(local-file "alacritty" #:recursive? #t))
@@ -142,6 +144,7 @@
142 (".docker/cli-plugins" ,(local-file "docker/cli-plugins" #:recursive? #t)) 144 (".docker/cli-plugins" ,(local-file "docker/cli-plugins" #:recursive? #t))
143 (".nix-channels" ,(local-file "nix-channels")))) 145 (".nix-channels" ,(local-file "nix-channels"))))
144 (service home-pipewire-service-type) 146 (service home-pipewire-service-type)
147 (service home-spotifyd-service-type)
145 (service home-dbus-service-type) 148 (service home-dbus-service-type)
146 (service home-gpg-agent-service-type 149 (service home-gpg-agent-service-type
147 (home-gpg-agent-configuration 150 (home-gpg-agent-configuration