summaryrefslogtreecommitdiff
path: root/home-config/nix-home-manager/firefox-nightly/default.nix
diff options
context:
space:
mode:
authorRyan Schanzenbacher <ryan@rschanz.org>2025-03-03 13:15:12 -0500
committerRyan Schanzenbacher <ryan@rschanz.org>2025-03-03 13:15:12 -0500
commitaa1a1e82efa8921fa120662da960cdaf381c4680 (patch)
tree823176bed44d8c265afdbb4abbf3b3752c436958 /home-config/nix-home-manager/firefox-nightly/default.nix
parentbd9bdb7ba66a5a22ebab2d04d65a281872e77b96 (diff)
updates to channels, new cursor, probably other fixes idk
Diffstat (limited to 'home-config/nix-home-manager/firefox-nightly/default.nix')
-rw-r--r--home-config/nix-home-manager/firefox-nightly/default.nix201
1 files changed, 201 insertions, 0 deletions
diff --git a/home-config/nix-home-manager/firefox-nightly/default.nix b/home-config/nix-home-manager/firefox-nightly/default.nix
new file mode 100644
index 0000000..d341348
--- /dev/null
+++ b/home-config/nix-home-manager/firefox-nightly/default.nix
@@ -0,0 +1,201 @@
1{ config, pkgs, mozff, ...}:
2
3let
4
5wrapped-ff-nightly = pkgs.wrapFirefox mozff.packages.${pkgs.system}.firefox-nightly-bin {
6 extraPolicies = import ./policies.nix;
7};
8
9in
10
11{
12 programs.firefox = {
13 enable = true;
14 package = mozff.packages.${pkgs.system}.firefox-nightly-bin;
15 policies = import ./policies.nix;
16
17 profiles.${config.home.username} = {
18 name = "${config.home.username}";
19 isDefault = true;
20 containersForce = true;
21 containers = {
22 rit = {
23 name = "RIT";
24 color = "orange";
25 icon = "dollar";
26 id = 1;
27 };
28 ritwork = {
29 name = "RIT Work";
30 color = "green";
31 icon = "briefcase";
32 id = 2;
33 };
34 other = {
35 name = "Other";
36 color = "blue";
37 icon = "fingerprint";
38 id = 3;
39 };
40 };
41 search = {
42 force = true;
43 default = "DuckDuckGo";
44 order = ["DuckDuckGo" "Google"];
45 engines = {
46 "Nix Packages" = {
47 urls = [
48 {
49 template = "https://search.nixos.org/packages";
50 params = [
51 {
52 name = "type";
53 value = "packages";
54 }
55 {
56 name = "channel";
57 value = "unstable";
58 }
59 {
60 name = "query";
61 value = "{searchTerms}";
62 }
63 ];
64 }
65 ];
66 icon = "${pkgs.nixos-icons}/share/icons/hicolor/scalable/apps/nix-snowflake.svg";
67 definedAliases = ["@np"];
68 };
69 };
70 };
71 userChrome = "
72#main-window .toolbar-items {
73overflow: hidden;
74transition: height 0.3s 0.3s !important;
75}
76/* Default state: Set initial height to enable animation */
77#main-window .toolbar-items { height: 3em !important; }
78#main-window .titlebar-button { height: 3em !important; }
79#main-window[uidensity=\"touch\"] .toolbar-items { height: 3.35em !important; }
80#main-window[uidensity=\"compact\"] .toolbar-items { height: 2.7em !important; }
81/* Hidden state: Hide native tabs strip */
82#main-window[titlepreface*=\"\"] .toolbar-items { height: 0 !important; }
83#main-window[titlepreface*=\"\"] .titlebar-button { height: 0 !important; }
84/* Hidden state: Fix z-index of active pinned tabs */
85#main-window[titlepreface*=\"\"] #tabbrowser-tabs { z-index: 0 !important; }
86
87/* Sidebery expand on mouse-over and hide otherwise */
88
89/* Source file https://github.com/MrOtherGuy/firefox-csshacks/tree/master/chrome/autohide_sidebar.css made available under Mozilla Public License v. 2.0
90See the above repository for updates as well as full license text. */
91
92/* Show sidebar only when the cursor is over it */
93/* The border controlling sidebar width will be removed so you'll need to modify these values to change width */
94
95#sidebar-box{
96--uc-sidebar-width: 60px;
97--uc-sidebar-hover-width: 230px;
98--uc-autohide-sidebar-delay: 200ms; /* Wait 0.2s before hiding sidebar */
99--uc-autohide-transition-duration: 115ms;
100--uc-autohide-transition-type: linear;
101--browser-area-z-index-sidebar: 3;
102position: relative;
103 min-width: var(--uc-sidebar-width) !important;
104width: var(--uc-sidebar-width) !important;
105 max-width: var(--uc-sidebar-width) !important;
106 z-index: var(--browser-area-z-index-sidebar,3);
107}
108#sidebar-box[positionend]{ direction: rtl }
109#sidebar-box[positionend] > *{ direction: ltr }
110
111#sidebar-box[positionend]:-moz-locale-dir(rtl){ direction: ltr }
112#sidebar-box[positionend]:-moz-locale-dir(rtl) > *{ direction: rtl }
113
114#main-window[sizemode=\"fullscreen\"] #sidebar-box{ --uc-sidebar-width: 1px; }
115
116#sidebar-splitter{ display: none }
117
118#sidebar-header{
119overflow: hidden;
120color: var(--chrome-color, inherit) !important;
121 padding-inline: 0 !important;
122}
123
124#sidebar-header::before,
125#sidebar-header::after{
126content: \"\";
127display: flex;
128 padding-left: 8px;
129}
130
131#sidebar-header,
132#sidebar{
133transition: min-width var(--uc-autohide-transition-duration) var(--uc-autohide-transition-type) var(--uc-autohide-sidebar-delay) !important;
134 min-width: var(--uc-sidebar-width) !important;
135 will-change: min-width;
136}
137#sidebar-box:hover > #sidebar-header,
138#sidebar-box:hover > #sidebar{
139min-width: var(--uc-sidebar-hover-width) !important;
140transition-delay: 0ms !important;
141}
142
143.sidebar-panel{
144background-color: transparent !important;
145color: var(--newtab-text-primary-color) !important;
146}
147
148.sidebar-panel #search-box{
149-moz-appearance: none !important;
150background-color: rgba(249,249,250,0.1) !important;
151color: inherit !important;
152}
153
154/* Add sidebar divider and give it background */
155
156#sidebar,
157#sidebar-header{
158background-color: inherit !important;
159border-inline: 1px solid rgb(80,80,80);
160border-inline-width: 0px 1px;
161}
162
163#sidebar-box:not([positionend]) > :-moz-locale-dir(rtl),
164#sidebar-box[positionend] > *{
165border-inline-width: 1px 0px;
166}
167
168/* Move statuspanel to the other side when sidebar is hovered so it doesn't get covered by sidebar */
169
170#sidebar-box:not([positionend]):hover ~ #appcontent #statuspanel{
171inset-inline: auto 0px !important;
172}
173#sidebar-box:not([positionend]):hover ~ #appcontent #statuspanel-label{
174margin-inline: 0px !important;
175border-left-style: solid !important;
176}
177
178/* Remove the tabs label and move the Sidebary icon to the center of the box */
179#sidebar-box:hover [id=\"sidebar-icon\"] {
180transform: translateX(0px) !important;
181 transition-delay: 0ms !important;
182}
183
184#sidebar-box [id=\"sidebar-icon\"] {
185transform: translateX(9px);
186transition: transform var(--uc-autohide-transition-duration) var(--uc-autohide-transition-type) var(--uc-autohide-sidebar-delay) !important;
187}
188
189#sidebar-box [id=\"sidebar-title\"] {
190visibility: hidden !important;
191transition: visibility var(--uc-autohide-transition-duration) var(--uc-autohide-transition-type) var(--uc-autohide-sidebar-delay) !important;
192}
193
194#sidebar-box:hover [id=\"sidebar-title\"] {
195visibility: visible !important;
196 transition-delay: 0ms !important;
197}
198";
199};
200};
201}