summaryrefslogtreecommitdiff
path: root/home-config/nix-home-manager/flake.nix
diff options
context:
space:
mode:
authorRyan Schanzenbacher <ryan@rschanz.org>2025-04-01 11:26:04 -0400
committerRyan Schanzenbacher <ryan@rschanz.org>2025-04-01 11:26:04 -0400
commitd465e92647470759177cb63914fd3571cea7a8a4 (patch)
treec2a27471bd33c7e3e53688c89758544664b89ac0 /home-config/nix-home-manager/flake.nix
parent365a13de3e19c66f6bb2ffb806e8086a068ffc25 (diff)
Using Zen, added nix update to be upstreamed
Diffstat (limited to 'home-config/nix-home-manager/flake.nix')
-rw-r--r--home-config/nix-home-manager/flake.nix13
1 files changed, 9 insertions, 4 deletions
diff --git a/home-config/nix-home-manager/flake.nix b/home-config/nix-home-manager/flake.nix
index ba3d01a..38b0708 100644
--- a/home-config/nix-home-manager/flake.nix
+++ b/home-config/nix-home-manager/flake.nix
@@ -3,9 +3,9 @@
3 3
4 inputs = { 4 inputs = {
5 # Specify the source of Home Manager and Nixpkgs. 5 # Specify the source of Home Manager and Nixpkgs.
6 nixpkgs.url = "github:nixos/nixpkgs/d74a2335ac9c133d6bbec9fc98d91a77f1604c1f"; 6 nixpkgs.url = "github:nixos/nixpkgs/a84ebe20c6bc2ecbcfb000a50776219f48d134cc";
7 home-manager = { 7 home-manager = {
8 url = "github:nix-community/home-manager/53c587d263f94aaf6a281745923c76bbec62bcf3"; 8 url = "github:nix-community/home-manager/693840c01b9bef9e54100239cef937e53d4661bf";
9 inputs.nixpkgs.follows = "nixpkgs"; 9 inputs.nixpkgs.follows = "nixpkgs";
10 }; 10 };
11 hyprlock = { 11 hyprlock = {
@@ -17,7 +17,7 @@
17 inputs.nixpkgs.follows = "nixpkgs"; 17 inputs.nixpkgs.follows = "nixpkgs";
18 }; 18 };
19 hyprland = { 19 hyprland = {
20 url = "github:hyprwm/hyprland/v0.47.2"; 20 url = "github:hyprwm/hyprland/v0.48.0";
21 inputs.nixpkgs.follows = "nixpkgs"; 21 inputs.nixpkgs.follows = "nixpkgs";
22 #inputs.hyprutils.url = "github:/hyprwm/hyprutils/6a8bc9d2a4451df12f5179dc0b1d2d46518a90ab"; 22 #inputs.hyprutils.url = "github:/hyprwm/hyprutils/6a8bc9d2a4451df12f5179dc0b1d2d46518a90ab";
23 }; 23 };
@@ -42,9 +42,13 @@
42 inputs.hyprland.follows = "hyprland"; 42 inputs.hyprland.follows = "hyprland";
43 inputs.nixpkgs.follows = "hyprland/nixpkgs"; 43 inputs.nixpkgs.follows = "hyprland/nixpkgs";
44 }; 44 };
45 zen-browser = {
46 url = "github:0xc000022070/zen-browser-flake/bef72020b20475847f24cd27134dca06724d4ba7";
47 inputs.nixpkgs.follows = "nixpkgs";
48 };
45 }; 49 };
46 50
47 outputs = { nixpkgs, home-manager, hyprland, nixgl, wpaperd, hyprpicker-git, hyprlock, mozff, clipboard-sync, hypr-dynamic-cursors, ... }@inputs: 51 outputs = { nixpkgs, home-manager, hyprland, nixgl, wpaperd, hyprpicker-git, hyprlock, mozff, clipboard-sync, hypr-dynamic-cursors, zen-browser, ... }@inputs:
48 let 52 let
49 system = "x86_64-linux"; 53 system = "x86_64-linux";
50 pkgs = nixpkgs.legacyPackages.${system}; 54 pkgs = nixpkgs.legacyPackages.${system};
@@ -70,6 +74,7 @@
70 inherit mozff; 74 inherit mozff;
71 inherit clipboard-sync; 75 inherit clipboard-sync;
72 inherit hypr-dynamic-cursors; 76 inherit hypr-dynamic-cursors;
77 inherit zen-browser;
73 }; 78 };
74 } 79 }
75 ]; 80 ];