summaryrefslogtreecommitdiff
path: root/home-config/nix-home-manager/home.nix
diff options
context:
space:
mode:
authorRyan Schanzenbacher <ryan@rschanz.org>2025-04-01 11:26:04 -0400
committerRyan Schanzenbacher <ryan@rschanz.org>2025-04-01 11:26:04 -0400
commitd465e92647470759177cb63914fd3571cea7a8a4 (patch)
treec2a27471bd33c7e3e53688c89758544664b89ac0 /home-config/nix-home-manager/home.nix
parent365a13de3e19c66f6bb2ffb806e8086a068ffc25 (diff)
Using Zen, added nix update to be upstreamed
Diffstat (limited to 'home-config/nix-home-manager/home.nix')
-rw-r--r--home-config/nix-home-manager/home.nix26
1 files changed, 25 insertions, 1 deletions
diff --git a/home-config/nix-home-manager/home.nix b/home-config/nix-home-manager/home.nix
index d2e0034..f5d386c 100644
--- a/home-config/nix-home-manager/home.nix
+++ b/home-config/nix-home-manager/home.nix
@@ -1,4 +1,24 @@
1{ config, pkgs, hyprland, nixgl, wpaperd, hyprpicker-git, hyprlock, mozff, clipboard-sync, hypr-dynamic-cursors, ... }: 1{ config, pkgs, hyprland, nixgl, wpaperd, hyprpicker-git, hyprlock, mozff, clipboard-sync, hypr-dynamic-cursors, zen-browser, ... }:
2let
3 # THIS IS NOT PERFECT AT ALL YET!!! Gets the basics done (my important
4 # policies regarding accounts and extensions. Does not set up profile
5 # stuff, like search. Most importantly, it DOES NOT add system CAs.
6 # To do that, run:
7 # `certutil -A -n "name" -t "CT,c" -i ./path/to/cert -d ~/.zen/profile-folder`
8 # I do this for my root and intermediate. BEWARE WHEN INSTALLING NEW
9 # SYSTEMS!!!!
10 ffPolicies = import ./zenPolicies.nix;
11 customZen = zen-browser.packages.${pkgs.system}.default.overrideAttrs (old: {
12 installPhase = old.installPhase + ''
13 rm -f $out/lib/zen-${old.version}/distribution/policies.json
14 rm -rf $out/lib
15 mkdir $out/opt/zen/distribution
16 ln -s ${pkgs.writeText "firefox-policies.json" (builtins.toJSON ffPolicies)} \
17 "$out/opt/zen/distribution/policies.json"
18 '';
19 });
20
21in
2 22
3{ 23{
4 imports = [ 24 imports = [
@@ -94,10 +114,14 @@
94 starship 114 starship
95 taskwarrior3 115 taskwarrior3
96 delta 116 delta
117 (flameshot.override { enableWlrSupport = true; })
97 118
98 # Here until i can fix firefox's stupid devtools issue 119 # Here until i can fix firefox's stupid devtools issue
99 chromium 120 chromium
100 121
122 # Maybe will work?
123 customZen
124
101 # Wrapped programs for some env variables 125 # Wrapped programs for some env variables
102 (pkgs.writeScriptBin "hyprlock" '' 126 (pkgs.writeScriptBin "hyprlock" ''
103 #! ${pkgs.bash}/bin/bash 127 #! ${pkgs.bash}/bin/bash