summaryrefslogtreecommitdiff
path: root/home-config/nix-home-manager
diff options
context:
space:
mode:
authorRyan Schanzenbacher <ryan@rschanz.org>2024-02-16 20:10:31 -0500
committerRyan Schanzenbacher <ryan@rschanz.org>2024-02-16 20:10:31 -0500
commit9396554c2141f3c4e14bcbd71d0f31b9ff7816d6 (patch)
tree4463bc49a7f743d7d4f2521213cc4ad8432aeae8 /home-config/nix-home-manager
parent9672616f431c8c4161238fe7ad1e2b4cf3040320 (diff)
flakes work!
Diffstat (limited to 'home-config/nix-home-manager')
-rw-r--r--home-config/nix-home-manager/flake.lock69
-rw-r--r--home-config/nix-home-manager/flake.nix39
-rw-r--r--home-config/nix-home-manager/home.nix11
3 files changed, 111 insertions, 8 deletions
diff --git a/home-config/nix-home-manager/flake.lock b/home-config/nix-home-manager/flake.lock
new file mode 100644
index 0000000..0356e26
--- /dev/null
+++ b/home-config/nix-home-manager/flake.lock
@@ -0,0 +1,69 @@
1{
2 "nodes": {
3 "home-manager": {
4 "inputs": {
5 "nixpkgs": [
6 "nixpkgs"
7 ]
8 },
9 "locked": {
10 "lastModified": 1708031129,
11 "narHash": "sha256-EH20hJfNnc1/ODdDVat9B7aKm0B95L3YtkIRwKLvQG8=",
12 "owner": "nix-community",
13 "repo": "home-manager",
14 "rev": "3d6791b3897b526c82920a2ab5f61d71985b3cf8",
15 "type": "github"
16 },
17 "original": {
18 "owner": "nix-community",
19 "repo": "home-manager",
20 "type": "github"
21 }
22 },
23 "hyprpicker-git": {
24 "inputs": {
25 "nixpkgs": [
26 "nixpkgs"
27 ]
28 },
29 "locked": {
30 "lastModified": 1703987863,
31 "narHash": "sha256-MHhAk74uk0qHVwSkLCcXLXMe4478M2oZEFPXwjSoo2E=",
32 "owner": "hyprwm",
33 "repo": "hyprpicker",
34 "rev": "2ef703474fb96e97e03e66e8820f213359f29382",
35 "type": "github"
36 },
37 "original": {
38 "owner": "hyprwm",
39 "repo": "hyprpicker",
40 "type": "github"
41 }
42 },
43 "nixpkgs": {
44 "locked": {
45 "lastModified": 1707956935,
46 "narHash": "sha256-ZL2TrjVsiFNKOYwYQozpbvQSwvtV/3Me7Zwhmdsfyu4=",
47 "owner": "nixos",
48 "repo": "nixpkgs",
49 "rev": "a4d4fe8c5002202493e87ec8dbc91335ff55552c",
50 "type": "github"
51 },
52 "original": {
53 "owner": "nixos",
54 "ref": "nixos-unstable",
55 "repo": "nixpkgs",
56 "type": "github"
57 }
58 },
59 "root": {
60 "inputs": {
61 "home-manager": "home-manager",
62 "hyprpicker-git": "hyprpicker-git",
63 "nixpkgs": "nixpkgs"
64 }
65 }
66 },
67 "root": "root",
68 "version": 7
69}
diff --git a/home-config/nix-home-manager/flake.nix b/home-config/nix-home-manager/flake.nix
new file mode 100644
index 0000000..8e1b937
--- /dev/null
+++ b/home-config/nix-home-manager/flake.nix
@@ -0,0 +1,39 @@
1{
2 description = "Home Manager configuration of ryan";
3
4 inputs = {
5 # Specify the source of Home Manager and Nixpkgs.
6 nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
7 home-manager = {
8 url = "github:nix-community/home-manager";
9 inputs.nixpkgs.follows = "nixpkgs";
10 };
11 hyprpicker-git = {
12 url = "github:hyprwm/hyprpicker";
13 inputs.nixpkgs.follows = "nixpkgs";
14 };
15 };
16
17 outputs = { nixpkgs, home-manager, hyprpicker-git, ... }:
18 let
19 system = "x86_64-linux";
20 pkgs = nixpkgs.legacyPackages.${system};
21 overlays = [
22 hyprpicker-git.overlays.default
23 ];
24 in {
25 homeConfigurations."ryan" = home-manager.lib.homeManagerConfiguration {
26 inherit pkgs;
27
28 # Specify your home configuration modules here, for example,
29 # the path to your home.nix.
30 modules = [
31 ./home.nix
32 {nixpkgs.overlays = overlays;}
33 ];
34
35 # Optionally use extraSpecialArgs
36 # to pass through arguments to home.nix
37 };
38 };
39}
diff --git a/home-config/nix-home-manager/home.nix b/home-config/nix-home-manager/home.nix
index aa90213..9dcdc28 100644
--- a/home-config/nix-home-manager/home.nix
+++ b/home-config/nix-home-manager/home.nix
@@ -13,18 +13,12 @@
13 # You should not change this value, even if you update Home Manager. If you do 13 # You should not change this value, even if you update Home Manager. If you do
14 # want to update the value, then make sure to first check the Home Manager 14 # want to update the value, then make sure to first check the Home Manager
15 # release notes. 15 # release notes.
16 home.stateVersion = "22.11"; # Please read the comment before changing. 16 home.stateVersion = "23.11"; # Please read the comment before changing.
17
18 # Enable nix flakes
19 nix = {
20 package = pkgs.nix;
21 settings.experimental-features = [ "nix-command" "flakes" ];
22 };
23 17
24 # This value will set some environment variables to allow home-manager to 18 # This value will set some environment variables to allow home-manager to
25 # function better outside of NixOS 19 # function better outside of NixOS
26 nixpkgs.config.allowUnfree = true; 20 nixpkgs.config.allowUnfree = true;
27 targets.genericLinux.enable = true; 21 #targets.genericLinux.enable = true;
28 fonts.fontconfig.enable = true; 22 fonts.fontconfig.enable = true;
29 23
30 # The home.packages option allows you to install Nix packages into your 24 # The home.packages option allows you to install Nix packages into your
@@ -47,6 +41,7 @@
47 waypaper 41 waypaper
48 gdu 42 gdu
49 spotify-player 43 spotify-player
44 hyprpicker
50 45
51 # # It is sometimes useful to fine-tune packages, for example, by applying 46 # # It is sometimes useful to fine-tune packages, for example, by applying
52 # # overrides. You can do that directly here, just don't forget the 47 # # overrides. You can do that directly here, just don't forget the