diff options
author | Ryan Schanzenbacher <ryan@rschanz.org> | 2023-11-06 20:00:12 -0500 |
---|---|---|
committer | Ryan Schanzenbacher <ryan@rschanz.org> | 2023-11-06 20:00:12 -0500 |
commit | bf8ccc69c6acab2b0b1ba72fcdc01e0495a97a6a (patch) | |
tree | 479ee9530c14d37f05342d2e612ab184d79ba3af /home-config | |
parent | 4628331b6b7058056fe692c5f633bb3e9643e053 (diff) |
updated hyprland, new wallpaper app, color picker, etc
Diffstat (limited to 'home-config')
-rw-r--r-- | home-config/home-configuration.scm | 1 | ||||
-rwxr-xr-x | home-config/hypr/autostart.sh | 8 | ||||
-rw-r--r-- | home-config/hypr/hyprland.conf | 4 | ||||
-rw-r--r-- | home-config/hypr/kanshi.conf | 4 | ||||
-rwxr-xr-x | home-config/hypr/wallpaper.sh | 6 | ||||
-rw-r--r-- | home-config/nix-home-manager/home.nix | 3 |
6 files changed, 25 insertions, 1 deletions
diff --git a/home-config/home-configuration.scm b/home-config/home-configuration.scm index 89a4511..9dd47a2 100644 --- a/home-config/home-configuration.scm +++ b/home-config/home-configuration.scm | |||
@@ -98,6 +98,7 @@ | |||
98 | "git" | 98 | "git" |
99 | "password-store" | 99 | "password-store" |
100 | "node" | 100 | "node" |
101 | "kanshi" | ||
101 | "git-lfs")) | 102 | "git-lfs")) |
102 | (list my-neovim wl-mirror firefox-wayland-new))) | 103 | (list my-neovim wl-mirror firefox-wayland-new))) |
103 | 104 | ||
diff --git a/home-config/hypr/autostart.sh b/home-config/hypr/autostart.sh index c53aeee..b05b71d 100755 --- a/home-config/hypr/autostart.sh +++ b/home-config/hypr/autostart.sh | |||
@@ -6,8 +6,14 @@ waybar & | |||
6 | 6 | ||
7 | mako & | 7 | mako & |
8 | 8 | ||
9 | swaybg -i ~/.config/hypr/Wallpapers/above-clouds.jpg & | 9 | #swaybg -i ~/.config/hypr/Wallpapers/above-clouds.jpg & |
10 | |||
11 | swww init & | ||
10 | 12 | ||
11 | swayidle -w timeout 300 'swaylock --screenshots --clock --indicator --grace 3 --fade-in 1 --effect-blur 7x5 --effect-greyscale' timeout 600 'hyprctl dispatch dpms off' resume 'hyprctl dispatch dpms on' before-sleep 'swaylock -f -c 000000' & | 13 | swayidle -w timeout 300 'swaylock --screenshots --clock --indicator --grace 3 --fade-in 1 --effect-blur 7x5 --effect-greyscale' timeout 600 'hyprctl dispatch dpms off' resume 'hyprctl dispatch dpms on' before-sleep 'swaylock -f -c 000000' & |
12 | 14 | ||
13 | syncthing serve --no-browser & | 15 | syncthing serve --no-browser & |
16 | |||
17 | wl-clip-persist -c regular & | ||
18 | |||
19 | kanshi -c ~/.config/hypr/kanshi.conf | ||
diff --git a/home-config/hypr/hyprland.conf b/home-config/hypr/hyprland.conf index 7367d6c..a3545b8 100644 --- a/home-config/hypr/hyprland.conf +++ b/home-config/hypr/hyprland.conf | |||
@@ -197,6 +197,9 @@ bind = $mainMod SHIFT, Print, exec, grimblast edit area | |||
197 | bind = $mainMod, N, exec, makoctl dismiss | 197 | bind = $mainMod, N, exec, makoctl dismiss |
198 | bind = $mainMod SHIFT, N, exec, makoctl dismiss -a | 198 | bind = $mainMod SHIFT, N, exec, makoctl dismiss -a |
199 | 199 | ||
200 | # Color picker | ||
201 | bind = $mainMod SHIFT, C, exec, hyprpicker -a | ||
202 | |||
200 | # Window Rules | 203 | # Window Rules |
201 | 204 | ||
202 | # Firefox PiP | 205 | # Firefox PiP |
@@ -222,4 +225,5 @@ exec-once = ~/.config/hypr/autostart.sh | |||
222 | 225 | ||
223 | misc { | 226 | misc { |
224 | disable_hyprland_logo = true | 227 | disable_hyprland_logo = true |
228 | force_default_wallpaper = 0 | ||
225 | } | 229 | } |
diff --git a/home-config/hypr/kanshi.conf b/home-config/hypr/kanshi.conf new file mode 100644 index 0000000..6a2cbfe --- /dev/null +++ b/home-config/hypr/kanshi.conf | |||
@@ -0,0 +1,4 @@ | |||
1 | profile { | ||
2 | output * enable | ||
3 | exec ~/.config/hypr/wallpaper.sh | ||
4 | } | ||
diff --git a/home-config/hypr/wallpaper.sh b/home-config/hypr/wallpaper.sh new file mode 100755 index 0000000..7d9ea21 --- /dev/null +++ b/home-config/hypr/wallpaper.sh | |||
@@ -0,0 +1,6 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | # Eventually allow for multiple animated backgrounds to be rotated. | ||
4 | # Right now just reset the current image for when outputs are changed | ||
5 | |||
6 | swww img ~/.config/hypr/Wallpapers/above-clouds.jpg | ||
diff --git a/home-config/nix-home-manager/home.nix b/home-config/nix-home-manager/home.nix index c535157..c6aed16 100644 --- a/home-config/nix-home-manager/home.nix +++ b/home-config/nix-home-manager/home.nix | |||
@@ -34,6 +34,9 @@ | |||
34 | gcc | 34 | gcc |
35 | pkg-config | 35 | pkg-config |
36 | wttrbar | 36 | wttrbar |
37 | swww | ||
38 | hyprpicker | ||
39 | wl-clip-persist | ||
37 | 40 | ||
38 | # # It is sometimes useful to fine-tune packages, for example, by applying | 41 | # # It is sometimes useful to fine-tune packages, for example, by applying |
39 | # # overrides. You can do that directly here, just don't forget the | 42 | # # overrides. You can do that directly here, just don't forget the |