summaryrefslogtreecommitdiff
path: root/home-config
diff options
context:
space:
mode:
authorRyan Schanzenbacher <ryan@rschanz.org>2025-01-20 20:49:03 -0500
committerRyan Schanzenbacher <ryan@rschanz.org>2025-01-20 20:49:03 -0500
commitddd6e973d651b9d9c4d160c8ebb288daa071e259 (patch)
treebe36f38ac02a15468dee4e9ab795975636fee844 /home-config
parentce1c24e3100d48c9c210eb1ebc5ebadcc6b77659 (diff)
Updated Thinkpad config to latest, updated all packages, updated docker
compose, changed nixGL to make hyprland work again, now using bash with starship config
Diffstat (limited to 'home-config')
-rw-r--r--home-config/bash_profile9
-rw-r--r--home-config/bashrc6
-rwxr-xr-xhome-config/docker/cli-plugins/docker-composebin59699273 -> 64694701 bytes
-rw-r--r--home-config/fish/fish_plugins5
-rw-r--r--home-config/home-configuration.scm21
-rw-r--r--home-config/nix-home-manager/flake.lock270
-rw-r--r--home-config/nix-home-manager/flake.nix9
-rw-r--r--home-config/nix-home-manager/home.nix30
8 files changed, 241 insertions, 109 deletions
diff --git a/home-config/bash_profile b/home-config/bash_profile
index 6bc7def..72ea319 100644
--- a/home-config/bash_profile
+++ b/home-config/bash_profile
@@ -1,16 +1,13 @@
1export MOZ_ENABLE_WAYLAND=1 1export MOZ_ENABLE_WAYLAND=1
2 2
3export XDG_CURRENT_DESKTOP=sway
4export XDG_SESSION_DESKTOP=sway
5export _JAVA_AWT_WM_NONREPEATING=1
6
7export XDG_DATA_DIRS=$XDG_DATA_DIRS:~/.nix-profile/share 3export XDG_DATA_DIRS=$XDG_DATA_DIRS:~/.nix-profile/share
8export PATH=~/.local/bin:$PATH:~/.nix-profile/bin 4export PATH=~/.local/bin:$PATH:~/.nix-profile/bin:~/.go/bin
5export GOPATH=~/.go
9 6
10# Honor per-interactive-shell startup file 7# Honor per-interactive-shell startup file
11if [ -f ~/.bashrc ]; then . ~/.bashrc; fi 8if [ -f ~/.bashrc ]; then . ~/.bashrc; fi
12 9
13if [ -z "$SSH_CLIENT" ] && [ -z "${DISPLAY}" ] && [ "${XDG_VTNR}" -eq 1 ]; then 10if [ -z "$SSH_CLIENT" ] && [ -z "${DISPLAY}" ] && [ "${XDG_VTNR}" -eq 1 ]; then
14 exec Hyprland 11 exec nixGLIntel Hyprland
15fi 12fi
16 13
diff --git a/home-config/bashrc b/home-config/bashrc
index 26fbbf4..386a2db 100644
--- a/home-config/bashrc
+++ b/home-config/bashrc
@@ -51,4 +51,8 @@ export XDG_DATA_DIRS=$XDG_DATA_DIRS:/var/lib/flatpak/exports/share:/home/ryan/.l
51#gpgconf --launch gpg-agent 51#gpgconf --launch gpg-agent
52export GPG_TTY=$(tty) 52export GPG_TTY=$(tty)
53 53
54eval "$(zoxide init bash)" 54# Zoxide
55eval "$(zoxide init --cmd cd bash)"
56
57# Starship
58eval "$(starship init bash)"
diff --git a/home-config/docker/cli-plugins/docker-compose b/home-config/docker/cli-plugins/docker-compose
index bf829e0..911e760 100755
--- a/home-config/docker/cli-plugins/docker-compose
+++ b/home-config/docker/cli-plugins/docker-compose
Binary files differ
diff --git a/home-config/fish/fish_plugins b/home-config/fish/fish_plugins
deleted file mode 100644
index 32f71ac..0000000
--- a/home-config/fish/fish_plugins
+++ /dev/null
@@ -1,5 +0,0 @@
1jorgebucaran/fisher
2ilancosman/tide@v6
3patrickf1/fzf.fish
4lilyball/nix-env.fish
5oh-my-fish/plugin-foreign-env
diff --git a/home-config/home-configuration.scm b/home-config/home-configuration.scm
index 93ec9e1..3e35a56 100644
--- a/home-config/home-configuration.scm
+++ b/home-config/home-configuration.scm
@@ -37,7 +37,6 @@
37(define %home-symlinks 37(define %home-symlinks
38 `((".config/guix/home-config/fish" ".config/fish") 38 `((".config/guix/home-config/fish" ".config/fish")
39 (".config/guix/home-config/nix-config" ".config/nix") 39 (".config/guix/home-config/nix-config" ".config/nix")
40 (".config/guix/home-config/tridactyl/native_main" ".local/share/tridactyl/native_main")
41 (".config/guix/home-config/nix-home-manager" ".config/home-manager"))) 40 (".config/guix/home-config/nix-home-manager" ".config/home-manager")))
42 41
43(home-symlinks %home-symlinks) 42(home-symlinks %home-symlinks)
@@ -140,16 +139,16 @@
140 ;; Below is the list of Home services. To search for available 139 ;; Below is the list of Home services. To search for available
141 ;; services, run 'guix home search KEYWORD' in a terminal. 140 ;; services, run 'guix home search KEYWORD' in a terminal.
142 (services 141 (services
143 (list ;(service home-bash-service-type 142 (list (service home-bash-service-type
144 ; (home-bash-configuration 143 (home-bash-configuration
145 ;(aliases '(("grep" . "grep --color=auto") ("ll" . "ls -l") 144 (aliases '(("grep" . "grep --color=auto") ("ll" . "ls -l")
146 ; ("ls" . "ls -p --color=auto") 145 ("ls" . "ls -p --color=auto")
147 ; ("spt" . "spotify_player") 146 ("spt" . "spotify_player")
148 ; ("python" . "python3"))) 147 ("python" . "python3")))
149 ; (bashrc (list (local-file 148 (bashrc (list (local-file
150 ; "bashrc"))) 149 "bashrc")))
151 ; (bash-profile (list (local-file 150 (bash-profile (list (local-file
152 ; "bash_profile"))))) 151 "bash_profile")))))
153 (service home-xdg-configuration-files-service-type 152 (service home-xdg-configuration-files-service-type
154 `(("nvim/init.vim" ,(local-file "nvim/config/init.vim")) 153 `(("nvim/init.vim" ,(local-file "nvim/config/init.vim"))
155 ("nvim/after/ftplugin/markdown/custom.vim" ,(local-file "nvim/config/after/ftplugin/markdown/custom.vim")) 154 ("nvim/after/ftplugin/markdown/custom.vim" ,(local-file "nvim/config/after/ftplugin/markdown/custom.vim"))
diff --git a/home-config/nix-home-manager/flake.lock b/home-config/nix-home-manager/flake.lock
index 653901b..8e3e4ed 100644
--- a/home-config/nix-home-manager/flake.lock
+++ b/home-config/nix-home-manager/flake.lock
@@ -2,29 +2,17 @@
2 "nodes": { 2 "nodes": {
3 "aquamarine": { 3 "aquamarine": {
4 "inputs": { 4 "inputs": {
5 "hyprutils": [ 5 "hyprutils": "hyprutils",
6 "hyprland", 6 "hyprwayland-scanner": "hyprwayland-scanner",
7 "hyprutils" 7 "nixpkgs": "nixpkgs",
8 ], 8 "systems": "systems"
9 "hyprwayland-scanner": [
10 "hyprland",
11 "hyprwayland-scanner"
12 ],
13 "nixpkgs": [
14 "hyprland",
15 "nixpkgs"
16 ],
17 "systems": [
18 "hyprland",
19 "systems"
20 ]
21 }, 9 },
22 "locked": { 10 "locked": {
23 "lastModified": 1731959031, 11 "lastModified": 1736702516,
24 "narHash": "sha256-TGcvIjftziC1CjuiHCzrYDwmOoSFYIhdiKmLetzB5L0=", 12 "narHash": "sha256-NbJiiPFnmciji3JHpqF/L0SdMQXKXn+q3Q/D8RjF/ak=",
25 "owner": "hyprwm", 13 "owner": "hyprwm",
26 "repo": "aquamarine", 14 "repo": "aquamarine",
27 "rev": "4468981c1c50999f315baa1508f0e53c4ee70c52", 15 "rev": "e7719f9b9f5321c7100733773ad9f38cb6db6b6f",
28 "type": "github" 16 "type": "github"
29 }, 17 },
30 "original": { 18 "original": {
@@ -93,17 +81,17 @@
93 ] 81 ]
94 }, 82 },
95 "locked": { 83 "locked": {
96 "lastModified": 1735381016, 84 "lastModified": 1736785676,
97 "narHash": "sha256-CyCZFhMUkuYbSD6bxB/r43EdmDE7hYeZZPTCv0GudO4=", 85 "narHash": "sha256-TY0jUwR3EW0fnS0X5wXMAVy6h4Z7Y6a3m+Yq++C9AyE=",
98 "owner": "nix-community", 86 "owner": "nix-community",
99 "repo": "home-manager", 87 "repo": "home-manager",
100 "rev": "10e99c43cdf4a0713b4e81d90691d22c6a58bdf2", 88 "rev": "fc52a210b60f2f52c74eac41a8647c1573d2071d",
101 "type": "github" 89 "type": "github"
102 }, 90 },
103 "original": { 91 "original": {
104 "owner": "nix-community", 92 "owner": "nix-community",
105 "repo": "home-manager", 93 "repo": "home-manager",
106 "rev": "10e99c43cdf4a0713b4e81d90691d22c6a58bdf2", 94 "rev": "fc52a210b60f2f52c74eac41a8647c1573d2071d",
107 "type": "github" 95 "type": "github"
108 } 96 }
109 }, 97 },
@@ -123,11 +111,11 @@
123 ] 111 ]
124 }, 112 },
125 "locked": { 113 "locked": {
126 "lastModified": 1728669738, 114 "lastModified": 1734906540,
127 "narHash": "sha256-EDNAU9AYcx8OupUzbTbWE1d3HYdeG0wO6Msg3iL1muk=", 115 "narHash": "sha256-vQ/L9hZFezC0LquLo4TWXkyniWtYBlFHAKIsDc7PYJE=",
128 "owner": "hyprwm", 116 "owner": "hyprwm",
129 "repo": "hyprcursor", 117 "repo": "hyprcursor",
130 "rev": "0264e698149fcb857a66a53018157b41f8d97bb0", 118 "rev": "69270ba8f057d55b0e6c2dca0e165d652856e613",
131 "type": "github" 119 "type": "github"
132 }, 120 },
133 "original": { 121 "original": {
@@ -136,33 +124,64 @@
136 "type": "github" 124 "type": "github"
137 } 125 }
138 }, 126 },
127 "hyprgraphics": {
128 "inputs": {
129 "hyprutils": [
130 "hyprland",
131 "hyprutils"
132 ],
133 "nixpkgs": [
134 "hyprland",
135 "nixpkgs"
136 ],
137 "systems": [
138 "hyprland",
139 "systems"
140 ]
141 },
142 "locked": {
143 "lastModified": 1736115290,
144 "narHash": "sha256-Jcn6yAzfUMcxy3tN/iZRbi/QgrYm7XLyVRl9g/nbUl4=",
145 "owner": "hyprwm",
146 "repo": "hyprgraphics",
147 "rev": "52202272d89da32a9f866c0d10305a5e3d954c50",
148 "type": "github"
149 },
150 "original": {
151 "owner": "hyprwm",
152 "repo": "hyprgraphics",
153 "type": "github"
154 }
155 },
139 "hyprland": { 156 "hyprland": {
140 "inputs": { 157 "inputs": {
141 "aquamarine": "aquamarine", 158 "aquamarine": "aquamarine",
142 "hyprcursor": "hyprcursor", 159 "hyprcursor": "hyprcursor",
160 "hyprgraphics": "hyprgraphics",
143 "hyprland-protocols": "hyprland-protocols", 161 "hyprland-protocols": "hyprland-protocols",
162 "hyprland-qtutils": "hyprland-qtutils",
144 "hyprlang": "hyprlang", 163 "hyprlang": "hyprlang",
145 "hyprutils": "hyprutils", 164 "hyprutils": "hyprutils_2",
146 "hyprwayland-scanner": "hyprwayland-scanner", 165 "hyprwayland-scanner": "hyprwayland-scanner_2",
147 "nixpkgs": [ 166 "nixpkgs": [
148 "nixpkgs" 167 "nixpkgs"
149 ], 168 ],
150 "pre-commit-hooks": "pre-commit-hooks", 169 "pre-commit-hooks": "pre-commit-hooks",
151 "systems": "systems", 170 "systems": "systems_2",
152 "xdph": "xdph" 171 "xdph": "xdph"
153 }, 172 },
154 "locked": { 173 "locked": {
155 "lastModified": 1732052838, 174 "lastModified": 1737038559,
156 "narHash": "sha256-ENsVNUEvJp7/7f6x7MVqtiVkFKkGy0Ux/ZqQM3Sb4CQ=", 175 "narHash": "sha256-irqN8zKwpQ0NFxEvV/wQRdopClwkyZXCQoF7mgX/Uss=",
157 "owner": "hyprwm", 176 "owner": "hyprwm",
158 "repo": "hyprland", 177 "repo": "hyprland",
159 "rev": "12f9a0d0b93f691d4d9923716557154d74777b0a", 178 "rev": "0dc7367a7006cc3cc877d52bf34c4998144bff84",
160 "type": "github" 179 "type": "github"
161 }, 180 },
162 "original": { 181 "original": {
163 "owner": "hyprwm", 182 "owner": "hyprwm",
164 "ref": "v0.45.2",
165 "repo": "hyprland", 183 "repo": "hyprland",
184 "rev": "0dc7367a7006cc3cc877d52bf34c4998144bff84",
166 "type": "github" 185 "type": "github"
167 } 186 }
168 }, 187 },
@@ -178,11 +197,11 @@
178 ] 197 ]
179 }, 198 },
180 "locked": { 199 "locked": {
181 "lastModified": 1728345020, 200 "lastModified": 1735774328,
182 "narHash": "sha256-xGbkc7U/Roe0/Cv3iKlzijIaFBNguasI31ynL2IlEoM=", 201 "narHash": "sha256-vIRwLS9w+N99EU1aJ+XNOU6mJTxrUBa31i1r82l0V7s=",
183 "owner": "hyprwm", 202 "owner": "hyprwm",
184 "repo": "hyprland-protocols", 203 "repo": "hyprland-protocols",
185 "rev": "a7c183800e74f337753de186522b9017a07a8cee", 204 "rev": "e3b6af97ddcfaafbda8e2828c719a5af84f662cb",
186 "type": "github" 205 "type": "github"
187 }, 206 },
188 "original": { 207 "original": {
@@ -191,6 +210,35 @@
191 "type": "github" 210 "type": "github"
192 } 211 }
193 }, 212 },
213 "hyprland-qtutils": {
214 "inputs": {
215 "hyprutils": [
216 "hyprland",
217 "hyprutils"
218 ],
219 "nixpkgs": [
220 "hyprland",
221 "nixpkgs"
222 ],
223 "systems": [
224 "hyprland",
225 "systems"
226 ]
227 },
228 "locked": {
229 "lastModified": 1736114838,
230 "narHash": "sha256-FxbuGQExtN37ToWYnGmO6weOYN6WPHN/RAqbr7gNPek=",
231 "owner": "hyprwm",
232 "repo": "hyprland-qtutils",
233 "rev": "6997fe382dcf396704227d2b98ffdd5066da6959",
234 "type": "github"
235 },
236 "original": {
237 "owner": "hyprwm",
238 "repo": "hyprland-qtutils",
239 "type": "github"
240 }
241 },
194 "hyprlang": { 242 "hyprlang": {
195 "inputs": { 243 "inputs": {
196 "hyprutils": [ 244 "hyprutils": [
@@ -207,11 +255,11 @@
207 ] 255 ]
208 }, 256 },
209 "locked": { 257 "locked": {
210 "lastModified": 1728168612, 258 "lastModified": 1735393019,
211 "narHash": "sha256-AnB1KfiXINmuiW7BALYrKqcjCnsLZPifhb/7BsfPbns=", 259 "narHash": "sha256-NPpqA8rtmDLsEmZOmz+qR67zsB6Y503Jnv+nSFLKJZ8=",
212 "owner": "hyprwm", 260 "owner": "hyprwm",
213 "repo": "hyprlang", 261 "repo": "hyprlang",
214 "rev": "f054f2e44d6a0b74607a6bc0f52dba337a3db38e", 262 "rev": "55608efdaa387af7bfdc0eddb404c409958efa43",
215 "type": "github" 263 "type": "github"
216 }, 264 },
217 "original": { 265 "original": {
@@ -222,12 +270,12 @@
222 }, 270 },
223 "hyprpicker-git": { 271 "hyprpicker-git": {
224 "inputs": { 272 "inputs": {
225 "hyprutils": "hyprutils_2", 273 "hyprutils": "hyprutils_3",
226 "hyprwayland-scanner": "hyprwayland-scanner_2", 274 "hyprwayland-scanner": "hyprwayland-scanner_3",
227 "nixpkgs": [ 275 "nixpkgs": [
228 "nixpkgs" 276 "nixpkgs"
229 ], 277 ],
230 "systems": "systems_2" 278 "systems": "systems_3"
231 }, 279 },
232 "locked": { 280 "locked": {
233 "lastModified": 1727705155, 281 "lastModified": 1727705155,
@@ -248,19 +296,21 @@
248 "inputs": { 296 "inputs": {
249 "nixpkgs": [ 297 "nixpkgs": [
250 "hyprland", 298 "hyprland",
299 "aquamarine",
251 "nixpkgs" 300 "nixpkgs"
252 ], 301 ],
253 "systems": [ 302 "systems": [
254 "hyprland", 303 "hyprland",
304 "aquamarine",
255 "systems" 305 "systems"
256 ] 306 ]
257 }, 307 },
258 "locked": { 308 "locked": {
259 "lastModified": 1731702627, 309 "lastModified": 1736613432,
260 "narHash": "sha256-+JeO9gevnXannQxMfR5xzZtF4sYmSlWkX/BPmPx0mWk=", 310 "narHash": "sha256-x7nMS1dFtlzgG13QoguKMZ6SKwSIQw82OANA5ZKF0d0=",
261 "owner": "hyprwm", 311 "owner": "hyprwm",
262 "repo": "hyprutils", 312 "repo": "hyprutils",
263 "rev": "e911361a687753bbbdfe3b6a9eab755ecaf1d9e1", 313 "rev": "72dfbf52967e4040693164319a027d8ac6315887",
264 "type": "github" 314 "type": "github"
265 }, 315 },
266 "original": { 316 "original": {
@@ -272,6 +322,31 @@
272 "hyprutils_2": { 322 "hyprutils_2": {
273 "inputs": { 323 "inputs": {
274 "nixpkgs": [ 324 "nixpkgs": [
325 "hyprland",
326 "nixpkgs"
327 ],
328 "systems": [
329 "hyprland",
330 "systems"
331 ]
332 },
333 "locked": {
334 "lastModified": 1736164519,
335 "narHash": "sha256-1LimBKvDpBbeX+qW7T240WEyw+DBVpDotZB4JYm8Aps=",
336 "owner": "hyprwm",
337 "repo": "hyprutils",
338 "rev": "3c895da64b0eb19870142196fa48c07090b441c4",
339 "type": "github"
340 },
341 "original": {
342 "owner": "hyprwm",
343 "repo": "hyprutils",
344 "type": "github"
345 }
346 },
347 "hyprutils_3": {
348 "inputs": {
349 "nixpkgs": [
275 "hyprpicker-git", 350 "hyprpicker-git",
276 "nixpkgs" 351 "nixpkgs"
277 ], 352 ],
@@ -298,19 +373,21 @@
298 "inputs": { 373 "inputs": {
299 "nixpkgs": [ 374 "nixpkgs": [
300 "hyprland", 375 "hyprland",
376 "aquamarine",
301 "nixpkgs" 377 "nixpkgs"
302 ], 378 ],
303 "systems": [ 379 "systems": [
304 "hyprland", 380 "hyprland",
381 "aquamarine",
305 "systems" 382 "systems"
306 ] 383 ]
307 }, 384 },
308 "locked": { 385 "locked": {
309 "lastModified": 1726874836, 386 "lastModified": 1735493474,
310 "narHash": "sha256-VKR0sf0PSNCB0wPHVKSAn41mCNVCnegWmgkrneKDhHM=", 387 "narHash": "sha256-fktzv4NaqKm94VAkAoVqO/nqQlw+X0/tJJNAeCSfzK4=",
311 "owner": "hyprwm", 388 "owner": "hyprwm",
312 "repo": "hyprwayland-scanner", 389 "repo": "hyprwayland-scanner",
313 "rev": "500c81a9e1a76760371049a8d99e008ea77aa59e", 390 "rev": "de913476b59ee88685fdc018e77b8f6637a2ae0b",
314 "type": "github" 391 "type": "github"
315 }, 392 },
316 "original": { 393 "original": {
@@ -322,6 +399,31 @@
322 "hyprwayland-scanner_2": { 399 "hyprwayland-scanner_2": {
323 "inputs": { 400 "inputs": {
324 "nixpkgs": [ 401 "nixpkgs": [
402 "hyprland",
403 "nixpkgs"
404 ],
405 "systems": [
406 "hyprland",
407 "systems"
408 ]
409 },
410 "locked": {
411 "lastModified": 1735493474,
412 "narHash": "sha256-fktzv4NaqKm94VAkAoVqO/nqQlw+X0/tJJNAeCSfzK4=",
413 "owner": "hyprwm",
414 "repo": "hyprwayland-scanner",
415 "rev": "de913476b59ee88685fdc018e77b8f6637a2ae0b",
416 "type": "github"
417 },
418 "original": {
419 "owner": "hyprwm",
420 "repo": "hyprwayland-scanner",
421 "type": "github"
422 }
423 },
424 "hyprwayland-scanner_3": {
425 "inputs": {
426 "nixpkgs": [
325 "hyprpicker-git", 427 "hyprpicker-git",
326 "nixpkgs" 428 "nixpkgs"
327 ], 429 ],
@@ -352,49 +454,49 @@
352 ] 454 ]
353 }, 455 },
354 "locked": { 456 "locked": {
355 "lastModified": 1713543440, 457 "lastModified": 1736159088,
356 "narHash": "sha256-lnzZQYG0+EXl/6NkGpyIz+FEOc/DSEG57AP1VsdeNrM=", 458 "narHash": "sha256-WDBc35XdHCdmgVYbPOtd2IeUtUHCYwNyEpIr5vLZMng=",
357 "owner": "nix-community", 459 "owner": "bb010g",
358 "repo": "nixGL", 460 "repo": "nixGL",
359 "rev": "310f8e49a149e4c9ea52f1adf70cdc768ec53f8a", 461 "rev": "3865170cbc23b32ec7cc8df1ec811fd44b6c2a58",
360 "type": "github" 462 "type": "github"
361 }, 463 },
362 "original": { 464 "original": {
363 "owner": "nix-community", 465 "owner": "bb010g",
466 "ref": "main",
364 "repo": "nixGL", 467 "repo": "nixGL",
365 "rev": "310f8e49a149e4c9ea52f1adf70cdc768ec53f8a",
366 "type": "github" 468 "type": "github"
367 } 469 }
368 }, 470 },
369 "nixpkgs": { 471 "nixpkgs": {
370 "locked": { 472 "locked": {
371 "lastModified": 1735661352, 473 "lastModified": 1736883708,
372 "narHash": "sha256-oSyxVJMvxB6op6Bd7u9TqBvbg8tiBd6aoiBAncMBzys=", 474 "narHash": "sha256-uQ+NQ0/xYU0N1CnXsa2zghgNaOPxWpMJXSUJJ9W7140=",
373 "owner": "nixos", 475 "owner": "NixOS",
374 "repo": "nixpkgs", 476 "repo": "nixpkgs",
375 "rev": "b4801729f1a1acb33d74b413c1cb0ced0837fb78", 477 "rev": "eb62e6aa39ea67e0b8018ba8ea077efe65807dc8",
376 "type": "github" 478 "type": "github"
377 }, 479 },
378 "original": { 480 "original": {
379 "owner": "nixos", 481 "owner": "NixOS",
482 "ref": "nixos-unstable",
380 "repo": "nixpkgs", 483 "repo": "nixpkgs",
381 "rev": "b4801729f1a1acb33d74b413c1cb0ced0837fb78",
382 "type": "github" 484 "type": "github"
383 } 485 }
384 }, 486 },
385 "nixpkgs-stable": { 487 "nixpkgs_2": {
386 "locked": { 488 "locked": {
387 "lastModified": 1730741070, 489 "lastModified": 1736012469,
388 "narHash": "sha256-edm8WG19kWozJ/GqyYx2VjW99EdhjKwbY3ZwdlPAAlo=", 490 "narHash": "sha256-/qlNWm/IEVVH7GfgAIyP6EsVZI6zjAx1cV5zNyrs+rI=",
389 "owner": "NixOS", 491 "owner": "nixos",
390 "repo": "nixpkgs", 492 "repo": "nixpkgs",
391 "rev": "d063c1dd113c91ab27959ba540c0d9753409edf3", 493 "rev": "8f3e1f807051e32d8c95cd12b9b421623850a34d",
392 "type": "github" 494 "type": "github"
393 }, 495 },
394 "original": { 496 "original": {
395 "owner": "NixOS", 497 "owner": "nixos",
396 "ref": "nixos-24.05",
397 "repo": "nixpkgs", 498 "repo": "nixpkgs",
499 "rev": "8f3e1f807051e32d8c95cd12b9b421623850a34d",
398 "type": "github" 500 "type": "github"
399 } 501 }
400 }, 502 },
@@ -405,15 +507,14 @@
405 "nixpkgs": [ 507 "nixpkgs": [
406 "hyprland", 508 "hyprland",
407 "nixpkgs" 509 "nixpkgs"
408 ], 510 ]
409 "nixpkgs-stable": "nixpkgs-stable"
410 }, 511 },
411 "locked": { 512 "locked": {
412 "lastModified": 1732021966, 513 "lastModified": 1735882644,
413 "narHash": "sha256-mnTbjpdqF0luOkou8ZFi2asa1N3AA2CchR/RqCNmsGE=", 514 "narHash": "sha256-3FZAG+pGt3OElQjesCAWeMkQ7C/nB1oTHLRQ8ceP110=",
414 "owner": "cachix", 515 "owner": "cachix",
415 "repo": "git-hooks.nix", 516 "repo": "git-hooks.nix",
416 "rev": "3308484d1a443fc5bc92012435d79e80458fe43c", 517 "rev": "a5a961387e75ae44cc20f0a57ae463da5e959656",
417 "type": "github" 518 "type": "github"
418 }, 519 },
419 "original": { 520 "original": {
@@ -428,7 +529,7 @@
428 "hyprland": "hyprland", 529 "hyprland": "hyprland",
429 "hyprpicker-git": "hyprpicker-git", 530 "hyprpicker-git": "hyprpicker-git",
430 "nixgl": "nixgl", 531 "nixgl": "nixgl",
431 "nixpkgs": "nixpkgs", 532 "nixpkgs": "nixpkgs_2",
432 "wpaperd": "wpaperd" 533 "wpaperd": "wpaperd"
433 } 534 }
434 }, 535 },
@@ -498,13 +599,28 @@
498 "type": "github" 599 "type": "github"
499 } 600 }
500 }, 601 },
602 "systems_4": {
603 "locked": {
604 "lastModified": 1689347949,
605 "narHash": "sha256-12tWmuL2zgBgZkdoB6qXZsgJEH9LR3oUgpaQq2RbI80=",
606 "owner": "nix-systems",
607 "repo": "default-linux",
608 "rev": "31732fcf5e8fea42e59c2488ad31a0e651500f68",
609 "type": "github"
610 },
611 "original": {
612 "owner": "nix-systems",
613 "repo": "default-linux",
614 "type": "github"
615 }
616 },
501 "wpaperd": { 617 "wpaperd": {
502 "inputs": { 618 "inputs": {
503 "nixpkgs": [ 619 "nixpkgs": [
504 "nixpkgs" 620 "nixpkgs"
505 ], 621 ],
506 "rust-overlay": "rust-overlay", 622 "rust-overlay": "rust-overlay",
507 "systems": "systems_3" 623 "systems": "systems_4"
508 }, 624 },
509 "locked": { 625 "locked": {
510 "lastModified": 1731514601, 626 "lastModified": 1731514601,
@@ -549,11 +665,11 @@
549 ] 665 ]
550 }, 666 },
551 "locked": { 667 "locked": {
552 "lastModified": 1731703417, 668 "lastModified": 1734907020,
553 "narHash": "sha256-rheDc/7C+yI+QspYr9J2z9kQ5P9F4ATapI7qyFAe1XA=", 669 "narHash": "sha256-p6HxwpRKVl1KIiY5xrJdjcEeK3pbmc///UOyV6QER+w=",
554 "owner": "hyprwm", 670 "owner": "hyprwm",
555 "repo": "xdg-desktop-portal-hyprland", 671 "repo": "xdg-desktop-portal-hyprland",
556 "rev": "8070f36deec723de71e7557441acb17e478204d3", 672 "rev": "d7f18dda5e511749fa1511185db3536208fb1a63",
557 "type": "github" 673 "type": "github"
558 }, 674 },
559 "original": { 675 "original": {
diff --git a/home-config/nix-home-manager/flake.nix b/home-config/nix-home-manager/flake.nix
index c64d043..af0af94 100644
--- a/home-config/nix-home-manager/flake.nix
+++ b/home-config/nix-home-manager/flake.nix
@@ -3,9 +3,9 @@
3 3
4 inputs = { 4 inputs = {
5 # Specify the source of Home Manager and Nixpkgs. 5 # Specify the source of Home Manager and Nixpkgs.
6 nixpkgs.url = "github:nixos/nixpkgs/b4801729f1a1acb33d74b413c1cb0ced0837fb78"; 6 nixpkgs.url = "github:nixos/nixpkgs/8f3e1f807051e32d8c95cd12b9b421623850a34d";
7 home-manager = { 7 home-manager = {
8 url = "github:nix-community/home-manager/10e99c43cdf4a0713b4e81d90691d22c6a58bdf2"; 8 url = "github:nix-community/home-manager/fc52a210b60f2f52c74eac41a8647c1573d2071d";
9 inputs.nixpkgs.follows = "nixpkgs"; 9 inputs.nixpkgs.follows = "nixpkgs";
10 }; 10 };
11 hyprpicker-git = { 11 hyprpicker-git = {
@@ -13,11 +13,12 @@
13 inputs.nixpkgs.follows = "nixpkgs"; 13 inputs.nixpkgs.follows = "nixpkgs";
14 }; 14 };
15 hyprland = { 15 hyprland = {
16 url = "github:hyprwm/hyprland/v0.45.2"; 16 url = "github:hyprwm/hyprland/0dc7367a7006cc3cc877d52bf34c4998144bff84";
17 inputs.nixpkgs.follows = "nixpkgs"; 17 inputs.nixpkgs.follows = "nixpkgs";
18 inputs.aquamarine.url = "github:hyprwm/aquamarine/main";
18 }; 19 };
19 nixgl = { 20 nixgl = {
20 url = "github:nix-community/nixGL/310f8e49a149e4c9ea52f1adf70cdc768ec53f8a"; 21 url = "github:bb010g/nixGL/main";
21 inputs.nixpkgs.follows = "nixpkgs"; 22 inputs.nixpkgs.follows = "nixpkgs";
22 }; 23 };
23 wpaperd = { 24 wpaperd = {
diff --git a/home-config/nix-home-manager/home.nix b/home-config/nix-home-manager/home.nix
index 5e85304..4c889c9 100644
--- a/home-config/nix-home-manager/home.nix
+++ b/home-config/nix-home-manager/home.nix
@@ -15,6 +15,9 @@
15 home.username = "ryan"; 15 home.username = "ryan";
16 home.homeDirectory = "/home/ryan"; 16 home.homeDirectory = "/home/ryan";
17 17
18 # Ignore news
19 news.display = "silent";
20
18 # This value determines the Home Manager release that your configuration is 21 # This value determines the Home Manager release that your configuration is
19 # compatible with. This helps avoid breakage when a new Home Manager release 22 # compatible with. This helps avoid breakage when a new Home Manager release
20 # introduces backwards incompatible changes. 23 # introduces backwards incompatible changes.
@@ -344,6 +347,22 @@
344 }; 347 };
345}; 348};
346 349
350 programs.starship = {
351 enable = true;
352 settings = {
353 add_newline = false;
354 character = {
355 success_symbol = "[➜](bold green)";
356 error_symbol = "[➜](bold red)";
357 };
358 time = {
359 disabled = false;
360 format = "\[ $time \]($style)";
361 time_format = "%T";
362 };
363 };
364 };
365
347 # The home.packages option allows you to install Nix packages into your 366 # The home.packages option allows you to install Nix packages into your
348 # environment. 367 # environment.
349 home.packages = with pkgs; [ 368 home.packages = with pkgs; [
@@ -377,13 +396,14 @@
377 #latest.firefox-nightly-bin 396 #latest.firefox-nightly-bin
378 eza 397 eza
379 wl-mirror 398 wl-mirror
399 starship
380 400
381 # Wrapped programs for some env variables 401 # Wrapped programs for some env variables
382 (pkgs.writeScriptBin "hyprlock" '' 402 # (pkgs.writeScriptBin "hyprlock" ''
383 #! ${pkgs.bash}/bin/bash 403 # #! ${pkgs.bash}/bin/bash
384 export LD_PRELOAD="/run/current-system/profile/lib/libpam.so.0:/run/current-system/profile/lib/libfontconfig.so:$LD_PRELOAD" 404 # export LD_PRELOAD="/run/current-system/profile/lib/libpam.so.0:/run/current-system/profile/lib/libfontconfig.so:$LD_PRELOAD"
385 exec ${pkgs.hyprlock}/bin/hyprlock "$@" 405 # exec ${pkgs.hyprlock}/bin/hyprlock "$@"
386 '') 406 # '')
387 407
388 # Flakes specific things defined in flake.nix 408 # Flakes specific things defined in flake.nix
389 hyprland.packages.${pkgs.system}.default 409 hyprland.packages.${pkgs.system}.default