summaryrefslogtreecommitdiff
path: root/modules/ryan-packages/patches
diff options
context:
space:
mode:
authorRyan Schanzenbacher <ryan@rschanz.org>2024-08-26 00:07:45 -0400
committerRyan Schanzenbacher <ryan@rschanz.org>2024-08-26 00:07:45 -0400
commit08263029b9253c794b2eb67628250c80ebdac341 (patch)
treee47f45469da9c9310ab6dfea81ea30d180bd6f0b /modules/ryan-packages/patches
parent16a21d07b9ff455b744398dcbfffd0396fe3f044 (diff)
working on hyprland update
Diffstat (limited to 'modules/ryan-packages/patches')
-rw-r--r--modules/ryan-packages/patches/aquamarine-fix-cmake.patch25
-rw-r--r--modules/ryan-packages/patches/hyprland-fix-cmake.patch41
2 files changed, 66 insertions, 0 deletions
diff --git a/modules/ryan-packages/patches/aquamarine-fix-cmake.patch b/modules/ryan-packages/patches/aquamarine-fix-cmake.patch
new file mode 100644
index 0000000..bd29649
--- /dev/null
+++ b/modules/ryan-packages/patches/aquamarine-fix-cmake.patch
@@ -0,0 +1,25 @@
1From 7b6f11ed0708d8775f42107e19d9099835e2498e Mon Sep 17 00:00:00 2001
2From: Freya Murphy <freya@freyacat.org>
3Date: Mon, 5 Aug 2024 17:52:48 -0400
4Subject: [PATCH] fix cmake
5
6---
7 CMakeLists.txt | 2 +-
8 1 file changed, 1 insertion(+), 1 deletion(-)
9
10diff --git a/CMakeLists.txt b/CMakeLists.txt
11index bb7a4d6..7f7e7ff 100644
12--- a/CMakeLists.txt
13+++ b/CMakeLists.txt
14@@ -19,7 +19,7 @@ set(INCLUDE ${CMAKE_INSTALL_FULL_INCLUDEDIR})
15 set(LIBDIR ${CMAKE_INSTALL_FULL_LIBDIR})
16
17 find_package(PkgConfig REQUIRED)
18-find_package(OpenGL REQUIRED COMPONENTS "GLES2")
19+find_package(OpenGL REQUIRED)
20 find_package(hyprwayland-scanner 0.4.0 REQUIRED)
21 pkg_check_modules(
22 deps
23--
242.45.1
25
diff --git a/modules/ryan-packages/patches/hyprland-fix-cmake.patch b/modules/ryan-packages/patches/hyprland-fix-cmake.patch
new file mode 100644
index 0000000..d294905
--- /dev/null
+++ b/modules/ryan-packages/patches/hyprland-fix-cmake.patch
@@ -0,0 +1,41 @@
1From 33fac66982422104cc1c2664f9a841fc96295c13 Mon Sep 17 00:00:00 2001
2From: Freya Murphy <freya@freyacat.org>
3Date: Mon, 5 Aug 2024 20:35:50 -0400
4Subject: [PATCH] fix cmake
5
6---
7 CMakeLists.txt | 4 +---
8 1 file changed, 1 insertion(+), 3 deletions(-)
9
10diff --git a/CMakeLists.txt b/CMakeLists.txt
11index fa58b63d..51ea6cfa 100644
12--- a/CMakeLists.txt
13+++ b/CMakeLists.txt
14@@ -26,7 +26,6 @@ execute_process(COMMAND ./scripts/generateVersion.sh
15 WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})
16
17 # udis
18-add_subdirectory("subprojects/udis86")
19
20 if(CMAKE_BUILD_TYPE)
21 string(TOLOWER ${CMAKE_BUILD_TYPE} BUILDTYPE_LOWER)
22@@ -85,7 +84,7 @@ if(LEGACY_RENDERER)
23 else()
24 set(GLES_VERSION "GLES3")
25 endif()
26-find_package(OpenGL REQUIRED COMPONENTS ${GLES_VERSION})
27+find_package(OpenGL REQUIRED)
28
29 pkg_check_modules(
30 deps
31@@ -314,7 +313,6 @@ protocolwayland()
32
33 # tools
34 add_subdirectory(hyprctl)
35-add_subdirectory(hyprpm)
36
37 # binary and symlink
38 install(TARGETS Hyprland)
39--
402.45.1
41