summaryrefslogtreecommitdiff
path: root/modules/ryan-packages/wm.scm
diff options
context:
space:
mode:
authorRyan Schanzenbacher <ryan@rschanz.org>2024-04-21 18:31:34 -0400
committerRyan Schanzenbacher <ryan@rschanz.org>2024-04-21 18:31:34 -0400
commit9c7803603fb56042ab97abc3e6a6c01acb598ebf (patch)
tree28108df1fcf137c404dc21bffcd709ca7925da9a /modules/ryan-packages/wm.scm
parent8a48a5775072430da4cc37f815b00d81db7283b4 (diff)
updated things and fish stuff
Diffstat (limited to 'modules/ryan-packages/wm.scm')
-rw-r--r--modules/ryan-packages/wm.scm35
1 files changed, 0 insertions, 35 deletions
diff --git a/modules/ryan-packages/wm.scm b/modules/ryan-packages/wm.scm
index be24289..0049947 100644
--- a/modules/ryan-packages/wm.scm
+++ b/modules/ryan-packages/wm.scm
@@ -126,38 +126,3 @@
126 (synopsis "Screen locker for Hyprland") 126 (synopsis "Screen locker for Hyprland")
127 (description "Screen locker for hyprland."))) 127 (description "Screen locker for hyprland.")))
128 128
129
130;(define hyprland-unbundle-wlroots-patch
131; (origin
132; (method url-fetch)
133; (uri (string-append "https://github.com/hyprwm/Hyprland" "/raw/"
134; "13f6f0b923ff3ec94a3bec886c28b90402ceef91"
135; "/nix/patches/meson-build.patch"))
136; (sha256
137; (base32 "02sq5ymxxrxp93mccafc4ilpsvs4m8bxc3whp7bcc5v9dx41va8k"))))
138
139;(define-public hyprland-temp
140; (package
141; (inherit hyprland)
142; (version "12985fa0d8e43b1e33326dfb49be681970dfaea5")
143; (source (origin
144; (method git-fetch)
145; (uri (git-reference
146; (url "https://github.com/hyprwm/Hyprland")
147; (commit version)))
148; (file-name (git-file-name "hyprland" version))
149; (modules '((guix build utils)))
150; (snippet
151; '(begin
152; (substitute* "meson.build"
153; ((".*hyprpm/src.*") ""))
154; (for-each delete-file-recursively
155; '("hyprpm"
156; "subprojects"))
157; (copy-file "src/version.h.in" "src/version.h")))
158; (sha256
159; (base32
160; "13l95h5krmv7syidw9c4gn62ac5qcqg9pmfh6x8ydjws97h05jvz"))
161; (patches (list hyprland-unbundle-wlroots-patch))))))
162
163hyprlock