diff options
-rw-r--r-- | home-config/home-configuration.scm | 3 | ||||
-rw-r--r-- | home-config/nix-home-manager/home.nix | 1 | ||||
-rw-r--r-- | home-config/waybar/config | 14 | ||||
-rw-r--r-- | modules/ryan-config/base-system.scm | 2 |
4 files changed, 14 insertions, 6 deletions
diff --git a/home-config/home-configuration.scm b/home-config/home-configuration.scm index c1ff5d6..9b64dec 100644 --- a/home-config/home-configuration.scm +++ b/home-config/home-configuration.scm | |||
@@ -54,13 +54,12 @@ | |||
54 | "netcat" | 54 | "netcat" |
55 | "bind:utils" | 55 | "bind:utils" |
56 | "font-cns11643" | 56 | "font-cns11643" |
57 | "font-google-noto-emoji" | ||
57 | "syncthing" | 58 | "syncthing" |
58 | "imv" | 59 | "imv" |
59 | "perl" | 60 | "perl" |
60 | "tor" | 61 | "tor" |
61 | "unzip" | 62 | "unzip" |
62 | "alacritty" | ||
63 | "foot" | ||
64 | "htop" | 63 | "htop" |
65 | "curl" | 64 | "curl" |
66 | "pandoc" | 65 | "pandoc" |
diff --git a/home-config/nix-home-manager/home.nix b/home-config/nix-home-manager/home.nix index 292f8ba..8165434 100644 --- a/home-config/nix-home-manager/home.nix +++ b/home-config/nix-home-manager/home.nix | |||
@@ -32,6 +32,7 @@ | |||
32 | rustup | 32 | rustup |
33 | gcc | 33 | gcc |
34 | pkg-config | 34 | pkg-config |
35 | wttrbar | ||
35 | 36 | ||
36 | # # It is sometimes useful to fine-tune packages, for example, by applying | 37 | # # It is sometimes useful to fine-tune packages, for example, by applying |
37 | # # overrides. You can do that directly here, just don't forget the | 38 | # # overrides. You can do that directly here, just don't forget the |
diff --git a/home-config/waybar/config b/home-config/waybar/config index 3dff06a..df9f6bb 100644 --- a/home-config/waybar/config +++ b/home-config/waybar/config | |||
@@ -56,7 +56,7 @@ | |||
56 | "ethernet": [""], | 56 | "ethernet": [""], |
57 | "disconnected": [""] | 57 | "disconnected": [""] |
58 | }, | 58 | }, |
59 | "on-click": "alacritty -e doas nmtui", | 59 | "on-click": "foot -t alacritty doas nmtui", |
60 | "tooltip": false | 60 | "tooltip": false |
61 | }, | 61 | }, |
62 | "pulseaudio": { | 62 | "pulseaudio": { |
@@ -96,16 +96,24 @@ | |||
96 | "on-scroll-down": "light -A 1", | 96 | "on-scroll-down": "light -A 1", |
97 | "on-scroll-up": "light -U 1" | 97 | "on-scroll-up": "light -U 1" |
98 | }, | 98 | }, |
99 | "custom/weather": { | 99 | "custom/weather_OLD": { |
100 | "format-alt": "{}", | 100 | "format-alt": "{}", |
101 | "format": "{alt}: {}", | 101 | "format": "{alt}: {}", |
102 | "format-alt-click": "click-right", | 102 | "format-alt-click": "click-right", |
103 | "interval": 1800, | 103 | "interval": 1800, |
104 | "return-type": "json", | 104 | "return-type": "json", |
105 | "on-click": "alacritty --class ala-wttr --hold -e curl https://v2.wttr.in", | 105 | "on-click": "foot -a ala-wttr -H curl https://v2.wttr.in", |
106 | "exec": "~/.config/waybar/modules/weather.sh", | 106 | "exec": "~/.config/waybar/modules/weather.sh", |
107 | "exec-if": "ping wttr.in -c1" | 107 | "exec-if": "ping wttr.in -c1" |
108 | }, | 108 | }, |
109 | "custom/weather": { | ||
110 | "format": "{} °", | ||
111 | "tooltip": true, | ||
112 | "interval": 3600, | ||
113 | "exec": "exit=101; while [ $exit = 101 ]; do wttrbar --main-indicator temp_F --fahrenheit; exit=$(echo $?); sleep 1; done", | ||
114 | "on-click": "foot -a ala-wttr -H curl https://v2.wttr.in", | ||
115 | "return-type": "json" | ||
116 | }, | ||
109 | "idle_inhibitor": { | 117 | "idle_inhibitor": { |
110 | "format": "{icon}", | 118 | "format": "{icon}", |
111 | "format-icons": { | 119 | "format-icons": { |
diff --git a/modules/ryan-config/base-system.scm b/modules/ryan-config/base-system.scm index d2af9e8..ae5c1af 100644 --- a/modules/ryan-config/base-system.scm +++ b/modules/ryan-config/base-system.scm | |||
@@ -113,7 +113,7 @@ | |||
113 | "swayidle" | 113 | "swayidle" |
114 | ;"swaylock-effects" | 114 | ;"swaylock-effects" |
115 | "fuzzel" | 115 | "fuzzel" |
116 | "alacritty" | 116 | "foot" |
117 | "pinentry-qt" | 117 | "pinentry-qt" |
118 | "adwaita-icon-theme" | 118 | "adwaita-icon-theme" |
119 | "hicolor-icon-theme" | 119 | "hicolor-icon-theme" |