summaryrefslogtreecommitdiff
path: root/home-config/fish/config.fish
diff options
context:
space:
mode:
Diffstat (limited to 'home-config/fish/config.fish')
-rw-r--r--home-config/fish/config.fish15
1 files changed, 15 insertions, 0 deletions
diff --git a/home-config/fish/config.fish b/home-config/fish/config.fish
new file mode 100644
index 0000000..f300cfe
--- /dev/null
+++ b/home-config/fish/config.fish
@@ -0,0 +1,15 @@
1if status is-interactive
2 # Commands to run in interactive sessions can go here
3 alias quit exit
4 alias cat "bat --paging=never"
5 alias ds "sudo -E guix system -L ~/.config/guix/modules reconfigure ~/.config/guix/$(prompt_hostname).scm"
6 alias dh "guix home -L ~/.config/guix/modules reconfigure ~/.config/guix/home-config/home-configuration.scm && home-manager switch"
7 alias gc "git -C ~/.config/guix add . && git -C ~/.config/guix commit && git -C ~/.config/guix push all"
8 alias cg "git -C ~/.config/guix pull"
9 alias cgh "git -C ~/.config/guix pull stationeryh main"
10 set -gx EDITOR nvim
11 set -gax XDG_DATA_DIRS ~/.nix-profile/share
12 fish_add_path ~/.local/bin
13 fish_add_path ~/.nix-profile/bin
14
15end