summaryrefslogtreecommitdiff
path: root/home-config/fish/functions/_tide_item_rustc.fish
diff options
context:
space:
mode:
Diffstat (limited to 'home-config/fish/functions/_tide_item_rustc.fish')
-rw-r--r--home-config/fish/functions/_tide_item_rustc.fish6
1 files changed, 6 insertions, 0 deletions
diff --git a/home-config/fish/functions/_tide_item_rustc.fish b/home-config/fish/functions/_tide_item_rustc.fish
new file mode 100644
index 0000000..b46cd99
--- /dev/null
+++ b/home-config/fish/functions/_tide_item_rustc.fish
@@ -0,0 +1,6 @@
1function _tide_item_rustc
2 if path is $_tide_parent_dirs/Cargo.toml
3 rustc --version | string match -qr "(?<v>[\d.]+)"
4 _tide_print_item rustc $tide_rustc_icon' ' $v
5 end
6end