summaryrefslogtreecommitdiff
path: root/home-config/nix-home-manager/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-config/nix-home-manager/home.nix')
-rw-r--r--home-config/nix-home-manager/home.nix33
1 files changed, 8 insertions, 25 deletions
diff --git a/home-config/nix-home-manager/home.nix b/home-config/nix-home-manager/home.nix
index 4c2c5f7..06096de 100644
--- a/home-config/nix-home-manager/home.nix
+++ b/home-config/nix-home-manager/home.nix
@@ -1,24 +1,4 @@
1{ config, pkgs, hyprland, nixgl, wpaperd, hyprpicker-git, hyprlock, mozff, clipboard-sync, hypr-dynamic-cursors, zen-browser, ... }: 1{ config, pkgs, hyprland, nixgl, wpaperd, hyprpicker-git, hyprlock, mozff, clipboard-sync, hypr-dynamic-cursors, home-manager, ... }:
2let
3 # THIS IS NOT PERFECT AT ALL YET!!! Gets the basics done (my important
4 # policies regarding accounts and extensions. Does not set up profile
5 # stuff, like search. Most importantly, it DOES NOT add system CAs.
6 # To do that, run:
7 # `certutil -A -n "name" -t "CT,c" -i ./path/to/cert -d ~/.zen/profile-folder`
8 # I do this for my root and intermediate. BEWARE WHEN INSTALLING NEW
9 # SYSTEMS!!!!
10 ffPolicies = import ./zenPolicies.nix;
11 customZen = zen-browser.packages.${pkgs.system}.default.overrideAttrs (old: {
12 installPhase = old.installPhase + ''
13 rm -f $out/lib/zen-${old.version}/distribution/policies.json
14 rm -rf $out/lib
15 mkdir $out/opt/zen/distribution
16 ln -s ${pkgs.writeText "firefox-policies.json" (builtins.toJSON ffPolicies)} \
17 "$out/opt/zen/distribution/policies.json"
18 '';
19 });
20
21in
22 2
23{ 3{
24 imports = [ 4 imports = [
@@ -78,13 +58,18 @@ in
78 }; 58 };
79 }; 59 };
80 60
61 programs.zen-browser = {
62 enable = true;
63 policies = import ./zenPolicies.nix;
64 };
65
81 # The home.packages option allows you to install Nix packages into your 66 # The home.packages option allows you to install Nix packages into your
82 # environment. 67 # environment.
83 home.packages = with pkgs; [ 68 home.packages = with pkgs; [
84 # # Adds the 'hello' command to your environment. It prints a friendly 69 # # Adds the 'hello' command to your environment. It prints a friendly
85 # # "Hello, world!" when run. 70 # # "Hello, world!" when run.
86 # pkgs.hello 71 # pkgs.hello
87 nix # Used to keep nix up to date when I don't update the guix package 72 # nix # Used to keep nix up to date when I don't update the guix package
88 yt-dlp 73 yt-dlp
89 #pass 74 #pass
90 rustup 75 rustup
@@ -115,14 +100,12 @@ in
115 starship 100 starship
116 taskwarrior3 101 taskwarrior3
117 delta 102 delta
103 pyprland
118 #(flameshot.override { enableWlrSupport = true; }) 104 #(flameshot.override { enableWlrSupport = true; })
119 105
120 # Here until i can fix firefox's stupid devtools issue 106 # Here until i can fix firefox's stupid devtools issue
121 chromium 107 chromium
122 108
123 # Maybe will work?
124 customZen
125
126 # Wrapped programs for some env variables 109 # Wrapped programs for some env variables
127 (pkgs.writeScriptBin "hyprlock" '' 110 (pkgs.writeScriptBin "hyprlock" ''
128 #! ${pkgs.bash}/bin/bash 111 #! ${pkgs.bash}/bin/bash