summaryrefslogtreecommitdiff
path: root/home-config/nix-home-manager/zenPolicies.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-config/nix-home-manager/zenPolicies.nix')
-rw-r--r--home-config/nix-home-manager/zenPolicies.nix126
1 files changed, 126 insertions, 0 deletions
diff --git a/home-config/nix-home-manager/zenPolicies.nix b/home-config/nix-home-manager/zenPolicies.nix
new file mode 100644
index 0000000..55b1190
--- /dev/null
+++ b/home-config/nix-home-manager/zenPolicies.nix
@@ -0,0 +1,126 @@
1let
2 lock-false = {
3 Value = false;
4 Status = "locked";
5 };
6 lock-true = {
7 Value = true;
8 Status = "locked";
9 };
10in
11{
12
13policies = {
14 EnableTrackingProtection = {
15 Value = true;
16 Locked = true;
17 Cryptomining = true;
18 Fingerprinting = true;
19 EmailTracking = true;
20 };
21 UserMessaging = {
22 WhatsNew = false;
23 ExtensionRecommendations = false;
24 FeatureRecommendations = false;
25 UrlbarInterventions = false;
26 SkipOnboarding = true;
27 MoreFromMozilla = false;
28 Labs = false;
29 Locked = true;
30 };
31 DisableAppUpdate = true;
32 DisableAccounts = true;
33 DisableFirefoxAccounts = true;
34 DisableFirefoxStudies = true;
35 DisablePocket = true;
36 DisableTelemetry = true;
37 AutofillAddressEnabled = false;
38 AutofillCreditCardEnabled = false;
39 DisableMasterPasswordCreation = true;
40 PasswordManagerEnabled = false;
41 PrimaryPassword = false;
42 OfferToSaveLogins = false;
43 NoDefaultBookmarks = true;
44 OverrideFirstRunPage = "";
45 OverridePostUpdatePage = "";
46 FirefoxHome = {
47 Search = true;
48 TopSites = true;
49 SponsoredTopSites = false;
50 Highlights = false;
51 Pocket = false;
52 SponsoredPocket = false;
53 Snippets = false;
54 Locked = true;
55 };
56 SearchSuggestEnabled = true;
57 FirefoxSuggest = {
58 WebSuggestions = true;
59 SponsoredSuggestions = false;
60 ImproveSuggest = false;
61 Locked = true;
62 };
63 PictureInPicture = lock-true;
64 HardwareAcceleration = true;
65 Certificates = {
66 ImportEnterpriseRoots = true;
67 };
68 ExtensionSettings = {
69 #"*".installation_mode = "blocked";
70 # uBlock Origin
71 "uBlock0@raymondhill.net" = {
72 install_url = "https://addons.mozilla.org/firefox/downloads/latest/ublock-origin/latest.xpi";
73 installation_mode = "force_installed";
74 };
75 # Bitwarden
76 "{446900e4-71c2-419f-a6a7-df9c091e268b}" = {
77 install_url = "https://addons.mozilla.org/firefox/downloads/latest/bitwarden-password-manager/latest.xpi";
78 installation_mode = "normal_installed";
79 };
80 # SponsorBlock
81 "sponsorBlocker@ajay.app" = {
82 install_url = "https://addons.mozilla.org/firefox/downloads/latest/sponsorblock/latest.xpi";
83 installation_mode = "force_installed";
84 };
85 # DeArrow
86 "deArrow@ajay.app" = {
87 install_url = "https://addons.mozilla.org/firefox/downloads/latest/dearrow/latest.xpi";
88 installation_mode = "force_installed";
89 };
90 # Return Youtube Dislike
91 "{762f9885-5a13-4abd-9c77-433dcd38b8fd}" = {
92 install_url = "https://addons.mozilla.org/firefox/downloads/latest/return-youtube-dislikes/latest.xpi";
93 installation_mode = "force_installed";
94 };
95 # Youtube Nonstop
96 "{0d7cafdd-501c-49ca-8ebb-e3341caaa55e}" = {
97 install_url = "https://addons.mozilla.org/firefox/downloads/latest/youtube-nonstop/latest.xpi";
98 installation_mode = "force_installed";
99 };
100 # TamperMonkey
101 "firefox@tampermonkey.net" = {
102 install_url = "https://addons.mozilla.org/firefox/downloads/latest/tampermonkey/latest.xpi";
103 installation_mode = "force_installed";
104 };
105 # Floccus
106 "floccus@handmadeideas.org" = {
107 install_url = "https://addons.mozilla.org/firefox/downloads/latest/floccus/latest.xpi";
108 installation_mode = "force_installed";
109 };
110 # Mailvelope
111 "jid1-AQqSMBYb0a8ADg@jetpack" = {
112 install_url = "https://addons.mozilla.org/firefox/downloads/latest/mailvelope/latest.xpi";
113 installation_mode = "force_installed";
114 };
115 };
116 Preferences = {
117 "xpinstall.whitelist.required" = lock-true;
118 "dom.webgpu.enabled" = lock-true;
119 "media.eme.enabled" = lock-true;
120 "general.autoScroll" = lock-true;
121 "general.smoothScroll" = lock-true;
122 "browser.crashReports.unsubmittedCheck.autoSubmit2" = lock-false;
123 "browser.aboutConfig.showWarning" = lock-false;
124 };
125};
126}