diff options
Diffstat (limited to 'home-config')
-rw-r--r-- | home-config/home-configuration.scm | 8 | ||||
-rw-r--r-- | home-config/nix-home-manager/flake.lock | 130 | ||||
-rw-r--r-- | home-config/nix-home-manager/flake.nix | 7 | ||||
-rw-r--r-- | home-config/nix-home-manager/home.nix | 1 | ||||
-rw-r--r-- | home-config/ssh/config | 4 |
5 files changed, 144 insertions, 6 deletions
diff --git a/home-config/home-configuration.scm b/home-config/home-configuration.scm index b5ff736..b89ff26 100644 --- a/home-config/home-configuration.scm +++ b/home-config/home-configuration.scm | |||
@@ -32,7 +32,9 @@ | |||
32 | (prepend gcc-12))))) | 32 | (prepend gcc-12))))) |
33 | 33 | ||
34 | (define %home-symlinks | 34 | (define %home-symlinks |
35 | `((".config/guix/home-config/fish" ".config/fish"))) | 35 | `((".config/guix/home-config/fish" ".config/fish") |
36 | (".config/guix/home-config/nix-config" ".config/nix") | ||
37 | (".config/guix/home-config/nix-home-manager" ".config/home-manager"))) | ||
36 | 38 | ||
37 | (home-symlinks %home-symlinks) | 39 | (home-symlinks %home-symlinks) |
38 | 40 | ||
@@ -150,9 +152,7 @@ | |||
150 | ("pulse/client.conf" ,(local-file "pulseaudio/client.conf")) | 152 | ("pulse/client.conf" ,(local-file "pulseaudio/client.conf")) |
151 | ("waybar" ,(local-file "waybar" #:recursive? #t)) | 153 | ("waybar" ,(local-file "waybar" #:recursive? #t)) |
152 | ("alacritty" ,(local-file "alacritty" #:recursive? #t)) | 154 | ("alacritty" ,(local-file "alacritty" #:recursive? #t)) |
153 | ("aerc" ,(local-file "aerc" #:recursive? #t)) | 155 | ("aerc" ,(local-file "aerc" #:recursive? #t)) )) |
154 | ("home-manager" ,(local-file "nix-home-manager" #:recursive? #t)) | ||
155 | ("nix" ,(local-file "nix-config" #:recursive? #t)) )) | ||
156 | (service home-files-service-type | 156 | (service home-files-service-type |
157 | `((".local/share/nvim/site/autoload/plug.vim" ,(local-file "nvim/plugin-manager/plug.vim")) | 157 | `((".local/share/nvim/site/autoload/plug.vim" ,(local-file "nvim/plugin-manager/plug.vim")) |
158 | (".ssh/config" ,(local-file "ssh/config")) | 158 | (".ssh/config" ,(local-file "ssh/config")) |
diff --git a/home-config/nix-home-manager/flake.lock b/home-config/nix-home-manager/flake.lock index 0356e26..8a9fdd3 100644 --- a/home-config/nix-home-manager/flake.lock +++ b/home-config/nix-home-manager/flake.lock | |||
@@ -1,5 +1,79 @@ | |||
1 | { | 1 | { |
2 | "nodes": { | 2 | "nodes": { |
3 | "flake-compat": { | ||
4 | "flake": false, | ||
5 | "locked": { | ||
6 | "lastModified": 1696426674, | ||
7 | "narHash": "sha256-kvjfFW7WAETZlt09AgDn1MrtKzP7t90Vf7vypd3OL1U=", | ||
8 | "owner": "edolstra", | ||
9 | "repo": "flake-compat", | ||
10 | "rev": "0f9255e01c2351cc7d116c072cb317785dd33b33", | ||
11 | "type": "github" | ||
12 | }, | ||
13 | "original": { | ||
14 | "owner": "edolstra", | ||
15 | "repo": "flake-compat", | ||
16 | "type": "github" | ||
17 | } | ||
18 | }, | ||
19 | "flake-utils": { | ||
20 | "inputs": { | ||
21 | "systems": "systems" | ||
22 | }, | ||
23 | "locked": { | ||
24 | "lastModified": 1710146030, | ||
25 | "narHash": "sha256-SZ5L6eA7HJ/nmkzGG7/ISclqe6oZdOZTNoesiInkXPQ=", | ||
26 | "owner": "numtide", | ||
27 | "repo": "flake-utils", | ||
28 | "rev": "b1d9ab70662946ef0850d488da1c9019f3a9752a", | ||
29 | "type": "github" | ||
30 | }, | ||
31 | "original": { | ||
32 | "owner": "numtide", | ||
33 | "repo": "flake-utils", | ||
34 | "type": "github" | ||
35 | } | ||
36 | }, | ||
37 | "flake-utils_2": { | ||
38 | "inputs": { | ||
39 | "systems": "systems_2" | ||
40 | }, | ||
41 | "locked": { | ||
42 | "lastModified": 1694529238, | ||
43 | "narHash": "sha256-zsNZZGTGnMOf9YpHKJqMSsa0dXbfmxeoJ7xHlrt+xmY=", | ||
44 | "owner": "numtide", | ||
45 | "repo": "flake-utils", | ||
46 | "rev": "ff7b65b44d01cf9ba6a71320833626af21126384", | ||
47 | "type": "github" | ||
48 | }, | ||
49 | "original": { | ||
50 | "owner": "numtide", | ||
51 | "repo": "flake-utils", | ||
52 | "type": "github" | ||
53 | } | ||
54 | }, | ||
55 | "gomod2nix": { | ||
56 | "inputs": { | ||
57 | "flake-utils": "flake-utils_2", | ||
58 | "nixpkgs": [ | ||
59 | "superfile", | ||
60 | "nixpkgs" | ||
61 | ] | ||
62 | }, | ||
63 | "locked": { | ||
64 | "lastModified": 1710154385, | ||
65 | "narHash": "sha256-4c3zQ2YY4BZOufaBJB4v9VBBeN2dH7iVdoJw8SDNCfI=", | ||
66 | "owner": "nix-community", | ||
67 | "repo": "gomod2nix", | ||
68 | "rev": "872b63ddd28f318489c929d25f1f0a3c6039c971", | ||
69 | "type": "github" | ||
70 | }, | ||
71 | "original": { | ||
72 | "owner": "nix-community", | ||
73 | "repo": "gomod2nix", | ||
74 | "type": "github" | ||
75 | } | ||
76 | }, | ||
3 | "home-manager": { | 77 | "home-manager": { |
4 | "inputs": { | 78 | "inputs": { |
5 | "nixpkgs": [ | 79 | "nixpkgs": [ |
@@ -60,7 +134,61 @@ | |||
60 | "inputs": { | 134 | "inputs": { |
61 | "home-manager": "home-manager", | 135 | "home-manager": "home-manager", |
62 | "hyprpicker-git": "hyprpicker-git", | 136 | "hyprpicker-git": "hyprpicker-git", |
63 | "nixpkgs": "nixpkgs" | 137 | "nixpkgs": "nixpkgs", |
138 | "superfile": "superfile" | ||
139 | } | ||
140 | }, | ||
141 | "superfile": { | ||
142 | "inputs": { | ||
143 | "flake-compat": "flake-compat", | ||
144 | "flake-utils": "flake-utils", | ||
145 | "gomod2nix": "gomod2nix", | ||
146 | "nixpkgs": [ | ||
147 | "nixpkgs" | ||
148 | ] | ||
149 | }, | ||
150 | "locked": { | ||
151 | "lastModified": 1715556404, | ||
152 | "narHash": "sha256-lG4hvdi0JNOG1s05UrmDKxwhk6TrFDWZsxHrWGw6vCM=", | ||
153 | "owner": "MHNightCat", | ||
154 | "repo": "superfile", | ||
155 | "rev": "eaed7829b07de14528ac203aad8a5ac5c04c68ef", | ||
156 | "type": "github" | ||
157 | }, | ||
158 | "original": { | ||
159 | "owner": "MHNightCat", | ||
160 | "repo": "superfile", | ||
161 | "type": "github" | ||
162 | } | ||
163 | }, | ||
164 | "systems": { | ||
165 | "locked": { | ||
166 | "lastModified": 1681028828, | ||
167 | "narHash": "sha256-Vy1rq5AaRuLzOxct8nz4T6wlgyUR7zLU309k9mBC768=", | ||
168 | "owner": "nix-systems", | ||
169 | "repo": "default", | ||
170 | "rev": "da67096a3b9bf56a91d16901293e51ba5b49a27e", | ||
171 | "type": "github" | ||
172 | }, | ||
173 | "original": { | ||
174 | "owner": "nix-systems", | ||
175 | "repo": "default", | ||
176 | "type": "github" | ||
177 | } | ||
178 | }, | ||
179 | "systems_2": { | ||
180 | "locked": { | ||
181 | "lastModified": 1681028828, | ||
182 | "narHash": "sha256-Vy1rq5AaRuLzOxct8nz4T6wlgyUR7zLU309k9mBC768=", | ||
183 | "owner": "nix-systems", | ||
184 | "repo": "default", | ||
185 | "rev": "da67096a3b9bf56a91d16901293e51ba5b49a27e", | ||
186 | "type": "github" | ||
187 | }, | ||
188 | "original": { | ||
189 | "owner": "nix-systems", | ||
190 | "repo": "default", | ||
191 | "type": "github" | ||
64 | } | 192 | } |
65 | } | 193 | } |
66 | }, | 194 | }, |
diff --git a/home-config/nix-home-manager/flake.nix b/home-config/nix-home-manager/flake.nix index 8e1b937..88405d0 100644 --- a/home-config/nix-home-manager/flake.nix +++ b/home-config/nix-home-manager/flake.nix | |||
@@ -12,9 +12,13 @@ | |||
12 | url = "github:hyprwm/hyprpicker"; | 12 | url = "github:hyprwm/hyprpicker"; |
13 | inputs.nixpkgs.follows = "nixpkgs"; | 13 | inputs.nixpkgs.follows = "nixpkgs"; |
14 | }; | 14 | }; |
15 | superfile = { | ||
16 | url = "github:MHNightCat/superfile"; | ||
17 | inputs.nixpkgs.follows = "nixpkgs"; | ||
18 | }; | ||
15 | }; | 19 | }; |
16 | 20 | ||
17 | outputs = { nixpkgs, home-manager, hyprpicker-git, ... }: | 21 | outputs = { nixpkgs, home-manager, hyprpicker-git, superfile, ... }: |
18 | let | 22 | let |
19 | system = "x86_64-linux"; | 23 | system = "x86_64-linux"; |
20 | pkgs = nixpkgs.legacyPackages.${system}; | 24 | pkgs = nixpkgs.legacyPackages.${system}; |
@@ -34,6 +38,7 @@ | |||
34 | 38 | ||
35 | # Optionally use extraSpecialArgs | 39 | # Optionally use extraSpecialArgs |
36 | # to pass through arguments to home.nix | 40 | # to pass through arguments to home.nix |
41 | extraSpecialArgs = {inherit inputs;}; | ||
37 | }; | 42 | }; |
38 | }; | 43 | }; |
39 | } | 44 | } |
diff --git a/home-config/nix-home-manager/home.nix b/home-config/nix-home-manager/home.nix index 9d712dc..9433801 100644 --- a/home-config/nix-home-manager/home.nix +++ b/home-config/nix-home-manager/home.nix | |||
@@ -43,6 +43,7 @@ | |||
43 | gdu | 43 | gdu |
44 | spotify-player | 44 | spotify-player |
45 | hyprpicker | 45 | hyprpicker |
46 | superfile | ||
46 | 47 | ||
47 | # # It is sometimes useful to fine-tune packages, for example, by applying | 48 | # # It is sometimes useful to fine-tune packages, for example, by applying |
48 | # # overrides. You can do that directly here, just don't forget the | 49 | # # overrides. You can do that directly here, just don't forget the |
diff --git a/home-config/ssh/config b/home-config/ssh/config index 1b8e4bf..45132d7 100644 --- a/home-config/ssh/config +++ b/home-config/ssh/config | |||
@@ -12,5 +12,9 @@ Host hetzner | |||
12 | HostName 5.161.207.21 | 12 | HostName 5.161.207.21 |
13 | User root | 13 | User root |
14 | 14 | ||
15 | Host rncorepub | ||
16 | Hostname 5.161.89.186 | ||
17 | User root | ||
18 | |||
15 | Host * | 19 | Host * |
16 | KexAlgorithms -sntrup761x25519-sha512@openssh.com | 20 | KexAlgorithms -sntrup761x25519-sha512@openssh.com |