mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 21:38:07 -05:00
gnu: imagemagick: Update to 6.9.2-1.
* gnu/packages/imagemagick.scm (imagemagick): Update to 6.9.2-1. [source]: Add imagemagick-test-segv.patch. [inputs]: Replace LIBJPEG-8 with LIBJPEG.
This commit is contained in:
parent
1d6c8db57c
commit
2ed74cea5c
3 changed files with 26 additions and 3 deletions
|
@ -505,6 +505,7 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/icecat-freetype-2.6.patch \
|
gnu/packages/patches/icecat-freetype-2.6.patch \
|
||||||
gnu/packages/patches/icecat-libvpx-1.4.patch \
|
gnu/packages/patches/icecat-libvpx-1.4.patch \
|
||||||
gnu/packages/patches/icu4c-CVE-2015-4760.patch \
|
gnu/packages/patches/icu4c-CVE-2015-4760.patch \
|
||||||
|
gnu/packages/patches/imagemagick-test-segv.patch \
|
||||||
gnu/packages/patches/irrlicht-mesa-10.patch \
|
gnu/packages/patches/irrlicht-mesa-10.patch \
|
||||||
gnu/packages/patches/jbig2dec-ignore-testtest.patch \
|
gnu/packages/patches/jbig2dec-ignore-testtest.patch \
|
||||||
gnu/packages/patches/julia-0.3.10-fix-empty-array.patch \
|
gnu/packages/patches/julia-0.3.10-fix-empty-array.patch \
|
||||||
|
|
|
@ -23,6 +23,7 @@ (define-module (gnu packages imagemagick)
|
||||||
#:use-module (guix build-system perl)
|
#:use-module (guix build-system perl)
|
||||||
#:use-module (guix download)
|
#:use-module (guix download)
|
||||||
#:use-module ((guix licenses) #:select (fsf-free))
|
#:use-module ((guix licenses) #:select (fsf-free))
|
||||||
|
#:use-module (gnu packages)
|
||||||
#:use-module (gnu packages algebra)
|
#:use-module (gnu packages algebra)
|
||||||
#:use-module (gnu packages compression)
|
#:use-module (gnu packages compression)
|
||||||
#:use-module (gnu packages fontutils)
|
#:use-module (gnu packages fontutils)
|
||||||
|
@ -37,14 +38,15 @@ (define-module (gnu packages imagemagick)
|
||||||
(define-public imagemagick
|
(define-public imagemagick
|
||||||
(package
|
(package
|
||||||
(name "imagemagick")
|
(name "imagemagick")
|
||||||
(version "6.9.1-3")
|
(version "6.9.2-1")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://imagemagick/ImageMagick-"
|
(uri (string-append "mirror://imagemagick/ImageMagick-"
|
||||||
version ".tar.xz"))
|
version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"18wbsjfccxlgsdsd6h9wvhcjrsglyi086jk4bk029ik07rh81laz"))))
|
"159afhqrj22jlz745ccbgnkdiwvn8pjcc96jic0iv9ms7gqxwln5"))
|
||||||
|
(patches (list (search-patch "imagemagick-test-segv.patch")))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:phases (modify-phases %standard-phases
|
`(#:phases (modify-phases %standard-phases
|
||||||
|
@ -84,7 +86,7 @@ (define-public imagemagick
|
||||||
("libxml2" ,libxml2)
|
("libxml2" ,libxml2)
|
||||||
("libtiff" ,libtiff)
|
("libtiff" ,libtiff)
|
||||||
("libpng" ,libpng)
|
("libpng" ,libpng)
|
||||||
("libjpeg" ,libjpeg-8)
|
("libjpeg" ,libjpeg)
|
||||||
("pango" ,pango)
|
("pango" ,pango)
|
||||||
("freetype" ,freetype)
|
("freetype" ,freetype)
|
||||||
("bzip2" ,bzip2)
|
("bzip2" ,bzip2)
|
||||||
|
|
20
gnu/packages/patches/imagemagick-test-segv.patch
Normal file
20
gnu/packages/patches/imagemagick-test-segv.patch
Normal file
|
@ -0,0 +1,20 @@
|
||||||
|
This patch works around a segmentation fault in 'Magick++/tests/color' when
|
||||||
|
running 'Magick++/tests/tests.tap'. Here we get an exception early on, which
|
||||||
|
is supposedly harmless:
|
||||||
|
|
||||||
|
Caught exception: color: UnableToOpenConfigureFile `colors.xml' @ warning/configure.c/GetConfigureOptions/706
|
||||||
|
|
||||||
|
However, when the stack unwinders run, 'UnregisterDOTImage' gets called even
|
||||||
|
though 'RegisterDOTImage' hadn't been called yet; thus, 'graphic_context' in
|
||||||
|
coders/dot.c is NULL, leading to the segfault.
|
||||||
|
|
||||||
|
--- ImageMagick-6.9.2-1/coders/dot.c 2015-09-16 17:32:42.900323334 +0200
|
||||||
|
+++ ImageMagick-6.9.2-1/coders/dot.c 2015-09-16 17:32:48.312367636 +0200
|
||||||
|
@@ -240,6 +240,7 @@ ModuleExport void UnregisterDOTImage(voi
|
||||||
|
(void) UnregisterMagickInfo("GV");
|
||||||
|
(void) UnregisterMagickInfo("DOT");
|
||||||
|
#if defined(MAGICKCORE_GVC_DELEGATE)
|
||||||
|
+ if (graphic_context != NULL)
|
||||||
|
gvFreeContext(graphic_context);
|
||||||
|
#endif
|
||||||
|
}
|
Loading…
Reference in a new issue