mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: libvisio: Update to 0.1.6.
* gnu/packages/libreoffice.scm (libvisio): Update to 0.1.6. [source](patches): Remove. * gnu/packages/patches/libvisio-fix-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
7a9283a619
commit
45d5c80253
3 changed files with 2 additions and 39 deletions
|
@ -825,7 +825,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/libusb-0.1-disable-tests.patch \
|
||||
%D%/packages/patches/libusb-for-axoloti.patch \
|
||||
%D%/packages/patches/libvirt-CVE-2017-1000256.patch \
|
||||
%D%/packages/patches/libvisio-fix-tests.patch \
|
||||
%D%/packages/patches/libvpx-CVE-2016-2818.patch \
|
||||
%D%/packages/patches/libxcb-python-3.5-compat.patch \
|
||||
%D%/packages/patches/libxfont-CVE-2017-13720.patch \
|
||||
|
|
|
@ -520,15 +520,14 @@ (define-public libpagemaker
|
|||
(define-public libvisio
|
||||
(package
|
||||
(name "libvisio")
|
||||
(version "0.1.5")
|
||||
(version "0.1.6")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
|
||||
name "-" version ".tar.xz"))
|
||||
(patches (search-patches "libvisio-fix-tests.patch"))
|
||||
(sha256 (base32
|
||||
"132szijxm95ibzq5qqaylifbf6wa81g08jxggnwv22v60dwhc2j3"))))
|
||||
"1yahpfl13qk6178irv8jn5ppxdn7isafqisyqsdw0lqxcz9h447y"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
`(("cppunit" ,cppunit)
|
||||
|
|
|
@ -1,35 +0,0 @@
|
|||
Tests assume a CET timezone, but do not respect the "TZ" variable.
|
||||
|
||||
This patch is a "squashed" version of these upstream commits:
|
||||
<https://cgit.freedesktop.org/libreoffice/libvisio/commit/?id=a97d30ad693374deab404ec31fe00665882cc949>
|
||||
<https://cgit.freedesktop.org/libreoffice/libvisio/commit/?id=c933df45a873e566c6ce4e5de5f829e64eb892f5>
|
||||
|
||||
diff --git a/src/test/Makefile.am b/src/test/Makefile.am
|
||||
index 59d3419..23049b5 100644
|
||||
--- a/src/test/Makefile.am
|
||||
+++ b/src/test/Makefile.am
|
||||
@@ -29,4 +29,7 @@ EXTRA_DIST = \
|
||||
data/dwg.vsdx \
|
||||
$(test_SOURCES)
|
||||
|
||||
+# ImportTest::testVsdMetadataTitleUtf8 checks formatted date string
|
||||
+AM_TESTS_ENVIRONMENT = TZ=UTC; export TZ;
|
||||
+
|
||||
TESTS = test
|
||||
diff --git a/src/test/importtest.cpp b/src/test/importtest.cpp
|
||||
index e05b3c1..32fb185 100644
|
||||
--- a/src/test/importtest.cpp
|
||||
+++ b/src/test/importtest.cpp
|
||||
@@ -242,8 +242,8 @@ void ImportTest::testVsdMetadataTitleUtf8()
|
||||
// Test the case when the string is UTF-8 encoded already in the file.
|
||||
assertXPath(m_doc, "/document/setDocumentMetaData", "title", "mytitle\xC3\xA9\xC3\xA1\xC5\x91\xC5\xB1");
|
||||
// Test <dcterms:created> and <dcterms:modified>.
|
||||
- assertXPath(m_doc, "/document/setDocumentMetaData", "creation-date", "2014-11-26T09:24:56Z");
|
||||
- assertXPath(m_doc, "/document/setDocumentMetaData", "date", "2014-11-26T09:24:56Z");
|
||||
+ assertXPath(m_doc, "/document/setDocumentMetaData", "creation-date", "2014-11-26T08:24:56Z");
|
||||
+ assertXPath(m_doc, "/document/setDocumentMetaData", "date", "2014-11-26T08:24:56Z");
|
||||
}
|
||||
|
||||
void ImportTest::testVsdUserDefinedMetadata()
|
||||
--
|
||||
2.1.4
|
Loading…
Reference in a new issue