mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 21:38:07 -05:00
gnu: icecat: Update to 68.2.0-guix0-preview2.
* gnu/packages/gnuzilla.scm (%icecat-version): Update. (%icecat-build-id): New variable. (icecat-source): Update gnuzilla repo commit and hash. (icecat)[arguments]: In the custom 'configure' phase, set the MOZ_BUILD_DATE environment variable to the value of %icecat-build-id. * gnu/packages/patches/icecat-gnuzilla-fixes.patch: Remove changes that are now in the upstream repository. Add more pending changes, including disabling the MOZ_SERVICES_HEALTHREPORT and MOZ_BLOCK_PROFILE_DOWNGRADE build flags, fixing a problem that prevented MOZ_DATA_REPORTING from being disabled, and fixes to the branding. * gnu/packages/patches/icecat-makeicecat.patch: Adapt to upstream changes, and changes in icecat-gnuzilla-fixes.patch. Remove a hunk that disabled rewrites to aboutRights.dtd in the l10n directory.
This commit is contained in:
parent
a06193603b
commit
7a1b2ba545
3 changed files with 232 additions and 1168 deletions
|
@ -550,7 +550,8 @@ (define* (computed-origin-method gexp-promise hash-algo hash
|
|||
#:system system
|
||||
#:guile-for-build guile)))
|
||||
|
||||
(define %icecat-version "68.2.0-guix0-preview1")
|
||||
(define %icecat-version "68.2.0-guix0-preview2")
|
||||
(define %icecat-build-id "20191028000000") ;must be of the form YYYYMMDDhhmmss
|
||||
|
||||
;; 'icecat-source' is a "computed" origin that generates an IceCat tarball
|
||||
;; from the corresponding upstream Firefox ESR tarball, using the 'makeicecat'
|
||||
|
@ -576,7 +577,7 @@ (define icecat-source
|
|||
|
||||
(upstream-icecat-base-version "68.1.0") ; maybe older than base-version
|
||||
;;(gnuzilla-commit (string-append "v" upstream-icecat-base-version))
|
||||
(gnuzilla-commit "395cc0798600cde44a30abaa3f5d08ce8b68f782")
|
||||
(gnuzilla-commit "aa7ab9483a64c43e77736917dd83841ccc437300")
|
||||
(gnuzilla-source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
|
@ -586,7 +587,7 @@ (define icecat-source
|
|||
(file-name (git-file-name "gnuzilla" upstream-icecat-base-version))
|
||||
(sha256
|
||||
(base32
|
||||
"1ll3j2kpsfp1f9dxy67fay1cidsng02l8a3a23wdjqkxgrg1cf4g"))))
|
||||
"03jygq1zna621y0ba6370cff4v2g9l57g3015y3vxbahnmzn9msa"))))
|
||||
|
||||
(gnuzilla-fixes-patch
|
||||
(local-file (search-patch "icecat-gnuzilla-fixes.patch")))
|
||||
|
@ -1016,6 +1017,7 @@ (define-public icecat
|
|||
(setenv "CONFIG_SHELL" bash)
|
||||
(setenv "AUTOCONF" (which "autoconf")) ; must be autoconf-2.13
|
||||
(setenv "CC" "gcc") ; apparently needed when Stylo is enabled
|
||||
(setenv "MOZ_BUILD_DATE" ,%icecat-build-id) ; avoid timestamp
|
||||
(mkdir "../build")
|
||||
(chdir "../build")
|
||||
(format #t "build directory: ~s~%" (getcwd))
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -25,7 +25,7 @@ index b04c731..06d1f3f 100644
|
|||
-wget -N https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${FFVERSION}esr/source/firefox-${FFVERSION}esr.source.tar.xz.asc
|
||||
-gpg --recv-keys --keyserver keyserver.ubuntu.com 14F26682D0916CDD81E37B6D61B7B526D98F0353
|
||||
-gpg --verify firefox-${FFVERSION}esr.source.tar.xz.asc
|
||||
-echo -n f56f5fa5a4744be0b9acf259cb991254d708a50b9a0a12d1d846ffa5a6c409ac firefox-${FFVERSION}esr.source.tar.xz |sha256sum -c -
|
||||
-echo -n 85f1c2eaf68ebedcbc0b78a342f6d16ef0865dedd426a1bba94b75c85f716f38 firefox-${FFVERSION}esr.source.tar.xz |sha256sum -c -
|
||||
-
|
||||
-echo Extracting Firefox tarball
|
||||
-tar -xf firefox-${FFVERSION}esr.source.tar.xz
|
||||
|
@ -37,7 +37,7 @@ index b04c731..06d1f3f 100644
|
|||
+# wget -N https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${FFVERSION}esr/source/firefox-${FFVERSION}esr.source.tar.xz.asc
|
||||
+# gpg --recv-keys --keyserver keyserver.ubuntu.com 14F26682D0916CDD81E37B6D61B7B526D98F0353
|
||||
+# gpg --verify firefox-${FFVERSION}esr.source.tar.xz.asc
|
||||
+# echo -n f56f5fa5a4744be0b9acf259cb991254d708a50b9a0a12d1d846ffa5a6c409ac firefox-${FFVERSION}esr.source.tar.xz |sha256sum -c -
|
||||
+# echo -n 85f1c2eaf68ebedcbc0b78a342f6d16ef0865dedd426a1bba94b75c85f716f38 firefox-${FFVERSION}esr.source.tar.xz |sha256sum -c -
|
||||
+#
|
||||
+# echo Extracting Firefox tarball
|
||||
+# tar -xf firefox-${FFVERSION}esr.source.tar.xz
|
||||
|
@ -96,24 +96,9 @@ index b04c731..06d1f3f 100644
|
|||
-cd $SOURCEDIR
|
||||
+# cd $SOURCEDIR
|
||||
|
||||
shopt -s nullglob
|
||||
for patch in $DATA/patches/*.patch; do
|
||||
echo Patching with file: $patch
|
||||
@@ -226,10 +226,10 @@ cp $DATA/bookmarks.html.in browser/locales/generic/profile/bookmarks.html.in
|
||||
|
||||
find -wholename '*/brand.dtd' |xargs /bin/sed 's/trademarkInfo.part1.*/trademarkInfo.part1 "">/' -i
|
||||
|
||||
-for STRING in rights.intro-point3-unbranded rights.intro-point4a-unbranded rights.intro-point4b-unbranded rights.intro-point4c-unbranded
|
||||
-do
|
||||
- find -name aboutRights.dtd | xargs sed -i "s/ENTITY $STRING.*/ENTITY $STRING \"\">/"
|
||||
-done
|
||||
+# for STRING in rights.intro-point3-unbranded rights.intro-point4a-unbranded rights.intro-point4b-unbranded rights.intro-point4c-unbranded
|
||||
+# do
|
||||
+# find -name aboutRights.dtd | xargs sed -i "s/ENTITY $STRING.*/ENTITY $STRING \"\">/"
|
||||
+# done
|
||||
|
||||
for STRING in rights-intro-point-2 rights-intro-point-3 rights-intro-point-4 rights-intro-point-5 rights-intro-point-6 rights-webservices rights-safebrowsing
|
||||
do
|
||||
@@ -595,6 +595,6 @@ sed 's/777/755/;' -i toolkit/crashreporter/google-breakpad/Makefile.in
|
||||
@@ -598,6 +598,6 @@ sed 's/777/755/;' -i toolkit/crashreporter/google-breakpad/Makefile.in
|
||||
# Fix CVE-2012-3386
|
||||
/bin/sed 's/chmod a+w/chmod u+w/' -i ./js/src/ctypes/libffi/Makefile.in ./toolkit/crashreporter/google-breakpad/Makefile.in ./toolkit/crashreporter/google-breakpad/src/third_party/glog/Makefile.in || true
|
||||
|
||||
|
|
Loading…
Reference in a new issue