mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-23 19:19:20 -05:00
gnu: Remove opencascade-oce.
This package is unmaintained by upstream, has no dependents and was replaced by opencascade-occt. * gnu/packages/maths.scm (opencascade-oce): Remove variable. * gnu/packages/patches/opencascade-oce-glibc-2.26.patch: Remove file. * gnu/local.mk: Unregister it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
8a0b625a2d
commit
a7e174a458
3 changed files with 1 additions and 119 deletions
|
@ -38,7 +38,7 @@
|
|||
# Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
|
||||
# Copyright © 2020 Martin Becze <mjbecze@riseup.net>
|
||||
# Copyright © 2020 Malte Frank Gerdes <mate.f.gerdes@gmail.com>
|
||||
# Copyright © 2020 Vinicius Monego <monego@posteo.net>
|
||||
# Copyright © 2020, 2023 Vinicius Monego <monego@posteo.net>
|
||||
# Copyright © 2021 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
|
||||
# Copyright © 2021 Greg Hogan <code@greghogan.com>
|
||||
# Copyright © 2021, 2022 Philip McGrath <philip@philipmcgrath.com>
|
||||
|
@ -1601,7 +1601,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/openboardview-use-system-imgui.patch \
|
||||
%D%/packages/patches/openboardview-use-system-utf8.patch \
|
||||
%D%/packages/patches/openbox-python3.patch \
|
||||
%D%/packages/patches/opencascade-oce-glibc-2.26.patch \
|
||||
%D%/packages/patches/openfoam-4.1-cleanup.patch \
|
||||
%D%/packages/patches/openjdk-10-idlj-reproducibility.patch \
|
||||
%D%/packages/patches/openjdk-15-xcursor-no-dynamic.patch \
|
||||
|
|
|
@ -2968,61 +2968,6 @@ (define-public octave
|
|||
#t))))))
|
||||
(synopsis "High-level language for numerical computation (with GUI)")))
|
||||
|
||||
(define-public opencascade-oce
|
||||
(package
|
||||
(name "opencascade-oce")
|
||||
(version "0.17.2")
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://github.com/tpaviot/oce")
|
||||
(commit (string-append "OCE-" version))))
|
||||
(file-name (git-file-name name version))
|
||||
(patches (search-patches "opencascade-oce-glibc-2.26.patch"))
|
||||
(sha256
|
||||
(base32 "0rg5wzkvfmzfl6v2amyryb8dnjad0nn9kyr607wy2gch6rciah69"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
'(#:configure-flags
|
||||
(list "-DOCE_TESTING:BOOL=ON"
|
||||
"-DOCE_USE_TCL_TEST_FRAMEWORK:BOOL=ON"
|
||||
"-DOCE_DRAW:BOOL=ON"
|
||||
(string-append "-DOCE_INSTALL_PREFIX:PATH="
|
||||
(assoc-ref %outputs "out"))
|
||||
"-UCMAKE_INSTALL_RPATH")))
|
||||
(inputs
|
||||
(list freetype
|
||||
glu
|
||||
libxmu
|
||||
mesa
|
||||
tcl
|
||||
tk))
|
||||
(native-inputs
|
||||
`(("python" ,python-wrapper)))
|
||||
(home-page "https://github.com/tpaviot/oce")
|
||||
(synopsis "Libraries for 3D modeling and numerical simulation")
|
||||
(description
|
||||
"Open CASCADE is a set of libraries for the development of applications
|
||||
dealing with 3D CAD data or requiring industrial 3D capabilities. It includes
|
||||
C++ class libraries providing services for 3D surface and solid modeling, CAD
|
||||
data exchange, and visualization. It is used for development of specialized
|
||||
software dealing with 3D models in design (CAD), manufacturing (CAM),
|
||||
numerical simulation (CAE), measurement equipment (CMM), and quality
|
||||
control (CAQ) domains.
|
||||
|
||||
This is the ``Community Edition'' (OCE) of Open CASCADE, which gathers
|
||||
patches, improvements, and experiments contributed by users over the official
|
||||
Open CASCADE library.")
|
||||
(license (list license:lgpl2.1; OCE libraries, with an exception for the
|
||||
; use of header files; see
|
||||
; OCCT_LGPL_EXCEPTION.txt
|
||||
license:public-domain; files
|
||||
; src/Standard/Standard_StdAllocator.hxx and
|
||||
; src/NCollection/NCollection_StdAllocator.hxx
|
||||
license:expat; file src/OpenGl/OpenGl_glext.h
|
||||
license:bsd-3)))); test framework gtest
|
||||
|
||||
(define-public opencascade-occt
|
||||
(package
|
||||
(name "opencascade-occt")
|
||||
|
|
|
@ -1,62 +0,0 @@
|
|||
Fix build with glibc 2.26:
|
||||
|
||||
https://github.com/tpaviot/oce/issues/675
|
||||
|
||||
Patch copied from upstream source repository:
|
||||
|
||||
https://github.com/tpaviot/oce/commit/aa1321e68cc004e3debe38d79ae74581a617c767
|
||||
|
||||
From aa1321e68cc004e3debe38d79ae74581a617c767 Mon Sep 17 00:00:00 2001
|
||||
From: Janus Weil <janus@gcc.gnu.org>
|
||||
Date: Mon, 18 Dec 2017 11:27:55 +0100
|
||||
Subject: [PATCH] fix build errors with glibc 2.26+ due to missing xlocale.h
|
||||
(issue #675)
|
||||
|
||||
* check for the presence of xlocale.h via cmake
|
||||
* remove related logic from Standard_CLocaleSentry.hxx
|
||||
---
|
||||
CMakeLists.txt | 1 +
|
||||
src/Standard/Standard_CLocaleSentry.hxx | 15 ---------------
|
||||
2 files changed, 1 insertion(+), 15 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index b782b4101..50e9500b2 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -616,6 +616,7 @@ if (NOT WIN32)
|
||||
# compilation anywhere in OCE
|
||||
include(CheckIncludeFile)
|
||||
check_include_file(strings.h HAVE_STRINGS_H)
|
||||
+ check_include_file(xlocale.h HAVE_XLOCALE_H)
|
||||
include(CheckIncludeFileCXX)
|
||||
check_include_file_cxx(mm_malloc.h HAVE_MM_MALLOC_H)
|
||||
check_include_file_cxx(atomic.h OCE_HAVE_ATOMIC_H)
|
||||
diff --git a/src/Standard/Standard_CLocaleSentry.hxx b/src/Standard/Standard_CLocaleSentry.hxx
|
||||
index 2b226e7f3..1a4c1dadc 100644
|
||||
--- a/src/Standard/Standard_CLocaleSentry.hxx
|
||||
+++ b/src/Standard/Standard_CLocaleSentry.hxx
|
||||
@@ -20,21 +20,6 @@
|
||||
|
||||
#include <locale.h>
|
||||
|
||||
-#ifndef HAVE_XLOCALE_H
|
||||
- //! "xlocale.h" available in Mac OS X and glibc (Linux) for a long time as an extension
|
||||
- //! and become part of POSIX since '2008.
|
||||
- //! Notice that this is impossible to test (_POSIX_C_SOURCE >= 200809L)
|
||||
- //! since POSIX didn't declared such identifier.
|
||||
- #if defined(__APPLE__)
|
||||
- #define HAVE_XLOCALE_H
|
||||
- #endif
|
||||
-
|
||||
- //! We check _GNU_SOURCE for glibc extensions here and it is always defined by g++ compiler.
|
||||
- #if defined(_GNU_SOURCE) && !defined(__ANDROID__)
|
||||
- #define HAVE_XLOCALE_H
|
||||
- #endif
|
||||
-#endif // ifndef HAVE_LOCALE_H
|
||||
-
|
||||
#ifdef HAVE_XLOCALE_H
|
||||
#include <xlocale.h>
|
||||
#endif
|
||||
--
|
||||
2.15.1
|
||||
|
Loading…
Reference in a new issue