gnu: ddd: Update to 3.4.1.

* gnu/packages/debug.scm (ddd): Update to 3.4.1.
[source](origin): Add new patch to fix build.
[arguments]<#:configure-flags>: Add explicit flag fir freetype
include path.
[native-inputs]: Add bison, flex and perl.
[inputs]: Add freetype, libxaw, and libxft.
* gnu/packages/patches/ddd-build.patch: New file.
* gnu/local.mk: Register new file.

Change-Id: Ic305cc0c7e15d0f0565f2adde514a43497e11f98
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
Andy Tai 2024-09-24 19:26:25 -07:00 committed by Ludovic Courtès
parent 51868735f3
commit c32dcfd09c
No known key found for this signature in database
GPG key ID: 090B11993D9AEBB5
3 changed files with 35 additions and 8 deletions

View file

@ -1133,6 +1133,7 @@ dist_patch_DATA = \
%D%/packages/patches/dbus-c++-gcc-compat.patch \ %D%/packages/patches/dbus-c++-gcc-compat.patch \
%D%/packages/patches/dbus-c++-threading-mutex.patch \ %D%/packages/patches/dbus-c++-threading-mutex.patch \
%D%/packages/patches/dbxfs-remove-sentry-sdk.patch \ %D%/packages/patches/dbxfs-remove-sentry-sdk.patch \
%D%/packages/patches/ddd-build.patch \
%D%/packages/patches/debops-constants-for-external-program-names.patch \ %D%/packages/patches/debops-constants-for-external-program-names.patch \
%D%/packages/patches/debops-debops-defaults-fall-back-to-less.patch \ %D%/packages/patches/debops-debops-defaults-fall-back-to-less.patch \
%D%/packages/patches/dee-vapi.patch \ %D%/packages/patches/dee-vapi.patch \

View file

@ -52,6 +52,7 @@ (define-module (gnu packages debug)
#:use-module (gnu packages code) #:use-module (gnu packages code)
#:use-module (gnu packages compression) #:use-module (gnu packages compression)
#:use-module (gnu packages flex) #:use-module (gnu packages flex)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gcc) #:use-module (gnu packages gcc)
#:use-module (gnu packages gdb) #:use-module (gnu packages gdb)
#:use-module (gnu packages glib) #:use-module (gnu packages glib)
@ -1006,23 +1007,24 @@ (define-public seer-gdb
(define-public ddd (define-public ddd
(package (package
(name "ddd") (name "ddd")
(version "3.4.0") (version "3.4.1")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "mirror://gnu/ddd/ddd-" version ".tar.gz")) (uri (string-append "mirror://gnu/ddd/ddd-" version ".tar.gz"))
(patches (search-patches "ddd-build.patch"))
(sha256 (sha256
(base32 (base32
"03sqsfiri5p130cmmzh2wikg0gisql496rvdhr1qaidh1f5bqk2x")))) "12gfyh139rim49m56lxm36ckdyiiz4n3la3y6ik1aqgrqfk1fxdq"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(arguments (arguments
(list #:tests? #f ;tests require manual intervention (list #:tests? #f ;tests require manual intervention
;; Avoid "friend declaration specifies default arguments and isnt #:configure-flags
;; a definition" errors. #~(list (string-append "--with-freetype-includes="
#:configure-flags #~(list "CXXFLAGS=-fpermissive"))) #$(this-package-input "freetype") "/include/freetype2"))))
(native-inputs (native-inputs
(list pkg-config)) (list pkg-config bison flex perl))
(inputs (inputs
(list motif ncurses gdb)) (list libxaw libxft freetype motif ncurses gdb))
(synopsis "Graphical front-end for GDB and other debuggers") (synopsis "Graphical front-end for GDB and other debuggers")
(description "GNU DDD, the Data Display Debugger, is a graphical front-end (description "GNU DDD, the Data Display Debugger, is a graphical front-end
for command-line debuggers. Many back-end debuggers are supported, notably for command-line debuggers. Many back-end debuggers are supported, notably

View file

@ -0,0 +1,24 @@
Add missing '-I' flag.
--- old/ddd/Makefile.am (revision 7508)
+++ new/ddd/Makefile.am (working copy)
@@ -655,7 +655,7 @@
LIBXFT = @XFT_LIBS@ -lfontconfig
# Freetype2 headers
-XFTINCLUDE = @XFT_INCLUDE@
+XFTINCLUDE = -I@XFT_INCLUDE@
# X Miscellaneous Utilities needed for Athena and Motif >= 2.0 (lXmu)
LIBXMU = @XMU_LIBS@
--- old/ddd/Makefile.in (revision 7508)
+++ new/ddd/Makefile.in (working copy)
@@ -1307,7 +1307,7 @@
LIBXFT = @XFT_LIBS@ -lfontconfig
# Freetype2 headers
-XFTINCLUDE = @XFT_INCLUDE@
+XFTINCLUDE = -I@XFT_INCLUDE@
# X Miscellaneous Utilities needed for Athena and Motif >= 2.0 (lXmu)
LIBXMU = @XMU_LIBS@