mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: curl: Update to 7.55.1.
* gnu/packages/patches/curl-bounds-check.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/curl.scm (curl): Update to 7.55.1. [replacement]: Remove field. [source]: Use '.xz' tarball. (curl-7.55.0): Remove variable.
This commit is contained in:
parent
efa0ba499e
commit
e0afc09de4
3 changed files with 3 additions and 50 deletions
|
@ -572,7 +572,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/crda-optional-gcrypt.patch \
|
||||
%D%/packages/patches/crossmap-allow-system-pysam.patch \
|
||||
%D%/packages/patches/clucene-contribs-lib.patch \
|
||||
%D%/packages/patches/curl-bounds-check.patch \
|
||||
%D%/packages/patches/cursynth-wave-rand.patch \
|
||||
%D%/packages/patches/cvs-2017-12836.patch \
|
||||
%D%/packages/patches/cyrus-sasl-CVE-2013-4122.patch \
|
||||
|
|
|
@ -42,15 +42,14 @@ (define-module (gnu packages curl)
|
|||
(define-public curl
|
||||
(package
|
||||
(name "curl")
|
||||
(replacement curl-7.55.0)
|
||||
(version "7.54.1")
|
||||
(version "7.55.1")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://curl.haxx.se/download/curl-"
|
||||
version ".tar.lzma"))
|
||||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0vnv3cz0s1l5cjby86hm0x6pgzqijmdm97qa9q5px200956z6yib"))))
|
||||
"1dvbcwcar3dv488h9378hy145ma3ws2fwpbr6mgszd7chipcmbry"))))
|
||||
(build-system gnu-build-system)
|
||||
(outputs '("out"
|
||||
"doc")) ;1.2 MiB of man3 pages
|
||||
|
@ -122,29 +121,3 @@ (define-public curl
|
|||
(license (license:non-copyleft "file://COPYING"
|
||||
"See COPYING in the distribution."))
|
||||
(home-page "https://curl.haxx.se/")))
|
||||
|
||||
(define-public curl-7.55.0
|
||||
(package
|
||||
(inherit curl)
|
||||
(version "7.55.0")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://curl.haxx.se/download/curl-"
|
||||
version ".tar.xz"))
|
||||
(patches (search-patches "curl-bounds-check.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"1785vxi0jamiv9d1wr1l45g0fm9ircxdfyfzf7ld8zv0z0i8bmfd"))))
|
||||
(arguments
|
||||
`(,@(substitute-keyword-arguments (package-arguments curl)
|
||||
((#:phases phases)
|
||||
`(modify-phases ,phases
|
||||
(add-before 'install 'fix-Makefile
|
||||
;; Fix a regression in 7.55.0 where docs are not installed.
|
||||
;; https://github.com/curl/curl/commit/a7bbbb7c368c6096802007f61f19a02e9d75285b
|
||||
(lambda _
|
||||
(substitute* "Makefile"
|
||||
(("install-data-hook:\n")
|
||||
"install-data-hook:\n\tcd docs/libcurl && $(MAKE) install\n"))
|
||||
#t)))))))))
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
Fix test failure on some 32-bit platforms.
|
||||
|
||||
Patch copied from upstream source repository:
|
||||
|
||||
https://github.com/curl/curl/commit/45a560390c4356bcb81d933bbbb229c8ea2acb63
|
||||
|
||||
diff --git a/src/tool_paramhlp.c b/src/tool_paramhlp.c
|
||||
index b9dedc989e..85c5e79a7e 100644
|
||||
--- a/src/tool_paramhlp.c
|
||||
+++ b/src/tool_paramhlp.c
|
||||
@@ -218,7 +218,7 @@ static ParameterError str2double(double *val, const char *str, long max)
|
||||
num = strtod(str, &endptr);
|
||||
if(errno == ERANGE)
|
||||
return PARAM_NUMBER_TOO_LARGE;
|
||||
- if((long)num > max) {
|
||||
+ if(num > max) {
|
||||
/* too large */
|
||||
return PARAM_NUMBER_TOO_LARGE;
|
||||
}
|
Loading…
Reference in a new issue