mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-16 11:55:27 -05:00
eb5f3ea100
* gnu/packages/patches/webkitgtk-icu-65.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/webkit.scm (webkitgtk)[source](patches): New field.
47 lines
1.7 KiB
Diff
47 lines
1.7 KiB
Diff
Fix build with ICU 65.
|
|
|
|
Taken from upstream:
|
|
https://bugs.webkit.org/show_bug.cgi?id=202600
|
|
https://trac.webkit.org/r250747
|
|
|
|
diff --git a/Source/WTF/wtf/URLHelpers.cpp b/Source/WTF/wtf/URLHelpers.cpp
|
|
index 18e7f13cd615..c584f1a0cb7e 100644
|
|
--- a/Source/WTF/wtf/URLHelpers.cpp
|
|
+++ b/Source/WTF/wtf/URLHelpers.cpp
|
|
@@ -301,7 +301,7 @@ static bool allCharactersInIDNScriptWhiteList(const UChar* buffer, int32_t lengt
|
|
Optional<UChar32> previousCodePoint;
|
|
while (i < length) {
|
|
UChar32 c;
|
|
- U16_NEXT(buffer, i, length, c)
|
|
+ U16_NEXT(buffer, i, length, c);
|
|
UErrorCode error = U_ZERO_ERROR;
|
|
UScriptCode script = uscript_getScript(c, &error);
|
|
if (error != U_ZERO_ERROR) {
|
|
diff --git a/Source/WebCore/dom/Document.cpp b/Source/WebCore/dom/Document.cpp
|
|
index 2443e24c9bc4..1fbb3a716006 100644
|
|
--- a/Source/WebCore/dom/Document.cpp
|
|
+++ b/Source/WebCore/dom/Document.cpp
|
|
@@ -4954,12 +4954,12 @@ static bool isValidNameNonASCII(const UChar* characters, unsigned length)
|
|
unsigned i = 0;
|
|
|
|
UChar32 c;
|
|
- U16_NEXT(characters, i, length, c)
|
|
+ U16_NEXT(characters, i, length, c);
|
|
if (!isValidNameStart(c))
|
|
return false;
|
|
|
|
while (i < length) {
|
|
- U16_NEXT(characters, i, length, c)
|
|
+ U16_NEXT(characters, i, length, c);
|
|
if (!isValidNamePart(c))
|
|
return false;
|
|
}
|
|
@@ -5019,7 +5019,7 @@ ExceptionOr<std::pair<AtomString, AtomString>> Document::parseQualifiedName(cons
|
|
|
|
for (unsigned i = 0; i < length; ) {
|
|
UChar32 c;
|
|
- U16_NEXT(qualifiedName, i, length, c)
|
|
+ U16_NEXT(qualifiedName, i, length, c);
|
|
if (c == ':') {
|
|
if (sawColon)
|
|
return Exception { InvalidCharacterError };
|