mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
b4693f4a58
This fixes a test failure introduced in commit
c527b0ce23
.
* gnu/packages/patches/ghc-testsuite-grep-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/haskell.scm (ghc-8.6, ghc-8.8, ghc-8.10)[native-inputs]: Patch
the 'ghc-testsuite' input.
39 lines
1.4 KiB
Diff
39 lines
1.4 KiB
Diff
Remove stray escapes to avoid warnings from grep 3.8 which breaks
|
|
expected test output.
|
|
|
|
diff --git a/testsuite/tests/hsc2hs/Makefile b/testsuite/tests/hsc2hs/Makefile
|
|
--- a/testsuite/tests/hsc2hs/Makefile
|
|
+++ b/testsuite/tests/hsc2hs/Makefile
|
|
@@ -47,5 +47,5 @@ T12504:
|
|
ifeq "$(WINDOWS)" "YES"
|
|
grep '{-# LINE 1 \"T12504\\\\path\\\\to\\\\$@\.hsc\" #-}' T12504/path/to/$@.hs
|
|
else
|
|
- grep '{-# LINE 1 \"T12504/path/to/$@\.hsc\" #-}' T12504/path/to/$@.hs
|
|
+ grep '{-# LINE 1 "T12504/path/to/$@\.hsc" #-}' T12504/path/to/$@.hs
|
|
endif
|
|
diff --git a/testsuite/tests/numeric/should_run/T7014.primops b/testsuite/tests/numeric/should_run/T7014.primops
|
|
--- a/testsuite/tests/numeric/should_run/T7014.primops
|
|
+++ b/testsuite/tests/numeric/should_run/T7014.primops
|
|
@@ -1,8 +1,8 @@
|
|
and#
|
|
or#
|
|
uncheckedShift.*#
|
|
-\+#
|
|
-\-#
|
|
++#
|
|
+-#
|
|
\*#
|
|
quotInt#
|
|
remInt#
|
|
diff --git a/testsuite/tests/simplCore/should_compile/Makefile b/testsuite/tests/simplCore/should_compile/Makefile
|
|
--- a/testsuite/tests/simplCore/should_compile/Makefile
|
|
+++ b/testsuite/tests/simplCore/should_compile/Makefile
|
|
@@ -226,7 +226,7 @@ str-rules:
|
|
# g should have been collapsed into one defininition by CSE.
|
|
.PHONY: T13340
|
|
T13340:
|
|
- '$(TEST_HC)' $(TEST_HC_OPTS) -c -O T13340.hs -ddump-simpl -dsuppress-all | grep -c '\+#'
|
|
+ '$(TEST_HC)' $(TEST_HC_OPTS) -c -O T13340.hs -ddump-simpl -dsuppress-all | grep -c '+#'
|
|
|
|
|
|
# We expect to see all dictionaries specialized away.
|