mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
4719b71572
These patches were originally found at the debian mingw-w64 team's mingw-w64 repo, and should improve the reproducibility of our mingw-w64 toolchain. * gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch: New file. * gnu/packages/patches/mingw-w64-reproducible-gendef.patch: New file. * gnu/local.mk (dist_patch_DATA): Update accordingly. * gnu/packages/mingw.scm (make-mingw-w64): Apply patches.
26 lines
956 B
Diff
26 lines
956 B
Diff
This following patch was originally found at the debian mingw-w64 team's
|
|
mingw-w64 repo located here:
|
|
https://salsa.debian.org/mingw-w64-team/mingw-w64.git
|
|
|
|
Invoke the following in the aforementioned repo to see the original patch:
|
|
|
|
$ git show 4974e2c:debian/patches/dlltool-temp-prefix.patch
|
|
|
|
Description: Specify dlltool's temp prefix
|
|
Author: Stephen Kitt <steve@sk2.org>
|
|
|
|
By default dlltool uses its pid for the object files it generates.
|
|
Enforcing its temp prefix allows the files it generates to be
|
|
reproducible.
|
|
|
|
--- a/mingw-w64-crt/Makefile.am
|
|
+++ b/mingw-w64-crt/Makefile.am
|
|
@@ -36,7 +36,7 @@
|
|
DTDEF32=$(GENLIB) $(DLLTOOLFLAGS32) $(AM_DLLTOOLFLAGS)
|
|
DTDEF64=$(GENLIB) $(DLLTOOLFLAGS64) $(AM_DLLTOOLFLAGS)
|
|
else
|
|
- AM_DLLTOOLFLAGS=-k --as=$(AS) --output-lib $@
|
|
+ AM_DLLTOOLFLAGS=-k --as=$(AS) --output-lib $@ --temp-prefix $$(basename $@ .a)
|
|
DLLTOOLFLAGSARM32=-m arm
|
|
DLLTOOLFLAGSARM64=-m arm64
|
|
DLLTOOLFLAGS32=--as-flags=--32 -m i386
|