mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
37256c02a2
* gnu/packages/patches/netdde-build-fix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/hurd.scm (netdde)[source]: Update to e67c284ac113d939b10b4578334f27dab29d5b08 and use it. [inputs]: Add zlib:static. [arguments]: Remove #true from build phases. In 'build' phase, remove obsolete CFLAGS, and also build static version. In 'install' phase, install them in <out>/hurd. There is no check target, so set #:tests? to #false. Signed-off-by: Josselin Poiret <dev@jpoiret.xyz>
28 lines
722 B
Diff
28 lines
722 B
Diff
Upstream status: Presented upstream.
|
|
|
|
https://lists.gnu.org/archive/html/bug-hurd/2023-05//msg00449.html
|
|
|
|
From b0a7e4f2706bea8d1c80d5af7a095941f9635033 Mon Sep 17 00:00:00 2001
|
|
From: Janneke Nieuwenhuizen <janneke@gnu.org>
|
|
Date: Fri, 26 May 2023 17:39:17 +0200
|
|
Subject: [PATCH] Update for .../rumpdisk: Fix race condition in bootstrap
|
|
|
|
---
|
|
machdev.c | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/machdev.c b/machdev.c
|
|
index dda5eb8ba..1a6811072 100644
|
|
--- a/machdev.c
|
|
+++ b/machdev.c
|
|
@@ -18,5 +18,6 @@ void machdev_run1 (void *arg)
|
|
|
|
void machdev_run2(void)
|
|
{
|
|
- machdev_trivfs_server(bootstrap);
|
|
+ machdev_trivfs_server_startup(bootstrap);
|
|
+ machdev_trivfs_server_loop(NULL);
|
|
}
|
|
--
|
|
2.40.1
|
|
|